AQUASIM 2.0 - Tutorial

Computer Program for the Identification and Simulation of Aquatic Systems

Peter Reichert

Swiss Federal Institute for Environmental Science and Technology (EAWAG)
CH - 8600 Dübendorf, Switzerland
September 1998
ISBN: 3-906484-17-3
Preface

The original report on AQUASIM (Reichert, 1994) contained a brief tutorial that supported persons in learning to use the program. This tutorial contained examples in which the most important program features were used. Nevertheless, it was not very attractive, because each mouse click was documented, but no explanations to the reasons why the problem was solved in the demonstrated way were given. This was a particularly bad situation because we only rarely offered AQUASIM courses and no support on program usage is given with exception of the maintenance of an electronic user group. For this reason, as a supplement to the new user manual for AQUASIM 2.0 (Reichert, 1998), I decided to create this new, more attractive tutorial. This new tutorial contains additional examples, program handling is illustrated with snapshots of the most important dialog boxes, and comments are given which explain why the problem is solved in this way. I hope that this new tutorial better supports interested persons in learning to use AQUASIM efficiently. It is planned to update this tutorial regularly with major new program releases. For this reason, any comments on errors, omissions, didactical deficiencies, etc. are very welcome. Please send your comments to reichert@eawag.ch.

I would like to thank any persons who gave me comments on errors or deficiencies of draft versions of some of the examples which circulated at EAWAG since last year. Special thanks are to Oskar Wanner and Gerrit Goudsmit who, during the preparation of the AQUASIM course in autumn 1998, checked most of the examples very carefully.

Peter Reichert, September 1998
Contents

1 Introduction 1

2 Simulations with Simple Models 5
   → 2.1 Biochemical Processes in a Batch Reactor 6
   → 2.2 Transport and Substance Separation in a Box Network 24

3 Application of Data Analysis Techniques 43
   3.1 Identifiability Analysis with Sensitivity Functions 44
   3.2 Parameter Estimation 54
   3.3 Model Structure Selection 70

4 Numerical Parameters 83
   4.1 Parameters for Discretization in Time 84
   4.2 Parameters for Discretization in Space 96

5 Compartments 111
   5.1 Biofilm Reactor Compartment 112
   5.2 Advective-Diffusive Reactor Compartment 123
   5.3 Soil Column Compartment 129
   5.4 River Section Compartment 143
   5.5 Lake Compartment 160
      5.5.1 Transport of Dissolved Substances 160
      5.5.2 Particulate Substances and Sediment 169
      5.5.3 Turbulence Modelling 186

6 Batch Processing 207
   6.1 Execution of AQUASIM Jobs in Batch Mode 208
   6.2 Use AQUASIM with other programs 210
Chapter 1

Introduction

This tutorial contains a set of problems which can be solved with AQUASIM. For each problem, a brief problem description is followed by a detailed discussion of its solution. It is recommended, while following the solutions, to check the meaning of the important user definitions in the user manual (Reichert, 1998). All problems together cover the most important features of AQUASIM. Table 1.1 (page 3) gives an overview over which features are used (x) and which are discussed (X) in the solution of which problem. The overview given in Table 1.1 may be used to make a personal selection of the problems to be studied. A problem is recommended to be studied by program users who are familiar with the features used (x) and interested to learn the features discussed (X) in this problem. Copies of all files which are created in the tutorial examples are also delivered with AQUASIM.

A general guideline for the selection of problems to be studied by users not yet familiar with AQUASIM can be given as follows:

In the problems of chapter 2 the most essential features for simulating simple systems consisting of mixed reactors are discussed. Because the execution of simulations and the plot of results is only discussed in detail in these two problems, these problems must be studied by any AQUASIM user.

In the problems of chapter 3 the application of the data analysis techniques of AQUASIM are discussed. These are extremely important features of AQUASIM and the flexibility of AQUASIM with respect to the application of these techniques is one of its major advantages in comparison to other simulation programs. For this reason, these problems are strongly recommended to be studied. Nevertheless, for program users which are only interested in obtaining simulation results for their systems, the problems in this chapter can be omitted.

The problems in chapter 4 demonstrate the most important problems that can occur during execution of the numerical solution algorithms. AQUASIM uses very robust algorithms so that numerical problems should only rarely occur. Nevertheless, it is important to know which problems can occur. For this reason, the problems of this section are recommended to be studied by experienced users of AQUASIM.

In all previous chapters, only mixed reactor compartments were used. The problems in chapter 5 demonstrate the use of the more complicated compartments of AQUASIM. In each subsection the application of another compartment is demonstrated. Therefore,
the problems in this chapter can be selected according to the interest in the different types of compartments.

Finally, the problems in chapter 6 demonstrate how to execute long AQUASIM jobs on compute servers and how to use AQUASIM in connection with other programs that provide parameter sets or postprocess results (e.g. for plotting $\chi^2$ surfaces or for executing Monte Carlo simulations). These problems are interesting for advanced AQUASIM users working with large models and computing time intensive jobs and for users who want to calculate results for parameter sets specified externally of AQUASIM.
<table>
<thead>
<tr>
<th>Program feature</th>
<th>2.1</th>
<th>2.2</th>
<th>3.1</th>
<th>3.2</th>
<th>3.3</th>
<th>4.1</th>
<th>4.2</th>
<th>5.1</th>
<th>5.2</th>
<th>5.3</th>
<th>5.4</th>
<th>5.5</th>
<th>6.1</th>
<th>6.2</th>
</tr>
</thead>
<tbody>
<tr>
<td>State variable:</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>dyn. volume</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>dyn. surface</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>equilibrium</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Program variable:</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>calculation number</td>
<td></td>
<td></td>
<td></td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>time</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>zone index</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>others</td>
<td></td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Constant variable</td>
<td>X</td>
<td></td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Real list variable</td>
<td></td>
<td></td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Variable list variable</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Formula variable:</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>values</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>algebraic expression</td>
<td></td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>if-then construct</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Probe variable</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Dynamic process</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Equilibrium process</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Mixed reactor compart.</td>
<td></td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Biofilm reactor compart.</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Adv.-diff. react. compart.</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Soil column compart.</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>River section compart.</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Lake compartment</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Advective link</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Diffusive link</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Simulation</td>
<td></td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Sensitivity analysis</td>
<td></td>
<td></td>
<td></td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Parameter estimation</td>
<td></td>
<td></td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Numerical parameters</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Batch mode</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Print to file</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Plot to screen:</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>calculated values</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>data points</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>error bars</td>
<td></td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>error contributions</td>
<td></td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>sensitivity functions</td>
<td></td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Table 1.1: Overview of which features of AQUASIM are used (x) and which are discussed (X) in which subsection of this tutorial.
CHAPTER 1. INTRODUCTION
Chapter 2

Simulations with Simple Models

In the problems and solutions described in this chapter the most essential features for simulating simple systems consisting of mixed reactors are discussed. The familiarity of the user with the program features discussed in this chapter is required for using AQUASIM and for understanding the solutions to the problems discussed in the other chapters. See Table 1.1 on page 3 for an overview of which AQUASIM features are discussed in which section of this tutorial.

In the problem discussed in section 2.1 the focus is on the formulation of processes and on the execution of simulations and the presentation of results on the screen. Furthermore, the connection of mixed reactors with diffusive links is discussed.

In the problem discussed in section 2.2 the focus is on advective connections of mixed reactors and on substance separation within these connections. As important additional features, program variables and real list variables and output of modeling results on PostScript or ASCII data files are discussed.
2.1 Biochemical Processes in a Batch Reactor

Problem
This example demonstrates how to formulate a simple set of biochemical processes in a batch reactor, how to connect such a reactor diffusively to a second reactor, how to do simulations, and how to plot the results to the screen.

Part A: In a stirred batch reactor with a volume of 10 l a substance $A$ is degraded by a first order process with a rate of

$$\tau_A = k_A C_A$$

and a rate constant of $k_A = 1 \text{ h}^{-1}$ ($\tau_A$ denotes the absolute value of the process rate, $C_A$ denotes the concentration of substance $A$). The initial concentration of substance $A$ is 1 mg/l.

Plot the concentration of substance $A$ in the reactor as a function of time for a time interval of 10 h.

Part B: Substance $A$ is not completely degraded but it is converted to substance $B$ with a fixed stoichiometry of 2:1 (1 mg of substance $A$ is converted to 0.5 mg of substance $B$). Substance $B$ is converted to substance $C$ with the nonlinear transformation rate

$$\tau_B = \frac{r_{\text{max},B} C_B}{K_B + C_B}$$

according to Monod, with a maximum conversion rate of $r_{\text{max},B} = 0.25 \text{ mg/l/h}$ and a half-saturation concentration of $K_B = 0.5 \text{ mg/l}$ ($\tau_B$ denotes the absolute value of the process rate, $C_B$ denotes the concentration of substance $B$). The stoichiometric ratio of this conversion is 1:2 (1 mg of substance $B$ is converted to 2 mg of substance $C$). The initial concentrations of the substances $B$ and $C$ are zero, the process rate and initial concentration of substance $A$ is the same as in part A.

Plot the concentrations of the substances $A$, $B$ and $C$ as functions of time for a time interval of 10 h.

Part C: The water volume of the reactor of 10 l is now in connection to a closed gas volume of additional 10 l. Substances $A$ and $B$ are assumed not to exist in the gas phase but substance $C$ escapes to the gas phase. The non-dimensional Henry coefficient of substance $C$ is given by $H_C = 2$ (the equilibrium concentration of $C$ in the gas phase is twice as large as the concentration in the water phase). The gas exchange coefficient for substance $C$ with respect to concentrations in the water phase is given as $q_{\text{ex},C} = 1 \text{ l/h}$. The initial concentration of the substance $C$ in the gas volume is zero. The initial concentrations of the substances $A$, $B$ and $C$ in the water volume and the process rates of these substances are the same as in part B.

Plot the concentrations of the substances $A$, $B$ and $C$ in the water volume as well as the concentration of substance $C$ in the gas volume as functions of time for a time interval of 30 h. Check your system definitions on the print file.
2.1. BIOCHEMICAL PROCESSES IN A BATCH REACTOR

Solution
Part A
Start the window interface version of AQUASIM or click the command File→New from the main menu bar to remove previously entered data from memory. Then perform the following steps:

- **Definition of variables**
  Click the command Edit→Variables or Edit→System from the main menu bar (the latter command also opens the dialog boxes for editing processes, compartments and links), click the button New in the dialog box Edit Variables and select the variable type State Variable as shown in Fig. 2.1. Now define a state variable $C_A$ for the concentration $C_A$ of the substance $A$ as shown in Fig. 2.2.

![Image of AQUASIM interface]

Figure 2.1: Dialog box for editing variables and selection box of variable type that appears after selecting the button New.

Comment: Note that the unit of a variable is only a comment that helps the program user to specify his or her inputs consistently. The user is responsible that this consistency is guaranteed. AQUASIM only uses the values of the variables and does not convert automatically between different units.

In a batch reactor $C_A$ can equivalently be described by a dynamic volume state variable or by a dynamic surface state variable, because such a reactor has no throughflow. For substances dissolved in the water, however, it is more natural to describe them by dynamic volume state variables. This is more robust against errors if later on a throughflow or an advective or diffusive link is introduced (surface state variables are not transported in such cases).
CHAPTER 2. SIMULATIONS WITH SIMPLE MODELS

Figure 2.2: Definition of the state variable C\textsubscript{A} for the concentration \textit{C}_A.

The default accuracies of 10\textsuperscript{-6} are acceptable because typical concentrations are in the order of 1 in this example (relative accuracies in the range of 10\textsuperscript{-6} to 10\textsuperscript{-4} and absolute accuracies in the range of a fraction of 10\textsuperscript{-6} to 10\textsuperscript{-4} of a typical value are recommended).

Analogously define a formula variable \textit{k}_A for the rate constant \textit{k}_A as shown in Fig. 2.3.

Figure 2.3: Definition of the formula variable \textit{k}_A for the rate constant \textit{k}_A.

Comment: The degradation rate constant \textit{k}_A can alternatively be implemented as a constant variable or as a formula variable. The implementation as a constant variable has the advantage that the value can be estimated by the parameter estimation algorithm and that sensitivity analyses with respect to the variable can be performed. If only simulations are to be performed, the specification of model parameters as formula variables is simpler because no standard deviation and no bounds of the legal interval of values must be specified. If later on a parameter estimation or a sensitivity analysis with respect to \textit{k}_A has to be performed, it is very simple by selecting the variable in the dialog box Edit Variables and clicking the button Edit Type to change the type of the variable \textit{k}_A to a constant variable.

A constant value is the most trivial example of an algebraic expression used in a formula variable. Note that any algebraic expression with addition (+), subtraction (-), multiplication (*), division (/), exponentiation (^), and with many mathematical functions can be used instead (see the user manual for a detailed
2.1. BIOCHEMICAL PROCESSES IN A BATCH REACTOR

description of the formula syntax). All previously defined variables can be used in such an algebraic expression.

Define a formula variable C_A_{ini} with a value of 1 for the initial condition as shown in Fig. 2.4.

![Figure 2.4: Definition of the variable C_A_{ini} for the initial concentration C_A_{ini}](image)

Comment: It is not necessary to introduce the variables k_A and C_A_{ini}, because their values can directly be specified in the rate expression of the dynamic process and as the initial condition for the variable C_A in the definition of the compartment. However, in most cases it is advantageous to introduce rate constants and initial conditions as variables. This increases the clarity of the definitions and makes it easier to use these parameters later on in sensitivity analyses and parameter estimations (the type of a variable can be changed quickly).

Save your system definitions to the file proc_a.aqu by clicking the command File→Save As from the main menu bar and specifying the file name.

Comment: Although program crashes occur very rarely, it is recommended to save system definitions frequently and to create backup copies of AQUASIM system files.

- Definition of process
The process matrix for the degradation process in this simple example is given by (see the user manual for the definition of a process matrix)

<table>
<thead>
<tr>
<th>Name</th>
<th>Substance</th>
<th>Rate</th>
</tr>
</thead>
<tbody>
<tr>
<td>Degradation</td>
<td>C_A</td>
<td>-1</td>
</tr>
<tr>
<td>of A</td>
<td></td>
<td>k_A C_A</td>
</tr>
</tbody>
</table>

Each row of such a process matrix is represented by one dynamic process in AQUASIM (in this case it contains only one process).

Click the command Edit→Processes or Edit→System from the main menu bar (the latter command also opens the dialog boxes for editing variables, compartments and links), click the button New in the dialog box Edit Processes and select the process type Dynamic Process. Now define the degradation process given in the above process matrix as shown in Fig. 2.5. To specify the stoichiometric coefficient click the button Add, select the variable C_A and specify the value of -1.

Comment: Note that the process matrix is not unique. Equivalent process matrices would be
Figure 2.5: Definition of the degradation process of substance A.

<table>
<thead>
<tr>
<th>Name</th>
<th>Substance</th>
<th>Rate</th>
</tr>
</thead>
<tbody>
<tr>
<td>Degradation A</td>
<td>$C_A$</td>
<td>$-k_A C_A$</td>
</tr>
</tbody>
</table>

or

<table>
<thead>
<tr>
<th>Name</th>
<th>Substance</th>
<th>Rate</th>
</tr>
</thead>
<tbody>
<tr>
<td>Degradation A</td>
<td>$C_A$</td>
<td>$-k_A C_A$</td>
</tr>
</tbody>
</table>

However, for rates that do not change their sign, it is usual to make the rate positive and implement the sign in the stoichiometric coefficient. Furthermore, the stoichiometric coefficient of the substance of most interest is set to $-1$ or $+1$, so that the original matrix is of the recommended form.

Save your system definitions by clicking the command **File→Save** from the main menu bar.

- **Definition of compartment**

  Click the command **Edit→Compartments** or **Edit→System** from the main menu bar (the latter command also opens the dialog boxes for editing variables, processes and links), click the button **New** in the dialog box **Edit Compartments** and select the compartment type **Mixed Reactor Compartment**. Now define the compartment **Reactor** describing the batch reactor as shown in Fig. 2.6. The reactor type is selected to be of **constant volume** and the volume is set to $10$ l.

  Comment: For the alternative option of **variable volume**, the outflow would have to be specified in the edit field below the radio buttons. Changes in volume would then be calculated by the program by integration of the differences in inflow (specified under **Input**) and outflow. The program variable **Reactor Volume** can be used to make the outflow depend on the current water level in the reactor (for an explanation of program variables look at Table 1.1 on page 3 to find an appropriate example).

  The consistent unit of the volume is liters, because the concentration was specified
with the unit of mg/l. As mentioned previously, AQUASIM only uses the numbers specified and does not convert units.

In addition to specifying the volume in the dialog box shown in Fig. 2.6, the relevant state variables and processes must be activated and the initial condition and input must be specified. This is done with the four buttons labelled Variables, Processes, Init. Cond., and Input.

To activate the state variable $C_A$ click the button Variables in the dialog box for the definition of the compartment (Fig. 2.6). In the dialog box Select Active State Variables shown in Fig. 2.7, select the variable in the right list box of available variables and click the button Activate (or double-click the variable in the right list box).

Comment: Note that state variables that are not active in a compartment return a value of zero. It is an important feature of AQUASIM that state variables can individually
be activated and inactivated in any compartment. This avoids unnecessary com-
putation of state variables which represent substances that are not present in all
compartments. However, sometimes this also leads to errors because the program
user forgot to activate the relevant state variables (only variables of this type need
to be activated). Similarly to variables, processes can also be selectively activated
or inactivated in each compartment.

The process DegradationA is activated analogously. Click the button Processes in the
dialog box for the definition of the compartment (Fig. 2.6). In the dialog box Select
Active Processes select the process in the right list box of available processes and
click the button Activate (or double-click the process in the right list box).

Finally, to specify the initial condition, click the button Init. Cond. in the dialog
box for the definition of the compartment (Fig. 2.6). Now, click the button Add in the
dialog box Edit Initial Conditions shown in Fig. 2.8, select the variable C_A and
specify the name of the variable C_Aini as the initial condition.

Comment: Note that no input must be specified in this example, because this would be in
contradiction to the definition of a batch reactor. To define throughflow and
substance input fluxes in cases where this is necessary, click the button Input and
give these definitions in the dialog box Edit Input.

Save your system definitions by clicking the command File→Save from the main menu
bar.

• Definition of plot
   Click the command View→Results from the main menu bar and click the button New
   in the dialog box View Results. Now specify the plot definition as shown in Fig. 2.9.
   This plot contains a single curve for the value of the variable C_A. To define the curve
for the variable C_A click the button Add. Then select the variable C_A in the field
Variable of the dialog box Edit Curve Definition (in the present example, C_A is
already selected because it is the first variable of the list). All other entries can be let
at their default values.

Comment: A plot definition can be specified before or after a simulation has been performed.
It only contains the information of which properties of which variables in which
2.1. BIOCHEMICAL PROCESSES IN A BATCH REACTOR

compartment and at which location are to be plotted and which signatures are to be used. After successful completion of a simulation, the plot definition can be used for the generation of the plot based on the data of the simulation. After a repetition of the simulation with changed parameter values, the same plot definition can be used to display a plot for the new simulation. The window containing the old plot is not affected by this procedure.

- **Definition of the simulation**
  To define the simulation click the command Calc→Simulation in the main menu bar. This dialog box Simulation shown in Fig. 2.10 is then used to define calculations and to initialize, start and continue the simulation. Simulations consist of one or more calculations. The buttons Initialize and Start/Continue in this dialog box are inactive unless at least one calculation is defined and is active (as is already the case in Fig. 2.10). Now click the button New in this dialog box. The dialog box shown in Fig. 2.11 appears. Accept the default values of 0 for the Calc. Number and for the Initial Time and the default selection for the Initial State. Write 0.1 in the edit field Step Size and 100 in the edit field Num. of Steps below the list box Output Steps and click Add. This copies these entries to the list box for step sizes and numbers of steps. Finally, select the calculation to be active for simulation. The dialog box Edit Calculation Definition should now look as shown in Fig. 2.11.

  Comment: Note that the step size chosen in the dialog box shown in Fig. 2.11 specifies which states are stored in memory for plotting. 100 steps seem to give a good enough resolution of the plot over the duration of 10 h. The internal step size selected by the integration algorithm depends on the accuracy of the state variables (cf. Fig.
CHAPTER 2. SIMULATIONS WITH SIMPLE MODELS

2.2). One calculation can consist of several series of steps of different size. Each series of a number of steps of constant size is represented by one row in the list box of the dialog box shown in Fig. 2.11. Each calculation has a calculations number. Only calculations that differ in the value of the calculation number can be active simultaneously. The program variable Calculation Number returns the value specified here (for an explanation of program variables look at Table 1.1 on page 3 to find an appropriate example). For this reason, with the aid of this program variable, the model equations can be made to depend on the calculation.

If the steady state option for the initial state is selected, the program tries to find the steady state and uses it as an initial state. Note, however, that not for all systems a steady state exists and that even if it exists, the program may not be able to find it. In the latter case, the steady state can be calculated by relaxation (time integration under constant conditions).

Save your system definitions by clicking the command File→Save from the main menu bar.

Comment: It is always recommended to save the system definitions before starting a simulation, because simulations may require significant computation time and because the cause of a program crash cannot be found without the system file in the version that was used to start the simulation.
2.1. BIOCHEMICAL PROCESSES IN A BATCH REACTOR

Figure 2.11: Dialog box used for defining a calculation.

- Execution of the simulation and presentation of results
  Click Start/Continue in the dialog box Simulation shown in Fig. 2.10 (this dialog box can be opened by clicking the command Calc→Simulation in the main menu bar).
  Comment: Note that if no calculated states exist the button Start/Continue initializes and starts the simulation. If there exist calculated states, this button continues the simulation. So clicking Start/Continue again, leads to a continuation of the simulation to a time of 20 h. In order to repeat the simulation (e.g. with changed parameter values) the button Initialize must be clicked first, followed by clicking Start/Continue.

Now select the plot Conc in the dialog box View Results and then click the button Plot to Screen (the dialog box View Results can be opened by clicking the command View→Results in the main menu bar). Fig. 2.12 shows the resulting plot of the time course of the concentration \( C_A \). The concentration \( C_A \) decreases exponentially from its start value of 1 mg/l.

Save your system definitions by clicking the command File→Save from the main menu bar. Answer No to the question to save calculated states.

Comment: Usually the file size increases unnecessarily when the calculated states are saved, because the states can readily be recalculated (all system definitions are saved). An exception is if you want to be able to plot results immediately after loading the file without performing a simulation. This is only possible if the calculated states have been saved.
CHAPTER 2. SIMULATIONS WITH SIMPLE MODELS

Figure 2.12: Plot of the concentration $C_A$. 
2.1. BIOCHEMICAL PROCESSES IN A BATCH REACTOR

Part B
Continue just after doing part A or load the file saved in part A from within the window interface version of AQUASIM. Then perform the following steps:

- **Definition of variables**
  Define additional state variables \( C_B \) for the concentration \( C_B \) of substance \( B \) and \( C_C \) for the concentration \( C_C \) of substance \( C \) analogously to the definition of \( C_A \) as shown in Fig. 2.2.

  Comment: Instead of clicking the button New in the dialog box Edit Variables and specifying all entries of the new state variable it is possible to select the variable \( C_A \) in the list box of this dialog box and click the button Duplicate. Then only minor changes must be made in order to define the new state variables \( C_B \) and \( C_C \).

  Analogously to the definition of \( C_{Aini} \) shown in Fig. 2.3, define additional formula variables \( r_{max,B} \) and \( K_B \) with values of 0.25 mg/l/h and 0.5 mg/l, respectively, for the process parameters \( r_{max,B} \) and \( K_B \).

- **Definition of processes**
  The extended process matrix for part B is given by (see user manual for the definition of a process matrix)

<table>
<thead>
<tr>
<th>Name</th>
<th>Substance</th>
<th>Rate</th>
</tr>
</thead>
<tbody>
<tr>
<td>Conversion A ( \rightarrow ) B</td>
<td>( C_A )</td>
<td>( C_B )</td>
</tr>
<tr>
<td>Conversion B ( \rightarrow ) C</td>
<td>( C_A )</td>
<td>( C_B )</td>
</tr>
</tbody>
</table>

  The first process in this matrix is an extension of the process defined in part A (not only degradation of the substance \( A \) but conversion of \( A \) to \( B \)), the second process is an additional process. The implementation of the first process is done by editing the degradation process for the substance \( A \) shown in Fig. 2.5 to the form shown in Fig.

![Figure 2.13: Definition of the conversion process of substance \( A \) to \( B \).](image)
2.13. To do this, select the process DegradationA in the dialog box Edit Processes and click the button Edit. Then change the process definitions as shown in Fig. 2.13. Define a second new process according to the above process matrix as shown in Fig. 2.14.

![Edit Dynamic Process](image)

Figure 2.14: Definition of the conversion process of substance B to C.

Comment: Note that equivalent process matrices are given by

<table>
<thead>
<tr>
<th>Name</th>
<th>Substance</th>
<th>Rate</th>
</tr>
</thead>
<tbody>
<tr>
<td>Conversion A → B</td>
<td>2 1</td>
<td>$\frac{1}{2}k_A C_A$</td>
</tr>
<tr>
<td>Conversion B → C</td>
<td>-1 2</td>
<td>$r_{max,B} \frac{C_B}{K_B + C_B}$</td>
</tr>
</tbody>
</table>

or

<table>
<thead>
<tr>
<th>Name</th>
<th>Substance</th>
<th>Rate</th>
</tr>
</thead>
<tbody>
<tr>
<td>Conversion A → B</td>
<td>2 1</td>
<td>$\frac{1}{2}k_A C_A$</td>
</tr>
<tr>
<td>Conversion B → C</td>
<td>-1 2</td>
<td>$2r_{max,B} \frac{C_B}{K_B + C_B}$</td>
</tr>
</tbody>
</table>

Both of these matrices fulfill the requirements stated in part A. The difference is that the stoichiometric coefficient with the value of one is assigned to a different substance.

Save your system definitions to the file proc.b.aqu by clicking the command File→Save As from the main menu bar and specifying the file name.

- **Definition of compartment**
  Open the dialog box for editing the compartment Reactor defined in part A. Click the button Variables and activate the new state variables C.B and C.C. Click now the button Processes and activate the new process Conversion.BC.
Comment: Initial conditions have not to be specified for the new state variables because the default initial conditions of zero can be used.

- Definition of plot
  Open the dialog box for editing the plot Conc defined in part A. Edit the curve definition for the variable C_A by adding the legend entry C_A. Then add two additional curve definitions for the variables C_B and C_C. In these two curve definitions change the line style and color and add the appropriate legend entry as shown in Fig. 2.15 for the variable C_C.

![Edit Curve Definition dialog box](image)

Figure 2.15: Definition of the curve for the variable C_C.

Comment: The entry Parameter in the curve definition dialog box shown in Fig. 2.15 is inactive because the type of the curve is selected to be the value of the variable and not an error contribution or a sensitivity function of a variable with respect to a parameter. The entry Compartment is inactive because only one compartment is defined. Finally, the entry Zone is inactive because the mixed reactor compartment Reactor consists of only one zone. The default value of the calculation number is zero. The calculation number can be used to hold different calculations simultaneously in the memory and to plot the results of such calculations within the same plot.

Save your system definitions by clicking the command **File→Save** from the main menu bar.
• Execution of the simulation and presentation of results
Repeat now the simulation performed in part A. To do this, click the button Initialize
and then the button Start/Continue in the dialog box shown in Fig. 2.10. Now select
the plot Conc in the dialog box View Results and click the button Plot to Screen.
Fig. 2.16 shows the resulting plot of the time courses of the concentrations $C_A$, $C_B$ and
$C_C$. The concentration $C_A$ decreases exponentially from its start value of 1 mg/l as
it was already the case in part A. The concentration of the intermediate product $C_B$

![Image](image-url)

Figure 2.16: Plot of the concentration $C_A$, $C_B$, and $C_C$.

increases from its start value of zero, comes to a maximum and then decreases again
to zero. The concentration of the end product $C_C$ raises to the start value of 1 mg/l
of substance A because the stoichiometric ratio of 0.5 from $A$ to $B$ and of 2 from $B$ to
$C$ lead to a stoichiometric factor of 1 for the combined reaction from $A$ to $C$.

Save your system definitions by clicking the command File→Save from the main menu
bar. Answer No to the question to save calculated states.
Part C
Continue just after doing part B or load the file saved in part B from within the window interface version of AQUASIM. Then perform the following steps:

- **Definition of variables**
  Define additional formula variables \( H_C \) and \( q_{ex,C} \) with values of 2 and 1 l/h for the gas exchange parameters \( H_C \) and \( q_{ex,C} \) analogously to the definition of \( C_{Aini} \) as shown in Fig. 2.3.

- **Definition of compartments**
  Add an additional mixed reactor compartment GasVolume with a bulk volume of 10 l by clicking the button *New* in the dialog box *Edit Compartments*. Activate the state variable \( C_C \) in this compartment.

- **Definition of links**
  To define the diffusive link, click the command *Edit--Links* or *Edit--System* from the main menu bar (the latter command also opens the dialog boxes for editing variables, processes and compartments). Then click the button *New* in the dialog box *Edit Links* and define the link as shown in Fig. 2.17

![Figure 2.17: Definition of the diffusive link between the reactors.](image)

Comment: With the definition shown in Fig. 2.17 the exchange flux between the compartments is given as \( q_{ex,C}(C_{C, gas}/H_C - C_{C, water}) \) (from the compartment GasVolume to the compartment Reactor). Note that selecting Reactor as compartment 1 and GasVolume as compartment 2 and replacing the Exchange Coefficient by \( q_{ex,C}/H_C \) and the Conversion Factor by \( H_C \) leads to an exchange flux of \( q_{ex,C}(C_{C, water} - H_CC_{C, gas}) \) (from the compartment Reactor to the compartment GasVolume), what is obviously the same as the definition given above (please look at the user manual for the definition of the exchange coefficient and the conversion factor).
• Definition of plot
Open the dialog box for editing the plot Conc defined in part B. Then add an additional curve definition for the variable C.C evaluated in the compartment GasVolume. Add a legend entry and select an appropriate signature. Click the button Scaling and specify the scaling parameters as shown in Fig. 2.18.

![Edit Plot Scaling dialog box](image)

Figure 2.18: Specification of plot scaling.

• Definition of the simulation
Open now the dialog box Simulation shown in Fig. 2.10, select the calculation and click Edit (or double-click the calculation). In the dialog box shown in Fig. 2.11 select the row of the list box with the definition of calculation steps and change the value in the edit field Num. of Steps below the list box from 100 to 300. Now click Replace. Save your system definitions to the file proc.c.aqu by clicking the command File→Save As from the main menu bar and specifying the file name.

• Execution of the simulation and presentation of results
To start now the simulation click the button Initialize and then the button Start/Continue in the dialog box Simulation shown in Fig. 2.10.
Now select the plot Conc in the dialog box View Results and click the button Plot to Screen. Fig. 2.19 shows the resulting plot of the time courses of the concentrations $C_A$, $C_B$ and $C_C$ in the water volume and of the concentration $C_C$ in the gas volume. The concentrations $C_A$ and $C_B$ behave as in part B, but $C_C$ escapes to the gas phase. At the end of the simulation, the concentration $C_C$ in the gas phase is about twice as large as that in the water phase as it is expected from the value of the Henry coefficient. Save your system definitions by clicking the command File→Save from the main menu bar. Answer No to the question to save calculated states.
Now click the command File→Print to File from the main menu bar and specify a file name. All system definitions are now written to this file in text format. This file can be printed directly or it can be opened with any text processing program and can then be printed from this program. This listing is very important in order to check the system definitions. For cases in which this listing is extremely long, a shorter version
Figure 2.19: Plot of the concentration $C_A$, $C_B$ and $C_C$. can be printed by selecting the short file format in the dialog box appearing after clicking the command File→Print Options from the main menu bar.
2.2 Transport and Substance Separation in a Box Network

Problem

This example demonstrates how to describe advective links between mixed reactors, bifurcations and substance separation. In addition it gives an introduction to program variables and real list variables.

Part A: Look at the configuration of mixed reactors and the flow scheme shown in Fig. 2.20.

Implement an AQUASIM system consisting of mixed reactors and advective links that corresponds to this configuration. Define the water flows indicated in the figure, perform a dynamic calculation over 10 h and plot the discharges and the retention times in all four reactors (the retention time \( \tau \) is given as the ratio of volume, \( V \), to discharge, \( Q \): \( \tau = V/Q \)).

Part B: A substance \( A \) flows into the mixed reactor 1 at a concentration as shown in Fig. 2.21: The inflow concentration is 10 mg/l between 0 and 4.9 h, it decreases linearly from 10 mg/l to 0 between 4.9 and 5.1 h, and it remains at 0 after 5.1 h.

Plot the time course of the concentration \( C_A \) of substance \( A \) in all reactors for initial concentrations of zero during a time interval of 10 h.
Part C: A substance $B$ now flows into the reactor 3 with a periodic loading of 100 mg/h during the last quarter of each hour. The substances $A$ and $B$ are converted to a substance $C$ in reactor 2 at a rate of $k_{AB}C_A C_B$ with a rate constant of $k_{AB} = 100 \text{ l/mg/h}$ and with stoichiometric coefficients of $-1$ for $C_A$ and $C_B$ and $+2$ for $C_C$. The substance $C$ is separated in the outlet of reactor 2 (e.g. by settling or filtration) so that it only flows to reactor 4 as shown in Fig. 2.22.

![Figure 2.22: Substance input and transformation for part C.](image)

Extend the AQUASIM system defined in part A and B to the new features described above and plot the time series of all three substances in all reactors. In addition to plotting the results to the screen plot them to a PostScript file and export them in text format for external postprocessing.
CHAPTER 2. SIMULATIONS WITH SIMPLE MODELS

Solution
Part A
Start the window interface version of AQUASIM or click the command File→New from the main menu bar to remove previously entered data from memory. Then perform the following steps:

- Definition of variables
  Define three formula variables \( Q_{in} \) for the inflow, \( Q_{in} \), to compartment 1 with a value of 10 l/h, \( Q_{rec} \) for the recirculation flow, \( Q_{rec} \), from compartment 2 to compartment 3 with a value of 50 l/h, and \( Q_{out} \) for the flow, \( Q_{out} \), out of compartment 2 that leaves the modelled system with a value of 5 l/h.

  Comment: It is not necessary to define these variables because the numbers given in Fig. 2.20 can be entered directly as inflows and bifurcation flows (as will become clear later). However, in most cases it is recommendable to introduce such auxiliary quantities as variables and use the variables in the inflow and bifurcation definitions, because this makes the system definitions clearer and it facilitates to use these variables for sensitivity analyses and parameter estimations later on (the type of a variable can be changed easily).

  Define two program variables \( Q \) as Discharge and \( V \) as Reactor Volume. As an example Fig. 2.23 shows the definition of the program variable for discharge.

  ![Figure 2.23: Definition of the program variable for discharge.](image)

  Comment: Program variables make quantities used by the program (in this case the discharge and the reactor volume) available for use in model formulations and for plotting.

  Finally, define a formula variable \( \tau \) as the algebraic expression \( V/Q \)

- Definition of compartments and links
  Before starting the implementation of compartments and links it must be clear how the investigated system should be mapped to an AQUASIM configuration. Fig. 2.24 shows how this is done in this example. All four mixed reactors are mapped to mixed reactor compartments of AQUASIM. The connections from reactor 1 to 2, from reactor 2 to 4 and from reactor 3 to 2 are mapped as advective links, the connection from reactor 2 to reactor 3 and the connection that leaves the modelled system from reactor 2 are implemented as bifurcations from the advective link from reactor 2 to 4.

  Comment: Note that the definition of links and bifurcations is not unique. Any of the three connections leaving the reactor 2 could be mapped to an advective link with the other two implemented as bifurcations. Because for each bifurcation a water flow
Figure 2.24: Mapping of the reactor configuration to AQUASIM.

can be specified and the rest of the water flows through the link that contains the bifurcations, with the data available, it seems to be most natural to define the connection from reactor 2 to 4 as the link and the other two as the bifurcations.

Define now four mixed reactor compartments Reactor_1, Reactor_2, Reactor_3 and Reactor_4 with volumes of 10 l, 10 l, 1 l and 10 l, respectively. For the compartment Reactor_1 define Qin as the water inflow (click the button Input in the dialog box for the definition of the compartment and write the expression Qin in the edit field labelled Water Inflow).

Define now three advective links Link_12 from the compartment Reactor_1 to the compartment Reactor_2, Linlc32 from the compartment Reactor_3 to the compartment Reactor_2 and Link_24 from the compartment Reactor_2 to the compartment Reactor_4. For the link Link_24 define two bifurcations Rec with a water flow of Qrec to compartment Reactor_3 and Out with a water flow Qout and without an outflow compartment. As an example Fig. 2.25 shows the definition of the link Link_24 and

Figure 2.25: Definition of link from reactor 2 to reactor 4.

Fig. 2.26 shows the definition of the bifurcation Rec.
CHAPTER 2. SIMULATIONS WITH SIMPLE MODELS

• Definition of plots
Define two plots Q and \( \tau \) each of which contains four curves for the discharge Q and the retention time \( \tau \) evaluated in each of the four compartments, respectively.

• Definition of the simulation
Define a calculation of 100 steps of size 0.1 h as described in section 2.1 (Fig. 2.11). Save your system definitions to the file \texttt{flow.a.aqu} by clicking the command File→Save As from the main menu bar and specifying the file name.

• Execution of the simulation and presentation of results
To start the simulation click the button Start/Continue in the dialog box Simulation opened with the command Calc→Simulation. Then use the plot definitions Q and \( \tau \) to plot discharges and retention times. Figure 2.27 shows the plot of the discharges and Fig. 2.28 that for the retention times in all four reactors. As is evident from Fig. 2.20 the discharge is 10 l/h for reactor 1, 60 l/h for reactor 2, 50 l/h for reactor 3, and 5 l/h for reactor 4. The retention times of reactors 2 and 3 are much smaller than those of the reactors 1 and 4.

Save your system definitions by clicking the command File→Save from the main menu bar. Answer No to the question to save calculated states.
Figure 2.27: Plot of discharge in all reactors.
CHAPTER 2. SIMULATIONS WITH SIMPLE MODELS

Figure 2.28: Plot of retention time in all reactors.
Part B
Continue just after doing part A or load the file saved in part A from within the window interface version of AQUASIM. Then perform the following steps:

- **Definition of variables**
  Define a state variable \( C_A \) for the concentration \( C_A \) of substance \( A \) and a program variable \( t \) for time. Then define a real list variable for the input concentration \( C_{A,in} \) as shown in Fig. 2.29. To add the data pairs specify the numbers for argument and value in the edit fields below the list box and then click the button Add.

**Comment:** For values of the argument within the range of arguments of data pairs the value of the real list variable is interpolated or smoothed according to the method selected with the radio buttons in the dialog box shown in Fig. 2.29. For both interpolation techniques, outside of this range the value of the first or last data point is used. For this reason, omission of the first data pair in the dialog box shown in Fig. 2.29 would lead to the same result.

The integration algorithm used by AQUASIM is not able to step over discontinuities of input variables. For this reason, an input concentration that would discontinuously switch from 10 mg/l to zero would result in numerical problems. Such an input must be approximated by an input as used in Fig. 2.29 that switches continuously from one value to another. However, the width of this transient range could be made much smaller.
• Definition of compartments
The variable $C_A$ must now be activated in every compartment. To do this, open the dialog box for the definition of every compartment, click the button Variables, select the variable in the right list box of the dialog box Select Active State Variables and click the button Activate. In addition, as shown in Fig. 2.30, for the compartment Reactor_1, $Q_{in} \cdot C_{Ain}$ must be specified as the input loading for the variable $C_A$. Initial conditions have not to be specified because the default initial condition of zero is correct in this case.

![Edit Input dialog box](image1)

Figure 2.30: Definition of the input to reactor 1.

• Definition of plot
An additional plot $C_A$ must be defined that contains four curves for the variable $C_A$ evaluated in all four compartments.
Save your system definitions to the file `flow.b.aqu` by clicking the command File→Save As from the main menu bar and specifying the file name.

• Execution of the simulation and presentation of results
Redo now the simulation done in part A. To do this, click first the button Initialize and then the button Start/Continue of the dialog box Simulation that can be opened with the command Calc→Simulation. Then select the plot $C_A$ in the dialog box View Results and click the button Plot to Screen. Fig. 2.31 shows the resulting plot. This figure shows how the substance $A$ enters the system and is washed out after its elimination from the input. Because of the very short retention time in the reactors 2 and 3, the concentrations in these reactors cannot be distinguished.

Save your system definitions by clicking the command File→Save from the main menu bar. Answer No to the question to save calculated states.
Figure 2.31: Plot of concentration $C_A$ in all reactors.
Part C
Continue just after doing part B or load the file saved in part B from within the window interface version of AQUASIM. Then perform the following steps:

- **Definition of variables**
  
  Define state variables $C_B$ for the concentration $C_B$ of substance $B$ and $C_C$ for the concentration $C_C$ of substance $C$.
  
  In order to simplify the definition of a periodic input function, define a formula variable $t_{\text{frac}}$ that returns the fraction of an hour. As shown in Fig. 2.32 this can be done by use of the modulo function which returns the rest after integer division. Within each hour this function increases linearly from 0 to 1 and jumps back to 0 at the beginning of the next hour. Now define a real list variable $F_{\text{Bin}}$ for the input loading of substance $B$ into the reactor 3 as shown in Fig. 2.33. Note that the variable $t_{\text{frac}}$ is used here as an argument instead of $t$ as used for the inflow concentration of substance $A$ shown in Fig. 2.29. Because of the definition of $t_{\text{frac}}$ this makes the time course of this variable periodic with period 1 h.

  Comment: Note that the discontinuity of the variable $t_{\text{frac}}$ after each hour may cause a discontinuity of a real list for which this variable is used as an argument. Because the integration algorithm used by AQUASIM has problems to step over discontinuities in input functions or process rates, this must be avoided. In the current context this is most easily avoided by ending the real list with argument $t_{\text{frac}}$ with the same value at the end of the period (in this case at 1) as was the start value at 0.

  Look at the user manual for the functions available in formula variables and for the syntax of algebraic expressions.

  Instead of typing the data pairs in the edit fields below the list box of the dialog box shown in Fig. 2.33 and clicking the button Add, it is possible to read data pairs from a text file. In many cases data may be available in a spreadsheet as shown in Fig. 2.34. In order to make such a file readable by AQUASIM save the spreadsheet in text format. AQUASIM can read data pairs from given rows and columns of a text file. Spaces between numbers (or text), tabs and commas are interpreted as column delimiters by AQUASIM. To read the data click the button Read in the dialog box shown in Fig. 2.33, select the file name and specify the row and column numbers in the dialog box shown in Fig. 2.35. For the data shown in Fig. 2.34 start and end row are 4 and 8 (or zero for end of file), the column number of the argument is 2, and the
column number of the value is 3 as shown in Fig. 2.35 if the spreadsheet is stored with tabs or commas as field delimiters. If the spreadsheet is stored with spaces as field delimiters, the leading empty column cannot be distinguished from leading blanks so that the column number of the argument would be 1, that of the value 2.

Finally, implement the rate constant $K_{AB}$ as a formula variable $k_{AB}$ with a value of 100 l/mg/h.

Save your system definitions to the file `flow.c.aqu` by clicking the command `File→Save As` from the main menu bar and specifying the file name.
CHAPTER 2. SIMULATIONS WITH SIMPLE MODELS

Figure 2.34: Input loading time series on a spreadsheet.

Figure 2.35: Dialog box for reading data pairs from a file.
• Definition of process
Define now the conversion process taking place in reactor 2 as the dynamic process Production_C shown in Fig. 2.36.

![Edit Dynamic Process](image)

Figure 2.36: Definition the process of conversion of A and B to C.

• Definition of compartments
Activate now the state variables C.B and C.C and the process Production_C in the compartment Reactor_2, activate the state variable C.B and define the variable F.Bin as the input loading for C.B in the compartment Reactor_3 as shown in Fig. 2.37, and activate the state variables C.B and C.C in the compartment Reactor_4.

![Edit Input](image)

Figure 2.37: Definition of the input of B to reactor 3.
Comment: The water inflow specified in the dialog box shown in Fig. 2.37 is only the external inflow in addition to the inflow from advective links. Because there is only a substance input without an accompanying water flow, the water inflow in the dialog box shown in Fig. 2.37 is set to zero. Because the substances B and C cannot be present in the compartment Reactor_1, it is not necessary to activate the state variables C.B and C.C in this compartment. Similarly the state variable C.C has not to be activated in the compartment Reactor_3 (not activating these state variables increases the computation speed, because AQUASIM has a smaller number of differential equations to solve).

- **Definition of links**

  The bifurcations Rec and Out of the advective link Link_24 must be modified not to transport the substance C. For the example of the bifurcation Rec it is shown in Fig. 2.38 how this is done. The radio buttons with water flow and as given below of this dialog box are used for the selection of how substance loadings are divided at the bifurcation. The default with water flow leads to a division of substance loadings proportional to water flow as it is typical for dissolved or suspended substances. If the alternative as given below is selected, the substance loadings can be given explicitly in the list box below the radio buttons. As shown in Fig. 2.38 loadings of $Q_{rec} \cdot C.A$ and of $Q_{rec} \cdot C.B$ were specified for the variables C.A and C.B, respectively. No loading is specified for the variable C.C so that the substance C is not transported through the bifurcation.

Comment: Note that the loadings for the substances A and B as specified above are exactly the same as those used by the program with the option with water flow. However, with this option, the loading of substance C would be given as $Q_{rec} \cdot C.C$. Also in the case that only one substance loading must be changed from its default value under the option with water flow, the radio button as given below must be
selected and all nonzero loadings must be specified. For this specification, the program variable \texttt{Discharge} can be used. In the context of a bifurcation of an advective link, this program variable returns the total water inflow to the link.

Define now substance loadings of $Q_{\text{out}} \cdot C_A$ and $Q_{\text{out}} \cdot C_B$ for the variables $C_A$ and $C_B$ in the bifurcation $\text{Out}$ in the same way.

- **Definition of plot**
  
  Add now two additional plot definitions $C_B$ and $C_C$ each containing curves for the concentration of the corresponding substance in all four reactors.

  Comment: This can be done by selecting the plot $C_A$ and then clicking the button \texttt{Duplicate}. The changes from $C_A$ to $C_B$ or $C_C$ need then less editing compared to creating new plot definitions.

  Save your system definitions by clicking the command File $\rightarrow$ Save from the main menu bar.

- **Execution of the simulation and presentation of results**
  
  Redo now the simulation done in parts A and B. To do this, first click the button \texttt{Initialize} and then the button \texttt{Start/Continue} of the dialog box \texttt{Simulation} that can be opened with the command Calc $\rightarrow$ Simulation. Then plot the concentrations of all three substances by selecting the appropriate plot definition and then clicking the button \texttt{Plot to Screen} in the dialog box \texttt{View Results}. The results are shown in the Figs. 2.39, 2.40 and 2.41. The first plot (as compared to Fig. 2.31 without conversion process) shows the consumption of substance $A$ during the intervals in which the substance $B$ is added. The second plot mainly shows the periodic input of substance $B$. The concentration of $B$ increases after 8 hours because then the substance $A$ is consumed and the conversion process of $A$ and $B$ to $C$ does not longer take place. Finally, the last plot shows the increase and decrease of the concentration of the substance $C$.

![Figure 2.39: Plot of concentration $C_A$ in all reactors.](image)
Figure 2.40: Plot of concentration $C_B$ in all reactors.

Now select the first plot definition in the dialog box View Results and click the button Plot to File and specify a file name. Repeat this procedure for the other two plot definitions and specify the same file name. All plots are now plotted to this PostScript file which can be sent to a printer in a way that depends on the hard- and software of the computer in use. A universal way is to load the PostScript file with the shareware program GhostScript and print it using the menu of this program.

Redo the same steps with clicking the button List to File instead of Plot to File and with specifying another file name. This file contains now all data series in text format. It can be loaded by any spreadsheet or plot program for external postprocessing.

Save your system definitions by clicking the command File→Save from the main menu bar. Answer No to the question to save calculated states.
2.2. TRANSPORT AND SUBSTANCE SEPARATION IN A BOX NETWORK

Figure 2.41: Plot of concentration $C_C$ in all reactors.
CHAPTER 2. SIMULATIONS WITH SIMPLE MODELS
Chapter 3

Application of Data Analysis Techniques

The tutorial examples discussed in this chapter are designed to give an introduction to the data analysis techniques of AQUASIM. This is the only chapter where these techniques are discussed. Because of the importance of these techniques it is strongly recommended for any AQUASIM user to study the examples given in this chapter carefully. See Table 1.1 on page 3 for an overview of which AQUASIM features are discussed in which section of this tutorial.

The problem discussed in section 3.1 gives an introduction in the calculation and use of sensitivity functions for identifiability analysis. In addition, constant variables are introduced, which are very important for the whole chapter.

In section 3.2 the most important data analysis features of AQUASIM are discussed: Parameter estimations, sensitivity analyses and error analyses. In addition, the use of variable list variables is discussed. This is also very important, because similar uses are advantageous in many contexts.

The last example in section 3.3 does not introduce new program features, but it demonstrates how AQUASIM can be used to make model structure selections.
3.1 Identifiability Analysis with Sensitivity Functions

Problem

This example demonstrates the usefulness of sensitivity functions in order to assess the identifiability of model parameters.

Part A: In a stirred batch reactor with a volume of 10 l there are three substances A, B and C that interact according to the following process matrix (if you have problems to understand the meaning of a process matrix see the user manual and the example described in section 2.1. In part B of this example exactly the same process matrix was used):

<table>
<thead>
<tr>
<th>Name</th>
<th>Substance</th>
<th>Rate</th>
</tr>
</thead>
<tbody>
<tr>
<td>Conversion A → B</td>
<td></td>
<td>k_A C_A</td>
</tr>
<tr>
<td>Conversion B → C</td>
<td></td>
<td>r_max,B \frac{C_B}{K_B + C_B}</td>
</tr>
</tbody>
</table>

The process parameters are given as \( k_A = 1 \text{ h}^{-1} \), \( r_{max,B} = 0.25 \text{ mg/1/h} \) and \( K_B = 0.5 \text{ mg/l} \). The initial concentration of substance A is \( C_{A,ini} = 1 \text{ mg/l} \), the initial concentrations of the other two substances are zero.

Plot the concentrations of all three substances in the reactor and the sensitivity functions

\[ \delta_{y,p} = p \frac{\partial y}{\partial p} \]

for all concentrations \( y = C_A, C_B \) and \( C_C \) with respect to the parameters \( p = C_{A,ini}, k_A, r_{max,B} \) and \( K_B \) as functions of time for a time interval of 10 h.

Use these sensitivity functions to assess the identifiability of model parameters from measured time series of the concentrations \( C_A, C_B \) and \( C_C \).

Part B: Use the sensitivity functions plotted in part A to determine which of the other parameters must be changed to which value if \( K_B \) is increased by a factor of 2 to \( K_B = 1 \text{ mg/l} \) in order to obtain a similar result as with the previous parameter values. Perform the simulations for the new set of parameters and compare it with the simulation done in part A.
3.1. IDENTIFIABILITY ANALYSIS WITH SENSITIVITY FUNCTIONS

Solution

Part A

Start the window interface version of AQUASIM or click the command File→New from the main menu bar to remove previously entered data from memory. Then perform the following steps:

- **Definition of variables**
  Define the dynamic volume state variables \( C_A, C_B \) and \( C_C \) for the concentrations \( C_A \) of substance \( A \), \( C_B \) of substance \( B \) and \( C_C \) of substance \( C \). Let the accuracies at their default values of \( 10^{-6} \) (recommendations with respect of the values of these accuracies are given in the example described in section 2.1).

Then define four constant variables \( C_{Aini} \) for \( C_{Aini} \) with a value of 1 mg/l, \( k_A \) for \( k_A \) with a value of \( 1 \) h\(^{-1} \), \( r_{max,B} \) for \( r_{max,B} \) with a value of 0.25 mg/l/h, and \( K_B \) for \( K_B \) with a value of 0.5 mg/l. Set the standard deviation of each of these variables to \( 10 \% \) of its value and set the minimum and maximum to zero and 10 times the value. Figure 3.1 shows the definition of \( C_{Aini} \) as an example.

![Figure 3.1: Definition of the constant variable C_Aini.](image)

Comment: The partial derivatives required for the calculation of sensitivity functions are calculated by comparing the results obtained with the original parameter value and those obtained with a parameter value that deviates from the original value by \( 1 \% \) of its standard deviation. In order that this gives reasonable results, this deviation in the parameter must lead to deviations in the results that are small enough that the secant gives a reasonable approximation to the tangent of the solution (negligible nonlinearity of the model response with respect to the parameter) but large enough that the deviation is larger than numerical integration errors. \( 1 \% \) of the standard deviation seems to be a reasonable value to fulfill this criterion. If the standard deviation is unknown, a value must be assumed that fulfills the criterion given above. A standard deviation of \( 10 \% \) of the value leads to a change of \( 0.1 \% \) of the value, what seems to be reasonable if the value is not very close to zero.

- **Definition of processes**
  The two processes \texttt{Conversion AB} and \texttt{Conversion BC} are defined as shown in the Figs. 2.13 and 2.14 of the example discussed in section 2.1.
• Definition of compartment
A mixed reactor compartment with a constant volume of 10 l must be defined as shown in Fig. 2.6. Then the state variables C.A, C.B and C.C and the processes Conversion.AB and Conversion.BC must be activated with the aid of the dialog boxes opened by clicking the buttons Variables and Processes, respectively. Finally, C.Aini must be specified as the initial condition for the state variable C.A with the aid of the dialog box opened by clicking the button Ini. Cond. as shown in Fig. 2.8.

• Definition of plots
Four plot definitions are required in order to plot the results. The first plot Conc contains three curve definitions for the values of the variables C.A, C.B and C.C as shown in Fig. 2.15 for the variable C.C. The three plot definitions SensAR.A, SensAR.B and SensAR.C are used to plot the sensitivity functions of the variables C.A, C.B and C.C with respect to all four model parameters. As an example, the plot definition for the sensitivity functions of the variable C.B is shown in Fig. 3.2. The abscissa is selected to be time and labels for the abscissa and the ordinate are specified. Then four curve definitions of absolute-relative sensitivity functions of C.B with respect to the four parameters are defined. As an example, the curve definition of the absolute-relative sensitivity function of C.B with respect to the parameter k.A is shown in Fig. 3.3.

Comment: If the radio button Sensitivity Function is selected, the four alternatives AbsAbs corresponding to the sensitivity function \( \frac{\delta y}{\delta p} \), RelAbs corresponding to \( \frac{\delta y}{\delta p} = \frac{1}{y} \frac{\delta y}{\delta p} \), AbsRel corresponding to \( \frac{\delta y}{\delta p} = \frac{\delta y}{\delta p} \) and RelRel correspond-
3.1. IDENTIFIABILITY ANALYSIS WITH SENSITIVITY FUNCTIONS

Figure 3.3: Curve definition for sensitivity function of $C_B$ with respect to $K_A$.

Ining to $\delta_{yp}^{y_p} = p/y \partial y/\partial p$ and the field for selecting the Parameter become active (see user manual for a discussion of the meaning of the sensitivity functions). In the current case it is recommended to use the parameter name also as the Legend entry because all curves are sensitivity functions of the same variable (that can be mentioned in the plot title) with respect to different parameters. Different Line Style and Line Color attributes should be used for different curves.

- **Definition of the simulation**
  Define a calculation as shown in Fig. 2.11 with Step Size equal to 0.1 and Num. of Steps equal to 100. In addition to selecting the check box active for simulation also select the check box active for sensitivity analysis. Save your system definitions to the file sens.a.aqu by clicking the command File----1-Save As from the main menu bar and specifying the file name.

- **Execution of the simulation, the sensitivity analysis and presentation of results**
  Click now the button Start/Continue in the dialog box Simulation to execute the simulation. Plot the calculated results to the screen (by selecting the plot Conc and then clicking the button Plot to Screen in the dialog box View Results). Fig. 3.4 shows the resulting time courses of the concentrations $C_A$, $C_B$ and $C_C$. The concentration $C_A$ decreases exponentially from its start value of 1 to zero. The concentration of the
intermediate product $C_B$ increases from its start value of zero, reaches a maximum and then decreases again to zero. The concentration of the end product $C_C$ raises to the start value of 1 mg/l of substance A because the stoichiometric ratio of 0.5 from A to B and of 2 from B to C lead to a stoichiometric factor of 1 for the combined reaction from A to C.

To define and execute a sensitivity analysis click the command Calc→Sensitivity Analysis from the main menu bar. This opens the dialog box shown in Fig. 3.5. A definition of a sensitivity analysis consists of two parts: Active parameters must be selected and one or more calculations must be defined. Selection of active parameters is done with the two upper list boxes in this dialog box. Calculations can be defined by clicking the button New between the two lower list boxes. This action opens the dialog box already discussed in section 2.1 for defining calculations for simulations. Activate now the parameters and calculations shown in Fig. 3.5.

Click now the button Start in the dialog box shown in Fig. 3.5 to execute the sensitivity analysis and specify a file name for the sensitivity ranking results. Now plot the sensitivity functions by selecting each of the three plot definitions SensAR_A, SensAR_B and SensAR_C and clicking the button Plot to Screen. The Figs. 3.6, 3.7 and 3.8 show the result.

It becomes evident from Fig. 3.6 that A is insensitive to the parameters $K_B$ and $r_{max,B}$. This is not astonishing as the first process that only affects the concentration of A is independent of these parameters. The dependence of A on the two parameters $C_{A,ini}$ and $k_A$ is different: The sensitivity of $C_A$ with respect to $C_{A,ini}$ has its maximum at a time of zero and decreases exponentially, while the sensitivity of $C_A$ with respect to $k_A$ increases from zero, reaches a maximum and then decreases again to zero (this is the behaviour of the absolute value of the sensitivity function; the negative sign indicates that $C_A$ decreases with increasing values of $k_A$). This makes these two parameters identifiable from data of the concentration $C_A$. 

Figure 3.4: Time course of the concentrations $C_A$, $C_B$ and $C_C$. 

![Figure 3.4: Time course of the concentrations $C_A$, $C_B$ and $C_C$.](image)
3.1. IDENTIFIABILITY ANALYSIS WITH SENSITIVITY FUNCTIONS

Fig. 3.7 shows that the dependence of $C_B$ on the parameters $C_{A,ini}$ and $k_A$ is different, whereas the dependence of $C_B$ on the other two parameters $K_B$ and $r_{max,B}$ leads to a similar shape of the changes in $C_B$, just with a different sign and magnitude. This means that changes induced by changes in the parameter $K_B$ can be approximately balanced by appropriate changes in the parameter $r_{max,B}$. This makes these two parameters non-identifiable from measured data of $C_B$.

Since the sensitivity functions of $C_C$ shown in Fig. 3.8 lead to the same result (similar behaviour of the sensitivity functions with respect to the parameters $K_B$ and $r_{max,B}$), also measured data of $C_C$ does not solve the identifiability problem of the two parameters $K_B$ and $r_{max,B}$.

The reason of the non-identifiability of the parameters $K_B$ and $r_{max,B}$ is that the concentrations $C_B$ are not much larger than the half-saturation concentration $K_B$. In this concentration range, the conversion rate of $B$ to $C$ can be linearized to $r_{max,B}/K_B$. $C_B$, an expression which makes the non-identifiability of $K_B$ and $r_{max,B}$ evident.

Look also at the file specified after starting the sensitivity analysis. This file contains a ranking of the time integral of the absolute values of the sensitivity functions $\delta_{p,r}$ and of the error contributions of all state variables with respect to all parameters in all compartments (see the user manual for more details).

Save your system definitions by clicking the command File→Save from the main menu bar. Answer No to the question to save calculated states.
Figure 3.6: Time course of the sensitivity functions of $C_A$ with respect to all four parameters.
3.1. IDENTIFIABILITY ANALYSIS WITH SENSITIVITY FUNCTIONS

Figure 3.7: Time course of the sensitivity functions of $C_B$ with respect to all four parameters.
Figure 3.8: Time course of the sensitivity functions of $C_C$ with respect to all four parameters.
Part B
As shown in Fig. 3.7, the sensitivity function of $C_B$ with respect to $K_B$ and $r_{\text{max},B}$ are of similar shape. The maximum of the sensitivity function with respect to $K_B$ has a value of about 0.15 mg/l, the minimum of the sensitivity function with respect to $r_{\text{max},B}$ is about $-0.2$ mg/l. This means that, in linear approximation, a change in $K_B$ can be compensated for by a change in $r_{\text{max},B}$ that is a factor of 0.15/0.2 as large (because the result is more sensitive to $r_{\text{max},B}$, the change in $r_{\text{max},B}$ must be smaller than the change in $K_B$). The signs of the changes in the parameters must be the same because the changes in $C_B$ have a different sign. If $K_B$ is changed by a factor of 2 from 0.5 mg/l to 1 mg/l a change of $r_{\text{max},B}$ by a factor of $2 \cdot 0.15/0.2$, this means from 0.25 mg/l/h to 0.375 mg/l/h would be the appropriate change. Fig. 3.9 shows the simulations performed for these new parameter values. The good correspondence of Fig. 3.9 with Fig. 3.4 demonstrates that

![Figure 3.9: Time course of the concentrations $C_A$, $C_B$ and $C_C$ for changed parameter values.](image)

the calculated concentrations for all substances are not significantly different for these two sets of parameters. This again confirms the non-identifiability of the model parameters $K_B$ and $r_{\text{max},B}$ from concentration time series of the three substances $A$, $B$ and $C$ in the concentration range of this simulation.

Save your system definitions to the file `sens_b.aqu` by clicking the command `File→Save As` from the main menu bar and specifying the file name. Answer No to the question to save calculated states.
3.2 Parameter Estimation

Problem
This example demonstrates how to use AQUASIM for performing parameter estimations for a given model and given measured data. The example starts with a simple problem of the estimation of parameters of rate expressions, it demonstrates how to include initial conditions into the estimation process and it ends with the simultaneous estimation of universal and experiment-specific parameters using the data of several experiments. The identifiability of the parameters is discussed using sensitivity functions and estimated standard errors and correlation coefficients. The approximative calculation of the standard errors of model predictions and of the contributions of different parameters to the total error is also discussed.

Part A: Use the measured time series on the file parest1.dat (Fig. 3.10) of decreasing substrate concentration in a batch reactor with a volume of 10 l to estimate the parameters half-saturation concentration $K$ and maximum conversion rate $r_{\text{max}}$ of a Monod-type degradation process

$$\frac{dC}{dt} = \frac{r_{\text{max}}C}{r_{\text{max}}K + C}$$

Start the calculation with the measured concentration at time zero. The data series on the file parest1.dat is given in the units of hand mg/l (argument and value in the first and second column, respectively, data starting in row 4; see Fig. 3.10). Use a relative standard deviation of 3% and an absolute standard deviation of $0.1 \text{ mg/l}$. Use start values of $K = 2 \text{ mg/l}$ and $r_{\text{max}} = 2 \text{ mg/l/h}$. Compare first a simulation using these parameter values with the measured data, then perform a parameter estimation and compare the simulation based on the estimated model parameter values with the measured data. Try to assess the identifiability of the model parameters with the aid of sensitivity functions and estimated standard errors and correlation coefficients.

Part B: In part A, the measurement inaccuracy of the initial concentration was ignored. In order to apply a more convincing parameter estimation procedure treat now the initial concentration as an additional parameter to be estimated by the program. Check again the sensitivity functions and the estimated standard errors and correlation coefficients for assessing the identifiability of the (extended) set of model parameters. Plot a model prediction with standard errors and the contributions of all model parameters to the total error. Discuss the differences between the absolute-relative sensitivity functions and the error contributions.

Part C: Use the data from a second experiment with the same bacterial population but with a different initial substrate concentration to increase the confidence in the estimated degradation rate parameters. The data series is given on the file parest2.dat in the units h and mg/l (argument and value in the first and second column, respectively, data starting in row 4; see Fig. 3.10). Use a relative standard deviation of 3% and an absolute standard deviation of $0.02 \text{ mg/l}$. Try again to assess the identifiability of the model parameters with the aid of sensitivity functions and estimated standard errors and correlation coefficients.
3.2. PARAMETER ESTIMATION

Figure 3.10: Data sets 1 and 2 used for parameter estimation.
Solution
Part A
Start the window interface version of AQUASIM or click the command File→New from the main menu bar to remove previously entered data from memory. Then perform the following steps:

• **Definition of variables**
  Define a state variable \( C \) for the concentration of the substrate, a program variable \( t \) referring to Time, and two constant variables \( K \) and \( r_{\text{max}} \) for the rate parameters \( K \) and \( r_{\text{max}} \) with values of 2 mg/l and 2 mg/l/h, standard deviations of 0.2 mg/l and 0.2 mg/l/h, minima of 0.01 mg/l and 0.01 mg/l/h and maxima of 10 mg/l and 10 mg/l/h.
  
  Comment: The standard deviations of the constant variables are only used for sensitivity analyses. If a parameter estimation is successful in estimating values and covariance matrix of the parameters, the calculated standard deviation overwrites the value specified here. For this reason, and because in the present example a parameter estimation is performed before executing a sensitivity analysis, the value entered for the standard deviation is irrelevant.

  Define a real list variable \( C_{\text{meas}} \) with the argument \( t \), a relative standard deviation of 0.03 and an absolute standard deviation of 0.1 mg/l and read the data pairs from the file `parest1.dat` (argument and value in the first and second column, respectively, data starting in row 4).

• **Definition of process**
  Define a dynamic process `Degradation` as shown in Fig. 3.11.

![Edit Dynamic Process](image)

Figure 3.11: Definition the process `Degradation`.

• **Definition of compartment**
  Define a mixed reactor compartment `Reactor` with a volume of 10 l, activate the variable \( C \) and the process `Degradation` and define the variable \( C_{\text{meas}} \) to be the initial condition for the variable \( C \).
3.2. PARAMETER ESTIMATION

- **Definition of plots**
  Define two plots Conc and Sens for concentrations and sensitivity functions. In the first plot define two curves for the measured concentration Cmeas (Markers) and for the calculated concentration C (solid line). In the second plot define two curves for the absolute-relative sensitivity functions of C with respect to the parameters K and rmax.

  **Comment:** Usually, the data used for curves in a plot consists of the calculated values of the variable to be plotted at the points of time of simulation output (for plots of time series) or at the spatial grid points of the compartment (for plots of spatial profiles). Lines are straight connections between these points, markers are plotted at any of these points. There is one exception from this general rule: If the variable to be plotted is a real list variable with the program variable Time as its argument (for plots of time series) or with the program variable corresponding to the spatial dimension of the compartment as its argument (for plots of spatial profiles), then the data points of the real list are used instead of the calculated values at points of time of simulation output. This makes it possible to show measured data points together with simulation results in the same plot.

  If for such a real list the interpolated or smoothed values should be plotted, define a formula variable with the name of the real list variable as its algebraic expression and plot this formula variable instead of or in addition to the real list. Then the data points can be compared with the interpolated values.

- **Definition of simulation and parameter estimation**

  ![Image](image.png)

  **Figure 3.12:** Definition of the fit calculation.

  Click the command Calc→Simulation from the main menu bar and define a calculation with 151 steps of 0.1 h. Select this calculation to be active for simulation as well as active for sensitivity analysis. Click now the command Calc→Parameter
Estimation from the main menu bar and click the button New in the dialog box Parameter Estimation. Define the calculation for parameter estimation as shown in Fig. 3.12. To add the fit target, click the button Add, select the data set and specify the variable, compartment, zone and spatial location for the comparison with the data set as shown in Fig. 3.13.

![Edit Fit Target dialog box](image)

Figure 3.13: Definition of the fit target.

Comment: Note that in contrast to the definition of a calculation for simulation and/or sensitivity analysis (cf. Fig. 2.11), the definition of a calculation for parameter estimation shown in Fig. 3.12 does not require the specification of size and number of time steps. This is not necessary, because the comparisons of calculation with measured data takes place at given points in time at which the solution is calculated.

Note that several options in the dialog box Edit Fit Target shown in Fig. 3.13 are inactive. This is a consequence of the fact that the user has no choice if there exists only one real list variable and only one compartment that consists of one zone. The last entry of this dialog box Time/Space has the meaning of a location in the compartment if the variable specified as Data is a time series, it has the meaning of time, if the variable specified as Data is a spatial profile. In the current case, this location is ignored because a mixed reactor compartment does not resolve spatial coordinates.

Save your system definitions to the file `parest_a.aqu` by clicking the command File→Save As from the main menu bar and specifying the file name.

- **Execution of simulation, parameter estimation and sensitivity analysis**

In the dialog box Simulation (opened with Calc→Simulation) click the button Start/Continue. A plot of the simulation results (plot Conc), shown in Fig. 3.14, demonstrates that the choice of the initial parameter values does not lead to a good fit.

In the dialog box Parameter Estimation (opened with Calc→Parameter Estimation), activate the parameters K and rmax, select the Method to be secant and click the button Start to execute the parameter estimation.

Comment: The secant method converges much faster than the simplex method and it calculates estimates for the standard deviations and the correlation matrix in addition to the estimates of the values of the parameters. However, if the start values of the parameters are far from the optimum or in case of important influence of the
3.2. PARAMETER ESTIMATION

Parameter constraints (minima and maxima of the constant variables) the secant algorithm may have problems to converge. In this case it is recommended to use the simplex algorithm first and improve convergence with the secant algorithm later on.

Now you have to specify the name of a file on which more information on the progress of the iterative estimation process and statistical information on the estimates is written. The dialog box shown in Fig. 3.15 summarises the results of the parameter estimation procedure. 19 iterations were required in order to achieve convergence of the parameter estimation algorithm. The value of the parameter $K$ was decreased from 2 to 1.38, that of $r_{max}$ from 2 to 1.15. The deviation between model results and data decreased from 1285 to 14.6. A restart of the parameter estimation process does not improve this result.

Comment: The estimated standard errors and correlations of the parameters are not given in the dialog box shown in Fig. 3.15. This information can be found on the file specified after clicking the Start button of the parameter estimation (the standard errors are also copied to the edit field Std. Dev. of the constant variables used as parameters to be estimated). In the current example, the estimated standard error for $K$ is 0.33 mg/l, that of $r_{max}$ 0.06 mg/l/h.

It is always recommended to restart the algorithm in order to check final convergence. Changing the algorithm between secant and simplex may be helpful for difficult parameter estimations.

To redo the simulation click first the button Initialize in the dialog box Simulation and then the button Start/Continue. Plot now again the concentration as a function of time. As shown in Fig. 3.16 (and expected from the small final value of $\chi^2$), the fit is now much better.

Comment: During parameter estimations output is only calculated at points of time where data points exist. For this reason, plotted results just after execution of a parameter estimation procedure may show a behavior which is not expected.

Figure 3.14: Comparison of simulation with measured data before execution of the parameter estimation procedure.

![Graph showing concentration over time](image-url)
CHAPTER 3. APPLICATION OF DATA ANALYSIS TECHNIQUES

Figure 3.15: Dialog box summarising the results of the parameter estimation procedure.

Parameter estimation is poorly resolved if the data points are not densely distributed over time. In such cases it is recommended to redo the simulation before the results are plotted (this simulation automatically uses the estimated parameter values). This leads then to a plot that uses the temporal resolution defined for the calculation instead of the temporal resolution of the data. In the case of a poor temporal distribution of data points, this leads to better results, if the resolution of the calculation is reasonably defined.

If you use a text editor to look at the file written during parameter estimation, you see that the estimated correlation matrix shows a large correlation of 0.97 between the two parameters. The reason for this high correlation can be seen by looking at the sensitivity functions of $C$ with respect to the two parameters $K$ and $r_{\text{max}}$. In order to be able to plot these sensitivity functions click the command Calc$\rightarrow$Sensitivity Analysis, activate the parameters $K$ and $r_{\text{max}}$, click the button Start to execute the sensitivity analysis, and specify a file name for a ranking of sensitivities. To plot the sensitivity functions select the plot Sens and then click the button Plot to Screen. The plot shown in Fig. 3.17 shows that the sensitivity functions of $C$ with respect to $K$ and $r_{\text{max}}$ are approximately linearly dependent. This means that a change in $C$ caused by a change in one parameter can be compensated by an appropriate change in the other parameter. This behaviour leads to the shape of the $\chi^2$-surface shown in Fig. 3.18 that has a very poorly defined minimum.

Save your system definitions by clicking the command File$\rightarrow$Save from the main menu bar. Answer No to the question to save calculated states.
Figure 3.16: Comparison of simulation with measured data after execution of the parameter estimation procedure.
Figure 3.17: Sensitivity functions of C with respect to K and rmax.
Figure 3.18: log($\chi^2$) surface for Monod-model.
CHAPTER 3. APPLICATION OF DATA ANALYSIS TECHNIQUES

Part B
Continue just after doing part A or load the file saved in part A from within the window interface version of AQUASIM. Then perform the following steps:

- **Modifications of the system definitions**
  Define a constant variable $C_{ini}$ with a value of 12 mg/l, a standard deviation of 1.2 mg/l, a minimum of 0 mg/l and a maximum of 100 mg/l. Activate the check boxes active for sensitivity analysis and active for parameter estimation. Change the initial condition for variable $C$ in the compartment Reactor from $C_{meas}$ to $C_{ini}$ and extend the plot definition Sens to contain a curve for the sensitivity of $C$ with respect to $C_{ini}$. Finally, duplicate the plot definition Sens, change the name to Err, for all curves change the curve type from Sensitivity Function to Error Contribution, and adapt the plot title and the ordinate label.

Save your system definitions to the file `parest_b.aqu` by clicking the command File → Save As from the main menu bar and specifying the file name.

- **Execution of parameter estimation and sensitivity analysis**
  Redo the parameter estimation and the sensitivity analysis. The final value of $\chi^2$ is now 12.1, the correlation between $K$ and $r_{max}$ decreased slightly to 0.95. Figure 3.19 shows the different behaviour of the sensitivity function of $C$ with respect to $C_{ini}$ compared to the two other sensitivity functions. This means that the new parameter $C_{ini}$ is identifiable although there exists an identifiability problem between the parameters $K$ and $r_{max}$.

Comment: Note that the parameter estimation done in part B is much better than that of part A because it considers the inaccuracy of the first measurement at time zero. Although usually only the parameters $K$ and $r_{max}$ are of interest, their estimates can be improved by including the initial condition as an additional parameter to be estimated.

Plot now the calculated values (plot $C_{conc}$). The result is shown in Fig. 3.20.
3.2. PARAMETER ESTIMATION

Figure 3.20: Model prediction with estimated standard error bars.

A sensitivity analysis has been performed, dotted lines indicating deviations by one standard error are now plotted, in addition to the expected result. This standard error of the model prediction is calculated based on the linear error propagation formula with omission of the parameter correlations. A plot of the error contributions shown in Fig. 3.21 (plot Err) shows the contribution of the different model parameters to the total error. By definition, the shapes of the error contributions shown in Fig. 3.21 are the same as those of the sensitivity functions shown in Fig. 3.19. However, the magnitude is different. The results can be interpreted as follows. As shown in Fig. 3.19, the model results are much less sensitive to the parameter $K$ than to the parameter $r_{\text{max}}$. This results in a much larger standard error of the parameter $K$ (the estimated standard error of $K$ is 0.35, that of $r_{\text{max}}$ is 0.09, the values of both parameters are of order unity). For this reason, although the model results are less sensitive to $K$, the error contribution for $K$ is about the same as that for $r_{\text{max}}$.

Save your system definitions by clicking the command File→Save from the main menu bar. Answer No to the question to save calculated states.
Figure 3.21: Error contributions of C with respect to K, rmax and Cini.
Part C
Continue just after doing part B or load the file saved in part B from within the window interface version of AQUASIM. Then perform the following steps:

- **Modification of the system definitions**
  Duplicate the variable Cini and rename the duplicate to Cini1. Repeat this procedure for the variable Cini2. Introduce the program variable calcnum referring to the Calculation Number. Select the variable Cini and then click the button **Edit Type**. Select the type Variable List Variable. Redefine now Cini in the dialog box **Edit Variable List Variable** as shown in Fig. 3.22. This makes the initial condition to depend on the calculation number (note that the argument of the variable list is the calculation number). For a calculation number of 1, the initial condition Cini1 is used, for a calculation number of 2, the initial condition Cini2 is used.

  **Comment:** Note that this approach can also be applied to parameters in transformation processes and not only to initial conditions. This would be meaningful if some of these parameters seem to depend on the experiment.

  Rename now the variable Cmeas to Cmeas1 and introduce an additional real list variable Cmeas2 containing the time series read from the file parest2.dat (argument and value in the first and second column, respectively, data starting in row 4).

  In the **Edit Calculation** dialog box, change the name Calculation to Calculation1 and change its calculation number to 1. Add an additional calculation Calculation2 with a calculation number of 2 and with 100 steps of size 0.1 h.

  Similarly change the calculation number of the existing fit calculation to 1 and add an additional fit calculation with calculation number 2 and with the new variable Cmeas2.
as the fit target to be compared with the calculated values of the variable C.

Finally, change the name of the plot definitions Conc, Sens and Err to Conc1, Sens1 and Err1 and change the calculation numbers of their curves to 1. Use the variable Cin1 as the parameter for describing the effect of the initial concentration. Now duplicate the plot definitions Conc1, Sens1 and Err1 to Conc2, Sens2 and Err2, change the calculation numbers from 1 to 2 and the variable Cin1 to Cin2.

Save your system definitions to the file parest_c.aqu by clicking the command File→Save As from the main menu bar and specifying the file name.

- **Execution of parameter estimation and sensitivity analysis**
  Redo the parameter estimation and the sensitivity analysis. The parameters $K$ and $r_{max}$ are now estimated much more accurately and with a much smaller correlation (The standard error of $K$ decreased from 0.35 to 0.10 mg/l, that of $r_{max}$ remained at 0.09 mg/l/h and the correlation coefficient of these two parameters from 0.95 to 0.85). The cause for this observation is illustrated with the sensitivity function shown in Figs. 3.23 and 3.24. The sensitivity functions of $C$ with respect to $K$ and $r_{max}$ are still approximately linearly dependent for each experiment. However, the changes necessary for one parameter to compensate for the effect of a change in the other parameter are different for the two experiments. For this reason the identifiability of these two parameters is strongly increased if two experiments with different initial concentrations are evaluated simultaneously. This is a typical result which illustrates the important capability of AQUASIM to estimate parameters simultaneously using data from different experiments.

Save your system definitions by clicking the command File→Save from the main menu bar. Answer No to the question to save calculated states.
3.2. PARAMETER ESTIMATION

Figure 3.24: Sensitivity functions of $C$ with respect to $K$, $r_{\text{max}}$ and $C_{\text{ini}}$ for experiment 2.
3.3 Model Structure Selection

Problem:
This example demonstrates the use of AQUASIM for model structure selection. Because the gain in decrease of $\chi^2$ that can be achieved by an increase in model structure complexity is used as a model structure selection criterion, this example provides also a good training in parameter estimation. In addition, due the parallel implementation of different models using calculation numbers, it is also an additional example of the use of calculation numbers.

Part A: Respiration measurement have been performed in a stirred and aerated reactor which has no inflow and in which degradation of a mixture of organic substrates takes place. The question to be answered is whether the substrate mixture can approximatively be described by one (aggregated) state variable with a linear or a Monod type degradation rate or if two different (less aggregated) state variables representing easily and slowly degradable organic matter must be distinguished. The respiration data is shown in Figs. 3.25 and 3.26. It is measured with a standard deviation of 0.1 mg/l/h and is available on the data file msel.dat.

![Respiration Data](image)

Figure 3.25: Respiration data to be used for model structure selection.

An evaluation between the following proposed model structures should be performed:

Model 1:
The degradation process can be described as a first order process of a single state variable $C_1$:

$$\frac{dC_1}{dt} = -\alpha_1 \frac{X}{Y_1} C_1 = -k_1 C_1 = -r_{M_1,1}$$

Model 2:
The degradation process can be described as a process with a single state variable $C_1$ but saturation effects represented by a Monod-type degradation rate...
3.3. **MODEL STRUCTURE SELECTION**

![Figure 3.26: Respiration data to be used for model structure selection.](image)

Two state variables $C_1$ and $C_2$ must be distinguished which represent fast and slowly degradable organic components. The degradation of both components can be described by a first order process, however different rate constants must be considered:

$$\frac{dC_1}{dt} = -\frac{\alpha_1 X}{Y_1} C_1 = -k_1 C_1 = -r_{M_3,1}$$

$$\frac{dC_2}{dt} = -\frac{\alpha_2 X}{Y_2} C_2 = -k_2 C_2 = -r_{M_3,2}$$
CHAPTER 3. APPLICATION OF DATA ANALYSIS TECHNIQUES

Model 4:
Two state variables $C_1$ and $C_2$ must be distinguished which represent fast and slowly degradable organic components. The degradation of one of these components can be described by a first order process, the degradation of the other component must be described with a Monod-type process:

$$\frac{dC_1}{dt} = -\frac{C_1}{Y_1} \frac{C_1}{K_1 + C_1} = -r_{M_4,1}$$

$$\frac{dC_2}{dt} = -\frac{C_2}{K_2 + C_2} = -r_{M_4,2}$$

Model 5:
Two state variables $C_1$ and $C_2$ must be distinguished which represent fast and slowly degradable organic components. The degradation of both components must be described by Monod-type processes with different rate constants:

$$\frac{dC_1}{dt} = -\frac{C_1}{K_1 + C_1} = -r_{M_5,1}$$

$$\frac{dC_2}{dt} = -\frac{C_2}{K_2 + C_2} = -r_{M_5,2}$$

For all models, the oxygen uptake rate $OUR$ which must be compared with the measured data is given as

$$OUR_{M_i} = \sum_{j=1}^{2} (1 - Y_i)r_{M_i,j}$$

where $Y_i$ is the yield of the process $i$.

Use a yield of $Y = 0.67$ (for all substrates) and perform parameter estimations of the initial concentrations of the substrates and the model parameters for all models. Then discuss which model is the most adequate for the description of the data.

Part B: Discuss the dependence of the model structure selection process done in part A on the value of the yield $Y$. Check your result by redoing some of the parameter estimations with a yield of $Y = 0.55$. 
3.3. MODEL STRUCTURE SELECTION

Solution

Part A

In order to evaluate all model structures the models could be implemented one after the other by making appropriate changes to the process rates. This has the disadvantage that it needs considerable editing for switching between model structures. For this reason an alternative approach is described here that requires more effort in the first implementation, but allows very fast switching between model structures once all structures have been implemented. The program variable Calculation Number is used in order to switch between model structures. Because in the current context a simultaneous fit of the different models is not meaningful, any other variable could be used as an indicator of which model should be used. The use of the calculation number makes switching between model structures possible without changing the value of a variable.

Start the window interface version of AQUASIM or click the command File→New from the main menu bar to remove previously entered data from memory. Then perform the following steps:

- **Definition of variables**
  
  Define two dynamic volume state variables \( C_1 \) and \( C_2 \) for the concentrations \( C_1 \) and \( C_2 \) of the organic components.

  Then define the following model parameters as constant variables:

<table>
<thead>
<tr>
<th>Meaning</th>
<th>Name</th>
<th>Unit</th>
<th>Value</th>
<th>Min.</th>
<th>Max.</th>
<th>St.Dev.</th>
</tr>
</thead>
<tbody>
<tr>
<td>( C_{1,ini} ) for model 1</td>
<td>( M1.C1ini )</td>
<td>mg/l</td>
<td>1</td>
<td>0</td>
<td>100</td>
<td>0.1</td>
</tr>
<tr>
<td>( k_1 ) for model 1</td>
<td>( M1.k1 )</td>
<td>1/h</td>
<td>1</td>
<td>0</td>
<td>100</td>
<td>0.1</td>
</tr>
<tr>
<td>( C_{1,ini} ) for model 2</td>
<td>( M2.C1ini )</td>
<td>mg/l</td>
<td>1</td>
<td>0</td>
<td>100</td>
<td>0.1</td>
</tr>
<tr>
<td>( K_1 ) for model 2</td>
<td>( M2.K1 )</td>
<td>mg/l</td>
<td>1</td>
<td>0.1</td>
<td>100</td>
<td>0.1</td>
</tr>
<tr>
<td>( r_{max,1} ) for model 2</td>
<td>( M2.rmax1 )</td>
<td>mg/l/h</td>
<td>1</td>
<td>0</td>
<td>100</td>
<td>0.1</td>
</tr>
<tr>
<td>( C_{1,ini} ) for model 3</td>
<td>( M3.C1ini )</td>
<td>mg/l</td>
<td>1</td>
<td>0</td>
<td>100</td>
<td>0.1</td>
</tr>
<tr>
<td>( k_1 ) for model 3</td>
<td>( M3.k1 )</td>
<td>1/h</td>
<td>1</td>
<td>0</td>
<td>100</td>
<td>0.1</td>
</tr>
<tr>
<td>( k_2 ) for model 3</td>
<td>( M3.k2 )</td>
<td>1/h</td>
<td>1</td>
<td>0</td>
<td>100</td>
<td>0.1</td>
</tr>
<tr>
<td>( C_{1,ini} ) for model 4</td>
<td>( M4.C1ini )</td>
<td>mg/l</td>
<td>1</td>
<td>0</td>
<td>100</td>
<td>0.1</td>
</tr>
<tr>
<td>( C_{2,ini} ) for model 4</td>
<td>( M4.C2ini )</td>
<td>mg/l</td>
<td>1</td>
<td>0</td>
<td>100</td>
<td>0.1</td>
</tr>
<tr>
<td>( k_1 ) for model 4</td>
<td>( M4.k1 )</td>
<td>1/h</td>
<td>1</td>
<td>0</td>
<td>100</td>
<td>0.1</td>
</tr>
<tr>
<td>( K_2 ) for model 4</td>
<td>( M4.K2 )</td>
<td>mg/l</td>
<td>1</td>
<td>0.1</td>
<td>100</td>
<td>0.1</td>
</tr>
<tr>
<td>( r_{max,2} ) for model 4</td>
<td>( M4.rmax2 )</td>
<td>mg/l/h</td>
<td>1</td>
<td>0</td>
<td>100</td>
<td>0.1</td>
</tr>
<tr>
<td>( C_{1,ini} ) for model 5</td>
<td>( M5.C1ini )</td>
<td>mg/l</td>
<td>1</td>
<td>0</td>
<td>100</td>
<td>0.1</td>
</tr>
<tr>
<td>( C_{2,ini} ) for model 5</td>
<td>( M5.C2ini )</td>
<td>mg/l</td>
<td>1</td>
<td>0</td>
<td>100</td>
<td>0.1</td>
</tr>
<tr>
<td>( K_1 ) for model 5</td>
<td>( M5.K1 )</td>
<td>mg/l</td>
<td>1</td>
<td>0.1</td>
<td>100</td>
<td>0.1</td>
</tr>
<tr>
<td>( K_2 ) for model 5</td>
<td>( M5.K2 )</td>
<td>mg/l</td>
<td>1</td>
<td>0.1</td>
<td>100</td>
<td>0.1</td>
</tr>
<tr>
<td>( r_{max,1} ) for model 5</td>
<td>( M5.rmax1 )</td>
<td>mg/l/h</td>
<td>1</td>
<td>0</td>
<td>100</td>
<td>0.1</td>
</tr>
<tr>
<td>( r_{max,2} ) for model 5</td>
<td>( M5.rmax2 )</td>
<td>mg/l/h</td>
<td>1</td>
<td>0</td>
<td>100</td>
<td>0.1</td>
</tr>
</tbody>
</table>

Save your system definitions to the file modsel_a.aqu by clicking the command File→Save As from the main menu bar and specifying the file name.

Define the variable calculation as the program variable Calculation Number and the variable zero as a formula variable with the value 0.

Comment: The variable zero is for use in a variable list variable, where it is not possible to enter the value 0.
CHAPTER 3. APPLICATION OF DATA ANALYSIS TECHNIQUES

The process rates are now defined as formula variables as follows:

<table>
<thead>
<tr>
<th>Meaning</th>
<th>Name</th>
<th>Unit</th>
<th>Expression</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rate for substrate 1 in model 1, $r_{M1,1}$</td>
<td>r1.M1</td>
<td>mg/l/h</td>
<td>$M1_{k1}\times C1$</td>
</tr>
<tr>
<td>Rate for substrate 1 in model 2, $r_{M2,1}$</td>
<td>r1.M2</td>
<td>mg/l/h</td>
<td>$M2_{rmax1}\times C1/(M2_{K1}+C1)$</td>
</tr>
<tr>
<td>Rate for substrate 1 in model 3, $r_{M3,1}$</td>
<td>r1.M3</td>
<td>mg/l/h</td>
<td>$M3_{k1}\times C1$</td>
</tr>
<tr>
<td>Rate for substrate 2 in model 3, $r_{M3,2}$</td>
<td>r2.M3</td>
<td>mg/l/h</td>
<td>$M3_{k2}\times C2$</td>
</tr>
<tr>
<td>Rate for substrate 1 in model 4, $r_{M4,1}$</td>
<td>r1.M4</td>
<td>mg/l/h</td>
<td>$M4_{k1}\times C1$</td>
</tr>
<tr>
<td>Rate for substrate 2 in model 4, $r_{M4,2}$</td>
<td>r2.M4</td>
<td>mg/l/h</td>
<td>$M4_{rmax2}\times C2/(M4_{K2}+C2)$</td>
</tr>
<tr>
<td>Rate for substrate 1 in model 5, $r_{M5,1}$</td>
<td>r1.M5</td>
<td>mg/l/h</td>
<td>$M5_{rmax1}\times C1/(M5_{K1}+C1)$</td>
</tr>
<tr>
<td>Rate for substrate 2 in model 5, $r_{M5,2}$</td>
<td>r2.M5</td>
<td>mg/l/h</td>
<td>$M5_{rmax2}\times C2/(M5_{K2}+C2)$</td>
</tr>
</tbody>
</table>

Save your system definitions by clicking the command File→Save from the main menu bar.

Define the variable $C_{1ini}$ as a variable list variable with the argument calcnum and a list of argument value pairs so that the calculation numbers 1 to 5 correspond to the initial concentrations $M1_{C1ini}$ to $M5_{C1ini}$ as shown in Fig. 3.27. Analogously define the variable $C_{2ini}$ as a variable list variable with the correspondence of the calculation numbers 1, 2, 3, 4 and 5 to the variables zero, zero, $M3_{C2ini}$, $M4_{C2ini}$ and $M5_{C2ini}$.

Analogously define the process rates as variable list variables $r1$ and $r2$ with the argument calcnum and with the correspondence of the calculation numbers 1 to 5 to the rates $r1.M1$ to $r1.M5$, and with the correspondence of the calculation numbers 1, 2,
3.3. MODEL STRUCTURE SELECTION

3, 4 and 5 to the rates zero, zero, \( r_2 \cdot M_3 \), \( r_2 \cdot M_4 \) and \( r_2 \cdot M_5 \), respectively. Figure 3.28 shows the definition of the variable \( r_2 \).

![Image of Variable List Editor](image)

Figure 3.28: Definition of the variable \( r_2 \) as a variable list with the argument calcnum.

Save your system definitions by clicking the command **File** → **Save** from the main menu bar.

Define the variable \( t \) as the program variable time and the formula variable \( Y \) with a value of 0.67 as the yield \( Y \).

Now the calculated oxygen uptake rate can be defined as a formula variable \( \text{resp\_calc} \) with the algebraic expression \((1-Y) \cdot (r_1 + r_2)\) and the measured oxygen uptake rate as a real list variable \( \text{resp\_meas} \) with the argument \( t \), a standard deviation of 0.5 mg/l/h and the 26 data pairs read from the file `meas1.dat`.

Comment: This relatively large set of variables is necessary in order to be able to distinguish the parameters of the different models. This is not in any case necessary, but often recommendable because it allows the user to easily switch back to a model of which the parameters were estimated earlier without the necessity to enter the parameter values obtained from the earlier parameter estimation.

Save your system definitions by clicking the command **File** → **Save** from the main menu bar.

- **Definition of processes**
  Define two dynamic processes \( \text{Degrad1} \) and \( \text{Degrad2} \) with process rates \( r_1 \) and \( r_2 \) and with a single stoichiometric coefficient of \(-1\) for the substrates \( C_1 \) and \( C_2 \), respectively. As an example, Fig. 3.29 shows the definition of the process \( \text{Degrad1} \).

- **Definition of compartment**
  Define a mixed reactor compartment \( \text{reactor} \) with a volume of 1. In this compartment
activate the state variables C1 and C2 and the processes Degrad1 and Degrad2. Finally, specify C1ini and C2ini to be the initial concentrations of C1 and C2, respectively.

- **Definition of plot**
  Define a plot with one curve consisting of markers for the variable resp_meas and five curves with lines of different styles for the variable resp_calc for the calculation numbers 1 to 5.
  
  Comment: The calculation number for the variable resp_meas is irrelevant because in a plot with abscissa time for a real list variable with the program variable Time as the argument, the data pairs of the real list variable are plotted instead of interpolated calculated values (if not desired, this feature can be omitted by plotting a formula variable of which the algebraic expression consists of the name of the real list variable).

  Save your system definitions by clicking the command File→Save from the main menu bar.

- **Definition of simulations and parameter estimations**
  Define five calculations with 250 steps of size 0.02 h and calculation numbers of 1, 2, 3, 4 and 5. Define five parameter estimation calculations Fit1 to Fit5 as shown in Fig. 3.30 for the example of Fit4 with the single fit target of comparing the data stored in the variable resp_meas with the variable resp_calc evaluated in the compartment reactor and with use of the calculation numbers 1 to 5.
  
  Save your system definitions by clicking the command File→Save from the main menu bar.

- **Execution of parameter estimations**
  In the dialog box Parameter Estimation select the parameters M1.C1ini and M1.k1 and the calculation Fit1 to be active. Then click the button Start and specify the name of a fit file for storing details of the parameter estimation. The program finds a final value of $\chi^2$ of about 142.1. A restart of the fit algorithm by clicking the button...
3.3. MODEL STRUCTURE SELECTION

Start again does not improve the fit.

Comment: It is always advisable to restart a fit in order to check if final convergence was obtained. In case of bad convergence of the algorithm this may improve the result.

Figure 3.31 shows the results of this fit. Obviously there are systematic deviations between data and simulation. The sign of the curvature of the simulation is always the same whereas it changes for the data.

Inactivate the parameters and the fit calculation for model 1 and activate the parameters $M2_{C1ini}$, $M2_{K1}$ and $M2_{rmax1}$ and the calculation $Fit2$ for model 2. Performing the parameter estimation leads to a $\chi^2$ value of 67.8 that is slightly improved to 67.3 by restarting the parameter estimation. Figure 3.32 shows the results of this fit. Obviously the fit is significantly improved, however, there are still systematic deviations between measurements and the simulation, especially close to the end of the simulation.

Inactivate the parameters and the fit calculation for model 2 and activate the parameters $M3_{C1ini}$, $M3_{C2ini}$, $M3_{k1}$ and $M3_{k2}$ and the calculation $Fit3$ for model 3. For this model the parameter estimation process converges very badly and the minimum of $\chi^2$ is obtained only after several restarts of the parameter estimation. The solution agrees with the solution of model 1 shown in Fig. 3.31 (the initial condition and the degradation rate of the substrate $C2$ are set to zero). The algorithm obviously cannot distinguish two exponential time scales.

Inactivate the parameters and the fit calculation for model 3 and activate the parameters $M4_{C1ini}$, $M4_{C2ini}$, $M4_{k1}$, $M4_{K2}$ and $M4_{rmax2}$ and the calculation $Fit4$ for model 4. The parameter estimation stops now at a value of $\chi^2$ of 14.0 which is not
improved upon restart of the algorithm. Figure 3.33 shows the results of this fit. There is excellent agreement of the simulation with the data.

Inactivate the parameters and the fit calculation for model 4 and activate the parameters $M_5.C1ini$, $M_5.C2ini$, $M_5.K1$, $M_5.K2$, $M_5.rmax1$ and $M_5.rmax2$ and the calculation Fit5 for model 5. Again, there is very bad convergence and the minimum of $\chi^2$ of 14.0 is achieved only after several restarts of the parameter estimation algorithm. The result cannot be distinguished from that of model 4 shown in Fig. 3.33.

The results can be summarised in the following table:

<table>
<thead>
<tr>
<th>model</th>
<th>no. of parameters</th>
<th>$\chi^2$</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>2</td>
<td>142.1</td>
</tr>
<tr>
<td>2</td>
<td>3</td>
<td>67.3</td>
</tr>
<tr>
<td>3</td>
<td>4</td>
<td>142.1</td>
</tr>
<tr>
<td>4</td>
<td>5</td>
<td>14.0</td>
</tr>
<tr>
<td>5</td>
<td>6</td>
<td>14.0</td>
</tr>
</tbody>
</table>

The model 4 is the first model that does not lead to systematic deviations between model results and data. It is obvious, that the increase in complexity from model 4 to model 5 does not reduce the value of $\chi^2$. For this reason, model 4 seems to be the most adequate model that should be selected.

Save your system definitions by clicking the command File→Save from the main menu bar. Answer No to the question to save calculated states.
Figure 3.32: Comparison of the results of model 2 with the measurements.
Figure 3.33: Comparison of the results of model 4 with the measurements.
Part B
It is obvious that a change in the value of $Y$ only leads to a rescaling of the concentrations $C_i$ (combined with a rescaling or the half-saturation concentrations $K_i$ and of the maximum conversion rates $r_{\text{max},i}$). The values of $\chi^2$ are not affected by this rescaling and therefore the model structure selection process leads to the same results. This can easily be verified by setting the parameter $Y$ in the AQUASIM system file created in part A to a new value and redoing the parameter estimations.
Chapter 4

Numerical Parameters

Although AQUASIM uses the very robust and stiffly stable integration algorithm DASSL (Petzold, 1983), due to the flexibility of the program which allows users to define very complicated models, numerical problems can occur during the time integration process. In this chapter the most important types of numerical problems are shown. The goal of the examples of this chapter is that AQUASIM users can learn a strategy of how to find the cause of numerical problems and how to solve them. For this reason, it is recommended to invest some time for studying the examples of this chapter.

In the example discussed in section 4.1 problems of time integration and related numerical parameters are discussed. This example uses a simple model with a mixed reactor compartment.

In the example discussed in section 4.2 problems of spatial discretization and related numerical parameters are discussed. This example uses an advective-diffusive reactor compartment. The tutorial example for this compartment is given in section 5.2. However, it should be possible to understand the example of section 4.2 without having studied the example in section 5.2 before.
4.1 Parameters for Discretization in Time

Problem
This example demonstrates possible problems of numerical time integration and the meaning of numerical parameters.

Part A: In a stirred reactor with a volume of 1 l and a constant throughflow of \( Q = 1 \) l/h a substance is added to the inflow periodically at a concentration of 100 mg/l during the first 0.01 h of any hour. The initial concentration is zero.

Calculate the concentration in the reactor as a function of time for 10 hours (1000 steps of size 0.01 h) using the default values of all numerical parameters. Plot the concentration time series and try to find out the cause of the wrong result. Then change the appropriate numerical parameter of the integration algorithm, redo the simulation, and plot the correct result.

Part B: Add a relaxation process by starting the simulation 10 hours earlier with one step of 10 hours followed by the simulation calculated above.

Try to find the solution to the numerical problem during calculation.

Part C: Set the water and substance inflows to zero and the initial concentration to 1 mg/l. Then add a degradation process with a rate of

\[ r = k\sqrt{C} \]

where \( C \) is the substance concentration and \( k = 1 \sqrt{\text{mg}/\text{l}/\text{h}} \) is a rate constant.

Redo the simulation of part A (1000 steps of 0.01 h) and try to find the cause of the numerical problem during calculation. Change the process rate to an expression that avoids the problem.
Solution
Part A
Start the window interface version of AQUASIM or click the command File→New from the main menu bar to remove previously entered data from memory. Then perform the following steps:

- **Definition of variables**
  Define a dynamic volume state variable C, a program variable t referring to Time, a formula variable period with a value of 1 h, and a formula variable Qin with a value of 1 l/s. Then define the time within each period as a formula variable $t_{\text{period}}$ as shown in Fig. 4.1. Now define a real list variable Cin as shown in Fig. 4.2.

![Edit Formula Variable](image)

Figure 4.1: Definition of the time in hours within each period.

**Comment:** The modulo function easily allows to define periodic functions as shown in Figs. 4.1 and 4.2 (cf. also part C of the example discussed in section 2.2). First the time within each period is defined as shown in Fig. 4.1. Then this time is used as an argument of a function implemented as a formula variable, a real list variable or a variable list variable (cf. Fig. 4.2). In this way, the function automatically becomes periodic.

Note that the input pulse is approximated by a continuous function the value of which increases and decreases within a time interval of 0.001 h. This is necessary because the integration algorithm has problems to step over discontinuities (if necessary, the time interval for increase and decrease can be made shorter). Note that the value of the real list variable at zero is the same as the value at the end of the period (in this case the value at 0.011 is used for values of the argument larger than 0.011). This is necessary to avoid a discontinuity when the argument $t_{\text{period}}$ discontinuously switches back from the value after one period to zero.

- **Definition of compartment**
  Define now a mixed reactor compartment with the variable C as an active state variable with a water inflow equal to Qin, with a substance input loading for the variable C of $\text{Qin} \times \text{Cin}$ and with a constant volume of 1 (l).

- **Definition of plot**
  Define a plot with abscissa time with a curve for the value of the variable C.

- **Definition of simulation**
  Define an active calculation of 1000 steps of size 0.01 h.

Save your system definitions to the file numtim.aq by clicking the command File→Save As from the main menu bar and specifying the file name.
Execution of simulation and presentation of results

Figure 4.3 shows the results of the simulation. Within the first 0.01 h the concentration in the reactor increases as a consequence of the inflow definition (first pulse). Then the concentration decreases exponentially due to the throughput through the reactor. This behaviour is correct during the first hour. But at the beginning of the second hour, this is no longer correct. The next pulse of the periodic input signal should lead to an increase in concentration similar to the increase at the beginning of the simulation. Similarly all succeeding input pulses are ignored.

What is the cause of this error?

The integration algorithm selects its internal time step according to the accuracy requirements of the calculated concentration. At the beginning of the simulation it starts with a very small time step. It then follows the input pulse and begins to increase the step size during the rest of the first hour, because the exponential decrease in concentration caused by the throughput can be calculated accurately also for relatively large time steps. Because the time step at the end of the first hour is much larger than the pulse width of 0.01 h, the algorithm steps over the pulse. The same happens with all succeeding pulses. If by chance the end of an integration time step would be within an input pulse interval, the algorithm would recognise the problem (because the accuracy criterion fails for such a fast change in input concentration), the algorithm would
4.1. **PARAMETERS FOR DISCRETIZATION IN TIME**

repeat the step by a sequence of smaller steps and it would follow this input pulse accurately. However, in the present example, the chance for catching all input pulses is very small because the integration of the exponential decrease in concentration is very simple and, therefore, makes large integration time steps possible. In order to avoid this problem, the internal step size of the integration algorithm must be limited to a value smaller than the duration of the input pulses. If this is done, at least one input evaluation is done within the pulse interval and therefore, as explained above, the concentration time series of the pulse is followed accurately by the integration algorithm. The internal step size of the integration algorithm can be limited with the aid of the dialog box opened with the **Numerical Parameters** command of the **Edit** menu. If the value of the numerical parameter **Maximum Internal Step Size** in this dialog box is changed from 1 to 0.01 and the simulation is redone, the plot shown in Fig. 4.4 results. This plot shows the correct behaviour of the concentration in the reactor.

Save your system definitions by clicking the command **File→Save** from the main menu bar. Answer **No** to the question to save calculated states.
Figure 4.4: Concentration time series with a value of 0.01 for the numerical parameter Maximum Internal Step Size. All input pulses are considered correctly.
Part B

Continue just after doing part A or load the file saved in part A from within the window interface version of AQUASIM. Then perform the following steps:

- **Modification of the system definitions**
  Open the dialog box Simulation by clicking the command Simulation in the menu Calc. Then open the dialog box Edit Calculation Definition by double-clicking the name of your calculation. Modify the definition as shown in Fig. 4.5. The initial time must be changed to -10. To insert the calculation step from -10 to 0 (no resolution of output during time integration for relaxation) and 1000 steps from 0 to 10 (good resolution of output during the interesting part of the simulation).

![Edit Calculation Definition dialog box](image)

Figure 4.5: Definition of a calculation with one step from -10 to 0 (no resolution of output during time integration for relaxation) and 1000 steps from 0 to 10 (good resolution of output during the interesting part of the simulation).

- **Execution of simulation and presentation of results**
  Now start the simulation. The simulation is interrupted with the message shown in Fig. 4.6. On the log file, the following DASSL error message is printed:
This error message indicates that the calculation was interrupted because the output time was not reached within 1000 steps of the algorithm. This message may be a hint for the presence of numerical problems, because the output resolution is usually not adequate if so many steps are required for a single output step. In the present case, the output step was chosen to be large because the dynamic behaviour during the relaxation phase was not of interest. For this reason, it is no problem if more than 1000 steps are required for one output step and the limit of 1000 steps should be increased. This is done in the dialog box Edit Numerical Parameters which is opened with the command Numerical Parameters in the menu Calc. In this dialog box, increase the value of the parameter Maximum Number of Internal Time Steps for one Output Time Step from 1000 to 10000. If now the simulation is redone, no numerical problem occurs and the result looks as shown in Fig. 4.7. This figure shows the correct result. Because the relaxation phase is done as one output time step, the concentration is linearly interpolated between its values at -10 and at 0 h. Then between 0 and 10 h the dynamics can be followed. By changing the scaling of the plot, the relaxation phase can be eliminated from the plot. However, if the dynamics of relaxation should be followed, more smaller output steps must be taken during relaxation.

Save your system definitions by clicking the command File→Save from the main menu bar. Answer No to the question to save calculated states.
4.1. PARAMETERS FOR DISCRETIZATION IN TIME

Figure 4.7: Concentration time series for relaxation and simulation.
Part C
Continue just after doing part B or load the file saved in part B from within the window interface version of AQUASIM. Then perform the following steps:

- **Modification of the system definitions**
  Define a formula variable $k$ with a value of $1 \sqrt{mg/l}/h$ and a dynamic process degradation with a rate of $k \cdot \sqrt{C}$ and a stoichiometric coefficient of -1 for the variable $C$. Then, in the Edit Mixed Reactor Compartment dialog box, activate the new process, add an initial condition of 1 mg/l for the variable $C$, set the inflow to 0 and delete the input flux for the variable $C$. Delete the relaxation time step of 10 h and set the initial time to 0.

  Save your system definitions to the file `numtim_c.aqu` by clicking the command `File-Save As` from the main menu bar and specifying the file name.

- **Execution of simulation and presentation of results**
  Now start the simulation. The simulation is interrupted with a message of a numerical problem (cf. Fig. 4.6). The simulation result up to the interruption looks as shown in Fig. 4.8. The result looks quite reasonable and gives no direct indication of the problem. The log file of the session contains the following messages:

![Concentration time series](image)

**Figure 4.8**: Concentration time series up to the interruption by the numerical problem.

- 05/25/1998 17:53:29 Integration at time 1.97
- 05/25/1998 17:53:29 Integration at time 1.98
- 05/25/1998 17:53:29 Integration at time 1.99
- FORMVAR numerical problem: illegal value in variable rate_degradation
- FORMVAR numerical problem: illegal value in variable rate_degradation
- FORMVAR numerical problem: illegal value in variable rate_degradation
- FORMVAR numerical problem: illegal value in variable rate_degradation
- 05/25/1998 17:53:29 Integration at time 2
- FORMVAR numerical problem: illegal value in variable rate_degradation
- FORMVAR numerical problem: illegal value in variable rate_degradation
- FORMVAR numerical problem: illegal value in variable rate_degradation
The DASSL error message indicates that the algorithm which calculates the solution after one time step did not converge although the size of the time step was decreased drastically. The cause (IRES equal to -1) is that the AQUASIM-function called by DASSL was not able to calculate the right hand side of the system of differential equations. This cause can closer be localized with the aid of the AQUASIM error messages on an illegal value in the variable rate_degradation. Unfortunately, such a variable does not exist in the list box of the dialog box Edit Variables. Besides the variables entered by the user (and seen in this dialog box) AQUASIM uses additional variables internally. The name of these variables should make clear to which quantity they refer. In the present example, it refers to the edit field Rate of the process degradation. This rate is given as $k\sqrt{C}$. An illegal value of this variable may therefore be caused by an illegal value or a negative value of the concentration $C$. The result plotted in Fig. 4.8 shows that the concentration at the time of the interrupt is very close to zero. In such situations, also for models that would not lead to negative concentrations, numerical inaccuracies may lead to (very small) negative values of the concentration. In the present case, however, the model solution in fact becomes undefined (as a real number) at this point of time. The differential equation solved by AQUASIM is given as

$$\text{Concentration time series}$$

Figure 4.9: Time series of the square root of the absolute value of the concentration up to the interruption by the numerical problem.
The analytical solution of this equation for an initial concentration $C_0$ is

$$\sqrt{C(t)} = \sqrt{C_0 - \frac{kt}{2}}$$

The concentration, $C$, becomes complex for $t > 2\sqrt{C_0}/k$. For this reason, the calculation must run into numerical problems at $t = 2$ h. The problem can clearer be seen if a new formula variable $\text{sqrtC}$ is introduced as $\sqrt{\text{abs}(C)}$. A plot of the value of this variable is shown in Fig. 4.9. It is evident, that the simulation runs into problems at $t = 2$ h.

This problem makes it evident that the process rate $k\sqrt{C}$ is not a good process formulation, at least not for small concentrations. If the process rate $k\sqrt{C}$ is a good description for reasonably large concentrations, the simplest correction to the process rate could be to replace it by a linear process rate for concentrations below a critical concentration $C_{\text{crit}}$. In Fig. 4.10 it is shown how this can be done. Note that the proposed expression

$$r = \begin{cases} 
  k\sqrt{C} & \text{for } C \geq C_{\text{crit}} \\
  k\sqrt{C_{\text{crit}}} \frac{C}{C_{\text{crit}}} & \text{for } C \leq C_{\text{crit}}
\end{cases}$$

leads to equal results as the previous expression for concentrations larger than $C_{\text{crit}}$, is linear for concentrations smaller than $C_{\text{crit}}$, and is continuous at $C_{\text{crit}}$. A simulation with this modified rate and with a value of $C_{\text{crit}} = 0.001$ mg/l can be done without any numerical problems. The result is shown in Fig. 4.11.

Save your system definitions by clicking the command File→Save from the main menu bar. Answer No to the question to save calculated states.
Figure 4.11: Concentration time series with the modified process rate definition.
CHAPTER 4. NUMERICAL PARAMETERS

4.2 Parameters for Discretization in Space

Problem
This example demonstrates possible problems in space discretization and the meaning of numerical parameters. The example uses an advective-diffusive reactor compartment. The tutorial example for this compartment is given in section 5.2. However, it should be possible to understand this example without having studied the example in section 5.2 before.

Part A: Calculate the advective transport of a concentration input pulse

\[ C_{1,in}(t) = 10 \text{ mg/l} \cdot \exp \left( -\frac{(t - t_0)^2}{2\sigma^2} \right) \]

with \( t_0 = 1500 \text{ s} \) and \( \sigma = 500 \text{ s} \) through a 200 m long channel with a cross-sectional area of 5 m\(^2\) and a discharge of 1 m\(^3\)/s. Implement the channel as an advective-diffusive reactor compartment without diffusion and compare the result with the analytical solution given as

\[ C_{1,out}(t) = 10 \text{ mg/l} \cdot \exp \left( -\frac{(t - t_0 - t_{adv})^2}{2\sigma^2} \right) \]

with an advection time of \( t_{adv} = 1000 \text{ s} \).

Use 52 grid points for spatial discretization, select the low resolution discretization technique and compare the numerical and with the analytical concentration time series at the end of the channel after performing 400 output steps of 10 s. Try to accelerate the calculation by increasing the numerical parameter Maximum Internal Step Size and by decreasing the numerical parameter Number of Codiagonals of the Jacobian Matrix (these parameters are accessible with the command Edit→Numerical Parameters from the main menu bar).

Part B: Change now to the initial width \( \sigma \) from 500 s to 100 s and repeat the simulation done in part A. Interpret the result.

Try to improve the the result by changing the number of grid points from 52 to 202 and/or by using the high resolution spatial discretization technique.

Try to reproduce the result of the simulation with 52 grid points and low resolution with 202 grid points and high resolution by introducing a diffusion coefficient with an appropriate value. Find this value by trial and error and compare it with the value

\[ D_{num} \approx \frac{1}{2} v \Delta x = \frac{1}{2} \frac{Q}{A} \frac{L}{n - 2} \]

expected for numerical diffusion (\( v \) is the advective velocity, \( \Delta x \) is the length of a cell used for discretization, \( L \) is the channel length and \( n \) is the number of grid points used for spatial discretization).

Part C: Add a second substance with an input pulse that increases linearly from 0 to 10 mg/l during the time from 1469 to 1471 s, remains at 10 mg/l until a time of 1529 s is reached and then decreases linearly to zero during the time from 1529 to 1531 s. Introduce again the analytical solution consisting of the same pulse shifted by 1000 s in time. Use a Maximum Internal Step Size of 200 s, redo
the simulation and look also at the spatial profiles of the substance at 1600 s, 1800 s, 2000 s, 2200 s and 2400 s. Redo the simulation after inactivating the concentration of the first substance. Interpret your result and change the appropriate numerical parameter to obtain the correct result.

Part D: Divide the advective-diffusive reactor compartment in two advectively linked advective-diffusive compartments with the same total length, the same total number of discretization cells and the same input at the inlet to the first compartment. Distinguish the names of the compartments by appending '_1' to the original name for the first compartment and by appending '_2' to the original name for the second compartment. Reproduce the final simulation done in part C.

Now, rename the compartments by replacing '_1' by '_up' and '_2' by '_down'. Redo the simulation and try to find out and fix the numerical problem that occurs.
Solution

Part A

Start the window interface version of AQUASIM or click the command File→New from the main menu bar to remove previously entered data from memory. Then perform the following steps:

• **Definition of variables**
  Define a state variable \( C_1 \), a program variable \( t \) referring to Time, and formula variables \( Q_{in}, \sigma, t_0 \) and \( t_{adv} \) with values of 1 \( m^3/s \), 500 s, 1500 s and 1000 s, respectively. Then define two formula variables \( C_{1in} \) as \( 10 \times \exp\left(-\frac{(t-t_0)^2}{2(\sigma^2)}\right) \) and \( C_{1out} \) as \( 10 \times \exp\left(-\frac{(t-t_0-t_{adv})^2}{2(\sigma^2)}\right) \).

• **Definition of compartment**
  Define an advective-diffusive reactor compartment PlugFlowReact and activate the state variable \( C_1 \). Click the button Input, then select the radio button Inlet Input and define the Water Inflow to be \( Q_{in} \) and the Loading for the variable \( C_1 \) to be \( Q_{in} \times C_{1in} \) as shown in Fig. 4.12. Then define the Start Coordinate to be 0 (m), the End Coordinate to be 200 (m), and the Cross Sectional Area to be 5 (m²). Select the radio button without diffusion, specify the Number of Grid Points to be 52, and select the Resolution to be low. These definitions of the advective-diffusive reactor compartment are shown in Fig. 4.13.

Comment: Within the advective-diffusive reactor compartment for all dynamic volume state variables one-dimensional advection-diffusion-reaction equations are solved (or pure advection-reaction equations if in the dialog box shown in Fig. 4.13 the radio button without diffusion is selected). These equations can describe advection, advection-diffusion or advection-dispersion processes coupled with substance transformations. The advective velocity is given as \( Q/A \) where \( Q \) is the discharge and \( A \) the cross-sectional area. The discharge, \( Q \), is equal to the Water Inflow specified in the dialog box shown in Fig. 4.12 plus the outflow of all advective links connected to the inflow of the compartment. The cross-sectional area, \( A \), is defined in the edit field Cross. Sect. in the dialog box shown in Fig. 4.13. With the aid of the program variable Space Coordinate \( X \), the cross-sectional...
4.2. PARAMETERS FOR DISCRETIZATION IN SPACE

area may become dependent on the location along the compartment (an algebraic expression can be entered in this edit field or the cross-sectional area can be defined as a real list variable with the program variable Space Coordinate X as the argument and this variable can be specified in the edit field Cross. Sect.). The numerical algorithm used for solving the advection-diffusion equation requires a user-specified discretization of the direction along the reactor that uses \( n - 2 \) cells of equal length if \( n \) denotes the number of grid points selected in the dialog box shown in Fig. 4.13 (two grid points are used for the start and end points of the reactor; the step size of the discretization in time is selected automatically by the time integration algorithm). Finally, the Resolution of the spatial discretization must be selected in the dialog box shown in Fig. 4.13. The low resolution method uses a simple first order discretization technique that is robust but leads to considerable numerical diffusion (as discussed in part B of this example), the high resolution method uses a second order discretization technique with flux limiters in order to avoid numerical oscillations of the solutions.

- **Definition of plot**
  Define a plot \( C_{1,t} \) containing two curves for the value of the variable \( C_1 \) evaluated in the compartment PlugFlowReact at the Space location 200 (m) and for the value of the variable \( C_{1,\text{out}} \).

  Comment: Because the variable \( C_{1,\text{out}} \) has a global value it is irrelevant in which compartment and at which location it is evaluated (if the location is within the legal range for the compartment).

- **Definition of simulation**
  Define an active calculation of 400 steps of 10 s.
  Save your system definitions to the file `numspa_a.aq` by clicking the command `File→Save As` from the main menu bar and specifying the file name.

- **Execution of simulation and presentation of results**
  Start now the simulation and look at the results shown in Fig. 4.14. The numerical solution shows reasonable agreement with the analytical solution. A small peak atten-
CHAPTER 4. NUMERICAL PARAMETERS

Figure 4.14: Comparison of the analytical and the numerical solution of part A.

Evaluation occurs due to numerical diffusion that will be discussed in more detail in part B of this example.

The simulation speed can now be increased significantly by changing the numerical parameters as shown in Fig. 4.15. This dialog box is open by clicking the command

![Edit Numerical Parameters dialog box](advdif_a_OutletConcentrationTimeSeries.png)

Figure 4.15: Numerical parameters as used for speeding up the integration process.

Edit → Numerical Parameters from the main menu bar. The parameter Maximum Internal Step Size has been increased from its default value of 1 to 100 and the parameter Number of Codiagonals of the Jacobian Matrix has been decreased from its default value 1000 to 8.

Comment: The integration time step is selected (and changed) automatically by the numerical integration algorithm (the solution is then interpolated at the points of time selected by the user with the external time step). The parameter Maximum Internal Step Size sets an upper bound to the internal time step selected by the algorithm. In the current example a maximum of 1 (s) leads to the execution of more time steps than necessary for keeping the integration at a reasonable accuracy. There-
fore, an increase of this parameter speeds up the calculation. The implicit numerical solver DASSL (Petzold, 1983) used for time integration of the spatially discretized partial differential equations (together with the ordinary differential equations and with the algebraic equations) requires the calculation of the matrix of the partial derivatives of the right-hand sides of the differential equations with respect to the state variables (Jacobian matrix). If the spatial configuration of the model implemented in AQUASIM does not contain recirculations, probe variables and biofilm compartments and if the flow through the linear arrangement of reactors is according to the alphabetical list in the dialog box Edit Compartments, then this matrix is banded and a reduction of the number of codiagonals of this matrix significantly increases calculation speed. The lower the number of state variables, the lower the number of necessary codiagonals. In the current case, the limitation to 8 codiagonals leads to a significant increase in calculation speed.

Save your system definitions by clicking the command File→Save from the main menu bar. Answer No to the question to save calculated states.
Part B
Continue just after doing part A or load the file saved in part A from within the window interface version of AQUASIM. Then perform the following steps:

- **Modification of the system definitions**
  Change the value of the variable \( \sigma \) from 500 s to 100 s.
  Save your system definitions to the file `numspa_b.aqu` by clicking the command `File\rightarrow Save As` from the main menu bar and specifying the file name.

- **Execution of simulation and presentation of results**
  Redo the simulation and plot the results. Fig. 4.16 shows the comparison of the analytical with the numerical solution for this new value of \( \sigma \). In contrast to the simulation with \( \sigma = 500 \) s done in part A (Fig. 4.14) the numerical solution for \( \sigma = 100 \) s deviates significantly from the analytical solution. This is due to numerical diffusion which has a larger effect to the narrower pulse in part B than it had in part A.

  Increase now in the dialog box `Edit Advective-Diffusive Compartment` shown in Fig. 4.13 the number of grid points to 202, redo the simulation and plot the results. The numerically calculated peak becomes now narrower, but there is still a significant deviation between the numerical and the analytical solution.

  Switch now back to 52 grid points but select the high resolution discretization scheme. The result is even better than for the simulation performed before with 202 grid points and the low resolution scheme.

  Finally, use 202 grid points and the high resolution scheme, redo the simulation and plot the results. This result is shown in Fig. 4.17. For the current peak width, there is now a good agreement between the numerical and the analytical solution. This means that there is no significant numerical diffusion.

  In the dialog box `Edit Advective-Diffusive Compartment` select now the radio button...
4.2. PARAMETERS FOR DISCRETIZATION IN SPACE

Figure 4.17: Comparison of numerical and analytical solution for 202 grid points and high resolution discretization.

ton with diffusion and specify a diffusion coefficient. Redo the simulation and look at the results. With a diffusion coefficient between 0.3 m²/s and 0.6 m²/s the numerical solution is similar to that for the simulation with 52 grid points and the low resolution discretization. This result corresponds to a value of the numerical diffusion of $D_{\text{num}} = 0.4$ m²/s calculated with the formula given above ($D_{\text{num}} \approx v\Delta x/2$).

Comment: The occurrence of numerical diffusion has the following consequences: If diffusion (or dispersion) is negligible in the system considered, the resolution of the discretization must be so high that for the pulse widths typical in the system the effect of numerical diffusion can be neglected. The equation $D_{\text{num}} \approx v\Delta x/2$ valid for the first order (low resolution) discretization scheme may help finding the adequate resolution. If there is significant diffusion (or dispersion) in the investigated system, there are two possibilities: The discretization can be chosen in such a way that the numerical diffusion can be neglected and the real diffusion coefficient is entered as a diffusion coefficient in the dialog box used for editing the advective-diffusive reactor compartment, or a first order (low resolution) discretization technique together with a purely advective compartment (option: without diffusion) can be used with the number of grid points chosen such that the numerical diffusion is equal to the real diffusion. From a conceptual point of view the first technique is more satisfying, however, from a pragmatic point of view the second technique is appealing because the computational demand is minimised.

Save your system definitions by clicking the command File→Save from the main menu bar. Answer No to the question to save calculated states.
Part C
Continue just after doing part B or load the file saved in part B from within the window interface version of AQUASIM. Then perform the following steps:

- **Modification of the system definitions**
  Add a state variable C2 and two real list variables C2in and C2out as shown in the Figs. 4.18 and 4.19.

Figure 4.18: Definition of the real list variable C2in.

Activate the variable C2 in the compartment PlugFlowReact and specify the Input Flux for the variable C2 into this compartment as Qin\*C2in.
Set the numerical parameter Maximum Internal Step Size to 200 (s).
Duplicate the plot definition Cl.t, change the name to C2.t and change the variable names from Cl to C2 and from Clout to C2out. Select the line style for the variable C2out to be solid. Add an additional plot definition as shown in Fig. 4.20.
Save your system definitions to the file numspa.c.aqu by clicking the command File—>Save As from the main menu bar and specifying the file name.

- **Execution of simulation and presentation of results**
  Redo the simulation and look at the result shown as a time series in Fig. 4.21 and as spatial profiles in Fig. 4.22. Note that for extremely sharp pulses a small numerical diffusion effect can hardly be avoided.
  Inactivate now the variable Cl in the compartment PlugFlowReact and redo simulation and plot. The pulse has been disappeared! The reason for this problem is that now
the time step limiting first substance is not longer calculated by the program. Because the concentration of the second substance is constant (zero) during quite a long time, the integration time step increases to its maximum of 200 s. With such a large time step it is possible that the integration algorithm steps over the input pulse without recognising the change in concentration. This problem can be solved by reducing the Maximum Internal Step Size to 50 (s). With this step size, the integrator cannot overstep an input pulse with a length of 60 s. If the integrator recognises the pulse, the step size is automatically decreased in order to follow its shape accurately. Save your system definitions by clicking the command File→Save from the main menu bar. Answer No to the question to save calculated states.
Figure 4.20: Definition of the plot for spatial profiles of C2.
Figure 4.21: Output times series of the variable C2.
Concentration Profiles

<table>
<thead>
<tr>
<th>Concentration Profiles</th>
<th>1800 s</th>
<th>1800 s</th>
<th>2000 s</th>
<th>2200 s</th>
<th>2400 s</th>
</tr>
</thead>
<tbody>
<tr>
<td>$C_2$ [g/m]</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>0</td>
<td>2</td>
<td>4</td>
<td>6</td>
<td>8</td>
<td>10</td>
</tr>
</tbody>
</table>

Figure 4.22: Spatial profiles of the variable $C_2$. 
4.2. PARAMETERS FOR DISCRETIZATION IN SPACE

Part D
Continue just after doing part C or load the file saved in part C from within the window interface version of AQUASIM. Then perform the following steps:

- **Modification of the system definitions**
  Rename the compartment PlugFlowReact to PlugFlowReact.1, reduce the End Coordinate from 200 to 100 and reduce the Num. of Grid Points from 202 to 102 (this corresponds to a reduction of the number of cells from 200 to 100). Then duplicate the compartment. Change the name of the copied compartment from PlugFlowReact.1 to PlugFlowReact.2, the Start Coordinate from 0 to 100 and the End Coordinate from 100 to 200. Then click the button Input, set the Water Inflow to 0 and delete the inlet Loadings.
  Define an advective link from compartment PlugFlowReact.1 to compartment PlugFlowReact.2.
  In the plot definition for the concentration time series change the compartment for the evaluation of the curve at the location 200 m from PlugFlowReact.1 to PlugFlowReact.2.
  Save your system definitions to the file numspa_d.aqu by clicking the command File→Save As from the main menu bar and specifying the file name.

- **Execution of simulation and presentation of results**
  The simulation can now easily be redone and leads to the same results as in part C (in order to look at the concentration profiles, additional curves must be defined for the same points of time in the compartment PlugFlowReact.2).
  Rename now the compartment PlugFlowReact.1 to PlugFlowReact.up and the compartment PlugFlowReact.2 to PlugFlowReact.down and restart the simulation. The initialization stops with a message of numerical problems.
  What is the cause for these problems?
  The partial differential equations are discretized in space in the alphabetical order in which they are listed in the dialog box Edit Compartments. If the alphabetical order corresponds to the flow direction, in the discretization scheme, the last grid points of the first compartment are close to the first grid points of the second compartment. This means that the advective link connects neighbouring grid points. This leads to a Jacobian matrix that is banded (within the compartments it is banded for the same reason). For this reason, computation time can be saved by limiting the number of codiagonals that are evaluated by the integration algorithm as it has been done in this example. However, if renaming changes the order of the compartments, the advective link that connects the last grid points of the upstream compartment with the first grid points of the downstream compartment connects the last grid points of the overall set with the first grid points. This leads to nonzero elements of the Jacobian matrix far from the diagonal. For this reason, integration with this discretization scheme does not converge if only a small number of codiagonals of the Jacobian matrix are evaluated. If the value of the numerical parameter Number of Codiagonals of the Jacobian Matrix in the dialog box opened by clicking the command Edit→Numerical Parameters is increased to 1000 (any value larger than the number of ordinary differential equations to be solved after spatial discretization leads to the evaluation of the full Jacobian matrix) the simulation runs without problems and the result is again equal to that in part C. However, the evaluation of the full Jacobian matrix makes
the simulation significantly slower. For this reason, it is important to try to guarantee a banded Jacobian matrix if this is possible (recirculations always generate nonzero elements of the Jacobian matrix far from the diagonal).
Chapter 5

Compartments

The basic AQUASIM features have been discussed in the chapters 2 to 4 using systems consisting of mixed reactors (with the exception of section 4.2). The goal of this chapter is to give an introduction to the various alternatives for more complicated compartments.

In section 5.1 a simple example for an application of the biofilm reactor compartment is discussed. This example demonstrates how substrate and population gradients over the depth of a biofilm can be modelled with AQUASIM.

The introduction of the advective-diffusive reactor compartment in section 5.2 is used to demonstrate the difference between flux-averaged and volume-averaged concentrations. This difference often causes problems in understanding calculated concentration steps if the diffusion or dispersion coefficient changes discontinuously.

In section 5.3 the soil column compartment is introduced. This is an extension of the advective-diffusive reactor compartment with respect to the consideration of diffusion into immobile regions.

Another extension of the advective-diffusive reactor compartment, the river section compartment, is discussed in section 5.4. In this compartment, instead of the continuity equation for water flow within a given cross-sectional area, simplified versions of the open-channel flow equations are solved. The transport processes are described analogously to the advective-diffusive reactor compartment with a diffusion-type approximation to the dispersion process.

The last compartment describing stratification, transport and transformation processes in a horizontally well-mixed lake is discussed in section 5.5.

In contrast to the chapters 2 to 4 which are very much recommended to be studied for all AQUASIM users, in the present chapter, the user can select to study the examples for the compartments in which he or she is interested.
5.1 Biofilm Reactor Compartment

The example of this section demonstrates how to calculate growth and structure of a biofilm on a substrate in a mixed reactor.

The main AQUASIM feature introduced in this section is the biofilm reactor compartment.

Problem

Part A: Calculate growth and composition of a biofilm which consists of two microbial species. It is assumed that the volume of water flowing over the biofilm surface area of 1 m² is 10⁻³ m³ and remains constant. The water inflow at a rate of 1 m³/d contains two substrates at a concentrations of 10 gCOD/m³ each. The density of both microorganisms is 25000 gCOD/m³. Each microbial species grows on one substrate only. Growth occurs with Monod-type rate laws with maximum growth rates of 0.4 d⁻¹ and 0.1 d⁻¹, half-saturation concentrations of 5 gCOD/m³ and yield coefficients of 0.01 and 0.5, respectively. Respiration occurs with specific rates of 0.05 d⁻¹ and 0.002 d⁻¹. The initial biofilm thickness is 10⁻⁴ m and the initial volume fractions of both species are 10 % (80 % of the biofilm consists of water). The diffusion coefficients of both substrates are assumed to be 2 · 10⁻⁵ m²/d.

Perform a simulation for 50 days and plot the concentration profiles of the dissolved substances and the volume fraction profiles of the microorganisms at the days 10, 25 and 50 and the biofilm thickness as a function of time.

Part B: Assume a mass transfer resistance due to a molecular boundary layer of 10⁻⁴ m thickness at the biofilm surface (diffusivity of particles equal to 10⁻⁷ m²/d) and a detachment velocity equal to half of the growth velocity of the biofilm.

Redo the simulation and discuss the differences in the results.

```
if \ u_F > 0 \ then \ c_{de} \times \ u_F \ else \ 0 \ endif
```
5.1. BIOFILM REACTOR COMPARTMENT

Solution
Part A
Start the window interface version of AQUASIM or click the command File→New from the main menu bar to remove previously entered data from memory. Then perform the following steps:

- **Definition of variables**
  Define a program variable LF referring to Biofilm Thickness as shown in Fig. 5.1. Then define dynamic volume state variables $S_1$, $S_2$, $X_1$ and $X_2$ for the two substrates and the two microbial species, respectively. Then create the following formula variables:

<table>
<thead>
<tr>
<th>Meaning</th>
<th>Name</th>
<th>Unit</th>
<th>Expression</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bacterial density, $\rho$</td>
<td>rho</td>
<td>gCOD/m$^3$</td>
<td>25000</td>
</tr>
<tr>
<td>Diffusivity of $S_1$, $D_{S_1}$</td>
<td>$D_{S_1}$</td>
<td>m$^2$/d</td>
<td>2e-5</td>
</tr>
<tr>
<td>Diffusivity of $S_2$, $D_{S_2}$</td>
<td>$D_{S_2}$</td>
<td>m$^2$/d</td>
<td>2e-5</td>
</tr>
<tr>
<td>Max. growth rate of $X_1$, $\mu_{X_1}$</td>
<td>$\mu_{X_1}$</td>
<td>1/d</td>
<td>0.4</td>
</tr>
<tr>
<td>Max. growth rate of $X_2$, $\mu_{X_2}$</td>
<td>$\mu_{X_2}$</td>
<td>1/d</td>
<td>0.1</td>
</tr>
<tr>
<td>Half-saturation conc. for $S_1$, $K_{S_1}$</td>
<td>$K_{S_1}$</td>
<td>gCOD/m$^3$</td>
<td>5</td>
</tr>
<tr>
<td>Half-saturation conc. for $S_2$, $K_{S_2}$</td>
<td>$K_{S_2}$</td>
<td>gCOD/m$^3$</td>
<td>5</td>
</tr>
<tr>
<td>Specific resp. rate of $X_1$, $b_{X_1}$</td>
<td>$b_{X_1}$</td>
<td>1/d</td>
<td>0.05</td>
</tr>
<tr>
<td>Specific resp. rate of $X_2$, $b_{X_2}$</td>
<td>$b_{X_2}$</td>
<td>1/d</td>
<td>0.002</td>
</tr>
<tr>
<td>Volume fraction of $X_1$, $\epsilon_{X_1}$</td>
<td>$\epsilon_{X_1}$</td>
<td></td>
<td>$X_1$/rho</td>
</tr>
<tr>
<td>Volume fraction of $X_2$, $\epsilon_{X_2}$</td>
<td>$\epsilon_{X_2}$</td>
<td></td>
<td>$X_2$/rho</td>
</tr>
<tr>
<td>Yield for growth of $X_1$, $Y_{X_1}$</td>
<td>$Y_{X_1}$</td>
<td></td>
<td>0.01</td>
</tr>
<tr>
<td>Yield for growth of $X_2$, $Y_{X_2}$</td>
<td>$Y_{X_2}$</td>
<td></td>
<td>0.5</td>
</tr>
<tr>
<td>Inflow, $Q_{in}$</td>
<td>$Q_{in}$</td>
<td>m$^3$/d</td>
<td>1</td>
</tr>
<tr>
<td>Inflow concentration of $S_1$, $S_{1,in}$</td>
<td>$S_{1,in}$</td>
<td>gCOD/m$^3$</td>
<td>10</td>
</tr>
<tr>
<td>Inflow concentration of $S_2$, $S_{2,in}$</td>
<td>$S_{2,in}$</td>
<td>gCOD/m$^3$</td>
<td>10</td>
</tr>
</tbody>
</table>

Save your system definitions to the file film.a.aqu by clicking the command File→Save As from the main menu bar and specifying the file name.

- **Definition of processes**
  Define a dynamic process for growth of microbial species of type 1 as shown in Fig. 5.2. By duplicating this process and replacing all $S_1$ by $S_2$, $X_1$ by $X_2$ and $Y_1$ by $Y_2$ create the analogous process for microbial species of type 2. Then introduce a respiration
process \( \text{Resp}_X \) with a rate of \( b_X \cdot X \) and a stoichiometric coefficient of -1 for \( X \). Again add the analogous process for microbial species of type 2 by duplicating the process \( \text{Resp}_X \), renaming it to \( \text{Resp}_2 \) and replacing \( b_X \) by \( b_X \) and all \( X \) by \( X \).

- **Definition of compartment**
  Define a biofilm reactor compartment as shown in Fig. 5.3. Activate the state variables \( S_1, X, S_2 \) and \( X \) and the processes \( \text{Gro}_X, \text{Gro}_2, \text{Resp}_X \) and \( \text{Resp}_2 \). Specify an initial condition of 0.0001 for the variable \( LF \) in the zone Biofilm Matrix and initial conditions of \( 0.1 \cdot \rho \) for the variables \( X \) and \( X \) in the zone Biofilm Matrix. Then specify the water inflow to be \( Qin \) and input loadings of \( Qin \cdot S_{in} \) and \( Qin \cdot S_{2in} \) for the variables \( S_1 \) and \( S_2 \), respectively. Then define particulate properties for the state variable \( X \) by first clicking the button **Particulate Variables** and then the button **Add**. In the dialog box **Edit Particulate Variable** select the variable \( X \), specify the Density to be equal to \( \rho \) and set all other properties to zero. Do the same for \( X \). Similarly, by clicking the button **Dissolved Variables** define the Boundary Layer Resistance to be zero and the Pore Diffusivity to be \( D_S \) and \( D_S \) for the variables \( S_1 \) and \( S_2 \), respectively.

Save your system definitions by clicking the command **File -- Save** from the main menu bar.

- **Definition of plots**
  Define a plot \( LF_t \) with a curve for the film thickness \( LF \) as a function of time. Then define a plot \( S_{t,z} \) with profiles of the substrate concentrations after 10, 25 and 50 d of simulation. For each substrate and each point in time plot two curves: a line for the zone Pore Water and a marker for the zone Bulk Volume.

Comment: In a plot of spatial profiles, the bulk volume concentration is plotted as a point at the biofilm surface. If lines are plotted in the biofilm matrix (or the pore volume) and markers in the bulk volume, the discontinuity resulting from a surface boundary layer can be made visible in the plot.
5.1. BIOFILM REACTOR COMPARTMENT

Finally, define a plot $X_z$ with curves for both species in the biofilm matrix after 10, 25 and 50 d of simulation.

- **Definition of the simulation**
  Define an active calculation with 50 steps of 1 day.
  Save your system definitions by clicking the command File→Save from the main menu bar.

- **Execution of the simulation and presentation of results**
  The simulation is now started by clicking the button Start/Continue of the dialog box Simulation. Then the results can be plotted. The Figs. 5.5 to 5.7 show the results. The concentration of the substrate $S_1$ which is consumed at a much higher rate than $S_2$ decreases much faster in the biofilm. This makes growth of $X_1$ only possible close to the biofilm surface. In the depth of the biofilm $X_2$ can grow on $S_2$. The microbial composition resulting from this behaviour is shown in Fig. 5.7.
  Save your system definitions by clicking the command File→Save from the main menu bar. Answer No to the question to save calculated states.
Figure 5.4: Definition of plot for substrate profiles.
5.1. BIOFILM REACTOR COMPARTMENT

Figure 5.5: Development of the biofilm thickness as a function of time.
CHAPTER 5. COMPARTMENTS

Figure 5.6: Profiles of both substrates at 10, 25 and 50 days.
Figure 5.7: Profiles of the volume fractions of both microbial species at 10, 25 and 50 days.
Part B
Continue just after doing part A or load the file saved in part A from within the window interface version of AQUASIM. Then perform the following steps:

- **Modification of the system definitions**
  Define a program variable \( uF \) referring to Growth Velocity of Biofilm, a formula variable \( D.X \) with a value of \( 1e-7 \) m\(^2\)/d, and a formula variable \( LL \) with a value of 0.0001 m. Then, for the particulate variables \( X1 \) and \( X2 \) add \( LL/D.X \) as the Boundary Layer Resistance and for the dissolved variables \( S1 \) and \( S2 \) add \( LL/D.S1 \) and \( LL/D.S2 \) as the Boundary Layer Resistance, respectively. Figure 5.8 shows the example for \( S1 \) (this dialog box is opened by clicking the button Dissolved Variables in the dialog box Edit Biofilm Reactor Compartment).

![Figure 5.8: Definition of the boundary layer resistance and the diffusivity of a dissolved variable.](image)

Then add the expression if \( uF>0 \) then \( 0.5\cdot uF \) else 0 endif as the global surface detachment velocity in the dialog box Edit Biofilm Reactor Compartment as shown in Fig. 5.9.

Comment: The formulation of the detachment velocity as given above guarantees that the detachment velocity does not become negative for shrinking biofilms (the detachment velocity must always be nonnegative).

Save your system definitions to the file film.b.aqu by clicking the command File→Save As from the main menu bar and specifying the file name.

- **Execution of the simulation and presentation of results**
  The Figs. 5.10 and 5.11 show the calculated substrate and microorganism profiles for the new model. Biofilm growth is smaller than in part A due to detachment and smaller substrate flux into the film.

Save your system definitions by clicking the command File→Save from the main menu bar. Answer No to the question to save calculated states.
5.1. BIOFILM REACTOR COMPARTMENT

Figure 5.9: Definition of the biofilm compartment; look in particular to the definition of the surface detachment velocity.
Figure 5.10: Profiles of both substrates at 10, 25 and 50 days.

Figure 5.11: Profiles of the volume fractions of both microbial species at 10, 25 and 50 days.
5.2 Adveactive-Diffusive Reactor Compartment

The example of this section demonstrates how to calculate the transport of a substance through an advective-diffusive reactor.

The main AQUASIM feature introduced in this section is the advective-diffusive reactor compartment.

Problem

Part A: Calculate the break-through curve of a rectangular tracer pulse of the form (arbitrary units)

\[
\begin{array}{|c|c|}
\hline
\text{time } t & \text{inflow concentration } C \\
0.00 & 0 \\
0.01 & 1 \\
1.00 & 1 \\
1.01 & 0 \\
\hline
\end{array}
\]

through a column with a cross-sectional area of 1 unit, a length of 1 unit, a discharge of 1 unit, and a dispersion coefficient of 0.1 units (arbitrary units). Compare the inflow concentration given above with the concentration time series at the end of the column.

Part B: Define a sampling device with a volume of 0.01 units and link it advectively to the outlet of the column. In addition to the concentration time series defined above, plot the concentration time series at the start position of the column and within the sampling device. Discuss the differences in the plotted curves.
Solution
Part A
Start the window interface version of AQUASIM or click the command File→New from the main menu bar to remove previously entered data from memory. Then perform the following steps:

- **Definition of variables**
  Define a program variable \( t \) referring to Time. Define a real list variable \( \text{Cin} \) for the inflow concentration as shown in Figure 5.12. Define a dynamic volume state variable \( C \) for the concentration of the tracer and two formula variables \( \text{Qin} \) with a value of 1 and \( D \) with a value of 0.1.

![Edit Real List Variable](image)

Figure 5.12: Definition of the inflow concentration as a function of time.

for the concentration of the tracer and two formula variables \( \text{Qin} \) with a value of 1 and \( D \) with a value of 0.1.

- **Definition of compartment**
  Define an advective-diffusive reactor compartment as shown in Fig. 5.13. The large number of grid points and the high resolution discretization technique were chosen in order to avoid numerical diffusion. Activate the variable \( C \) and define an Inlet Input with a Water Inflow equal to \( \text{Qin} \) and an Input Flux for the variable \( C \) equal to \( \text{Qin} \cdot \text{Cin} \).

- **Definition of plot**
  Define a plot with time series for \( \text{Cin} \) and for \( C \) evaluated at the location 1 (end of the compartment) in the advective-diffusive compartment.
• **Definition of simulation**
  Define an active calculation with 300 steps of size 0.01 and reduce the numerical parameter Number of Codagonals of the Jacobian Matrix to 10. Save your system definitions to the file `advdif.a.aqu` by clicking the command File→Save As from the main menu bar and specifying the file name.

• **Execution of the simulation and presentation of results**
  Start the simulation and plot the results. These are shown in Fig. 5.14. The pulse is shifted in time and spreaded through the effect of dispersion or diffusion.
Save your system definitions by clicking the command File→Save from the main menu bar. Answer No to the question to save calculated states.
5.2. ADVECTIVE-DIFFUSIVE REACTOR COMPARTMENT

Part B

Continue just after doing part A or load the file saved in part A from within the window interface version of AQUASIM. Then perform the following steps:

- **Modification of the system definitions**
  Create a mixed reactor compartment sampler with a constant volume of 0.01 and activate the variable C. Then create an advective link from the outlet of the advective-diffusive reactor compartment column to the mixed reactor compartment sampler as shown in Fig. 5.15. Finally add two curves to the existing plot definition for time series of the variable C in the advective-diffusive compartment at location 0 (start position of the column) and of the same variable evaluated in the new mixed reactor compartment. Save your system definitions to the file advdiLb.aqu by clicking the command File→Save As from the main menu bar and specifying the file name.

- **Execution of the calculation and presentation of results**
  Redo the simulation. Figure 5.16 shows the results of the calculation. Note that the concentration in the inlet is not identical to the concentration at the start position of the column and the concentration in the sampler is not identical to the concentration at the end of the column. The reason for this fact is that AQUASIM guarantees mass conservation at the inlet and at the outlet and that the diffusion coefficient \( D \) changes discontinuously between the compartments. Substance loading in the column is given as the sum of advective and diffusive or dispersive loadings as

\[
I = QC - AD \frac{\partial C}{\partial x} 
\]

This expression cannot remain constant without changes in \( C \) or \( \partial C/\partial x \) if \( D \) changes its value. For this reason, if mass conservation is guaranteed, a discontinuity in the diffusion coefficient leads to a discontinuity in concentration. At the inlet, the loading is specified as \( I = QC_{in} \). This means that dispersion and/or diffusion is neglected in the inlet. At the start position of the column, this loading is equal to the expression given above with a nonzero diffusion coefficient and with the concentration profile at the start.
CHAPTER 5. COMPARTMENTS

Figure 5.16: Plot of the concentration time series in the inlet (Cin), within the column at the start position (C at inlet), within the column at the end (C at outlet), and in the small mixed reactor compartment linked to the outlet (Cout).

position of the column. This explains why the concentration in the column is smaller than Cin when Cin increases and larger when Cin decreases. The same effect happens at the end of the column. The advective plus the dispersive or diffusive loading out of the column enters the small mixed reactor compartment where therefore the so-called flux-averaged concentration of the column becomes the volume averaged concentration in the sampler. The usefulness of flux- versus volume-averaged concentrations is discussed extensively in the literature (Pearson, 1959; Kreft and Zuber, 1961; Parker, 1984; Parker and van Genuchten, 1984).

Save your system definitions by clicking the command File→Save from the main menu bar. Answer No to the question to save calculated states.
5.3. SOIL COLUMN COMPARTMENT

5.3 Soil Column Compartment

Problem
This example demonstrates how to calculate break-through curves of substances through saturated soil columns in the presence of linear or nonlinear equilibrium or kinetic sorption and mobile and immobile regions. The main AQUASIM features introduced in this example are the saturated soil column compartment, dynamic surface state variables and the program variable Zone Index.

Part A: Implement a soil column with a length of 1 m, a cross-sectional area of \( A = 0.001 \) m\(^2\) and a porosity of \( \theta = 0.4 \). Assume dispersion-free transport. In the following isotherm equations, \( C \) denotes the concentration of a substance in the pore water (mass per water volume) and \( S \) the adsorbed mass per unit of solid phase mass. Compare the break-through curves without sorption, with linear sorption
\[
S_{eq} = K_d C
\]
\((K_d = 0.00058 \text{ m}^3/\text{kg})\), with nonlinear sorption with a Langmuir isotherm
\[
S_{eq} = \frac{S_{max} C}{K + C}
\]
\((S_{max} = 0.00029 \text{ mg/kg, } K = 0.5 \text{ mg/m}^3)\), and with nonlinear sorption with a Freundlich isotherm
\[
S_{eq} = K_F C^\alpha
\]
\((K_F = 0.00025, \alpha = 0.5)\). Assume a solid phase density of \( \rho_s = 2300 \text{ kg/m}^3 \) and equilibrium sorption (approximated by kinetic sorption with the very large relaxation time constant \( k = 10000 \text{ h}^{-1} \)). The water flow through the column is \( 0.001 \text{ m}^3/\text{h} \) and the concentration in the dispersion-free inflow tube is \( 1 \text{ mg/m}^3 \) in the time interval between zero and \( 0.5 \text{ h} \) and zero outside this interval. For the calculation with the Langmuir isotherm add an additional simulation with an input peak height of \( 0.2 \text{ mg/m}^3 \) instead of \( 1 \text{ mg/m}^3 \).

Implement the five cases with five different calculation numbers and plot the break-through curves as five curves in the same plot. Discuss the shapes of the break-through curves.

Part B: Redo all simulations of part A with kinetic sorption using a relaxation time constant of \( k = 100 \text{ h}^{-1} \) instead of \( k = 10000 \text{ h}^{-1} \).
Plot all five curves and discuss the differences to the results of part A.

Part C: Redo all simulations of part A with equilibrium sorption assuming transport with a dispersion coefficient of \( E = 0.015 \text{ m}^2\text{h}^{-1} \) instead of dispersion-free transport.
Plot all five curves and discuss the differences to the results of the parts A and B.

Part D: For the case of equilibrium sorption and dispersion-free transport (part A), assume now 10% of the pore volume to be immobile. Furthermore, assume 50% of the sorption sites to be in contact with the mobile zone and 50% with the immobile zone. Assume the exchange coefficient to be \( q_{ex} = 0.025 \text{ m}^2\text{h}^{-1} \).
CHAPTER 5. COMPARTMENTS

Plot all five curves and discuss the differences to the results of the parts A, B and C.
5.3. SOIL COLUMN COMPARTMENT

Solution
Part A

Start the window interface version of AQUASIM or click the command File→New from the main menu bar to remove previously entered data from memory. Then perform the following steps:

- **Definition of variables**
  Define a dynamic volume state variable $C$ for the dissolved concentration $C$ and a dynamic surface state variable $S$ for the adsorbed mass per unit of solid mass $S$ as shown in Fig. 5.17. Let the relative accuracies of both state variables and the absolute accuracy of $C$ at their default values of $10^{-5}$, but change the absolute accuracy of $S$ to $10^{-9}$.

![Edit State Variable](image)

Figure 5.17: Definition of the dynamic surface variable $S$.

![Edit Formula Variable](image)

Figure 5.18: Definition of the Freundlich isotherm with linearization at concentrations below $C_{crit}$.

Comment: Dynamic volume state variables are used to describe substances that are transported with water flow (usually in dissolved or suspended form, however, they can also be used to model temperature). In contrast, dynamic surface variables are only affected by transformation processes and are not affected by advective, dispersive or diffusive transport processes. For this reason, this type of state variables can be used to describe adsorbed substances. The unit used for the description of
these substances can be chosen by the program user. The program user is responsible to formulate the transformation processes in a way that is consistent with the choice of the units of the state variables. Because typical dissolved concentrations are in the order of 1 mg/m³, but typical adsorbed mass per unit of solid mass is in the order of 10⁻³ mg/m³, it is meaningful to reduce the absolute accuracy of $S$.

Define the following formula variables for general model parameters:

<table>
<thead>
<tr>
<th>Meaning</th>
<th>Name</th>
<th>Unit</th>
<th>Expression</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cross-sectional area, $A$</td>
<td>$A$</td>
<td>m²</td>
<td>0.001</td>
</tr>
<tr>
<td>Porosity, $\theta$</td>
<td>theta</td>
<td></td>
<td>0.4</td>
</tr>
<tr>
<td>Solid phase density, $\rho_s$</td>
<td>$\rho_s$</td>
<td>kg/m³</td>
<td>2300</td>
</tr>
<tr>
<td>Water flow into the column, $Q_{in}$</td>
<td>$Q_{in}$</td>
<td>m³/h</td>
<td>0.001</td>
</tr>
<tr>
<td>Relaxation time constant, $k$</td>
<td>$k$</td>
<td>1/h</td>
<td>10000</td>
</tr>
</tbody>
</table>

Figure 5.19: Definition of the sorption isotherm as a function of calculation number.

Define the following isotherm parameters as formula variables:

<table>
<thead>
<tr>
<th>Meaning</th>
<th>Name</th>
<th>Unit</th>
<th>Expression</th>
</tr>
</thead>
<tbody>
<tr>
<td>Distribution coeff., $K_d$</td>
<td>$K_d$</td>
<td>m⁻³/kg</td>
<td>0.00058</td>
</tr>
<tr>
<td>Maximum site density, $S_{max}$</td>
<td>$S_{max}$</td>
<td>mg/kg</td>
<td>0.00029</td>
</tr>
<tr>
<td>Half-saturation conc., $K$</td>
<td>$K$</td>
<td>mg/m³</td>
<td>0.5</td>
</tr>
<tr>
<td>Freundlich coeff., $K_F$</td>
<td>$K_F$</td>
<td></td>
<td>0.00025</td>
</tr>
<tr>
<td>Freundlich exp., $\alpha$</td>
<td>$\alpha$</td>
<td></td>
<td>0.5</td>
</tr>
<tr>
<td>Crit. conc., $C_{crit}$</td>
<td>$C_{crit}$</td>
<td>mg/m³</td>
<td>0.01</td>
</tr>
</tbody>
</table>

The last parameter is required for the linearization of the Freundlich isotherm at small
concentrations as discussed below. The isotherms can now be defined as formula variables as follows:

<table>
<thead>
<tr>
<th>Meaning</th>
<th>Name</th>
<th>Unit</th>
<th>Expression</th>
</tr>
</thead>
<tbody>
<tr>
<td>No sorption</td>
<td>Seq_O</td>
<td>mg/kg</td>
<td>0</td>
</tr>
<tr>
<td>Linear isoth.</td>
<td>Seq_lin</td>
<td>mg/kg</td>
<td>Kd*C</td>
</tr>
<tr>
<td>Langmuir isoth.</td>
<td>Seq.Langmuir</td>
<td>mg/kg</td>
<td>Smax*C/(K+C)</td>
</tr>
<tr>
<td>Freundlich isoth.</td>
<td>Seq.Freundlch</td>
<td>mg/kg</td>
<td>if C&gt;C_crit then KF<em>C^alpha else KF</em>C_crit^alpha*C/C_crit endif</td>
</tr>
</tbody>
</table>

As an example, the definition of the Freundlich isotherm is shown in Fig. 5.18.

Comment: The Freundlich isotherm cannot be differentiated at zero and it is undefined for negative concentrations. This causes a problem because, due to numerical effects, real concentrations of zero are approximated by very small positive or negative values (many orders of magnitude smaller than realistic concentrations). In order to avoid evaluations of the exponentiation in the isotherm equation for such negative concentrations, the isotherm is linearized below the concentrations C_crit as shown in Fig. 5.18. If the value of this concentration C_crit is very small compared to realistic concentrations, this linearization does not affect the simulation results. Note that at the transition point from the Freundlich to the linear isotherm (at C_crit), both branches of the function have the same value. This is necessary
because the integration algorithm has problems with discontinuous process rates. The example in Fig. 5.18 shows how if-then-else-endif constructs can be used in formula variables. Look at the manual for a more extensive description of the syntax of formula variables.

Save your system definitions to the file `soil.a.aqu` by clicking the command `File→Save As` from the main menu bar and specifying the file name.

Define now the variable `calcnum` as the program variable `Calculation Number` and the variable `t` as the program variable `Time` (with the unit of hours).

It is now possible to define a general sorption isotherm for all calculation numbers as shown in Fig. 5.19. This a variable list variable with the argument `calcnum` leads to the selection of different isotherms for different calculation numbers. Note that the Langmuir isotherm is used for the calculation numbers 2 and 3. This makes it possible to perform calculations with this isotherm for two different input pulse heights which are defined below.

![Edit Variable List Variable](image)

**Figure 5.21:** Definition of the calculation number dependence of the inflow concentration.

As a last definition, the inflow concentrations must be specified. Fig. 5.20 shows the definition of the input concentration pulse as a real list variable `C.in_1` with argument time.

**Comment:** Note that the definition of the input pulse shown in Fig. 5.20 has very steep, but continuous increasing and decreasing branches. This is necessary because the integration algorithm used by AQUASIM is not able to step over discontinuities in inflows or process rates. The steepness can be chosen to be large enough in order not to effect the simulation too much.
5.3. SOIL COLUMN COMPARTMENT

Define the inflow concentration $C_{\text{in}}$ analogously using a peak concentration of 0.2 mg/kg instead of 1 mg/kg. Finally, define the inflow concentration $C_{\text{in}}$ as a function of calculation number as a variable list variable as shown in Fig. 5.21. Note that the two cases with Langmuir isotherm for calculation numbers 2 and 3 have a different inflow concentration.

- **Definition of processes**
  Define now a sorption process as shown in Fig. 5.22. Note that the rate describes relaxation to the (calculation number dependent) sorption equilibrium and that the stoichiometric coefficients are used to convert the units from $C$ to $S$ as described in the user manual.

- **Definition of compartment**
  Define a saturated soil column compartment as shown in Fig. 5.23. Activate the state variables $C$ and $S$ and the process Sorption. Then define the Input as an Inlet Input with a Water Inflow of $Q_{\text{in}}$ and a loading of $Q_{\text{in}} \cdot C_{\text{in}}$ for the variable $C$.

- **Definition of plot**
  Define a plot with abscissa Time and five curves of the variable $C$ at location 1 (end coordinate of the soil column; see Fig. 5.23) for the calculation numbers 0, 1, 2, 3, and 4, respectively.

- **Definition of the simulations**
  Define five simulations with 200 steps of size 0.01 h for the calculation numbers 0, 1, 2, 3, and 4, respectively. Reduce the Number of Codiagonals of the Jacobian Matrix in the dialog box accessed with the menu option Edit→Numerical Parameters to 8.
  Save your system definitions by clicking the command File→Save from the main menu bar.

![Figure 5.22: Definition of the sorption process.](image-url)
Execution of the simulation and presentation of results

Activate all simulations and click the button Start/Continue of the dialog box Simulation. Then plot the five curves defined above. Fig. 5.24 shows the result. This plot clearly shows the retardation due to sorption (a small effect of numerical diffusion is seen in the curve with linear sorption) and the self-sharpening effect of the adsorption fronts and the spreading effect of the desorption fronts for nonlinear sorption. Note that the desorption front of the breakthrough curve with the smaller pulse height is identical to that with the larger pulse height and the same isotherm.

Save your system definitions by clicking the command File→Save from the main menu bar. Answer No to the question to save calculated states.
Figure 5.24: Break-through curves for all isotherms and input peak heights for part A.
Part B
Continue just after doing part A or load the file saved in part A from within the window interface version of AQUASIM. Then perform the following steps:

- **Modification to the system definitions**
  Change the value of the variable relaxation time constant $k$ from 10000 1/h to 100 1/h.
  Save your system definitions to the file soil.b.aqu by clicking the command File→Save As from the main menu bar and specifying the file name.

- **Execution of the simulation and presentation of results**
  First click the button Initialize and then the button Start/Continue of the dialog box Simulation. Then plot the five curves defined in part A. Fig. 5.25 shows the result. It becomes evident that the kinetic effects leads to a smoothing of the sharp edges of the break-through curves with sorption. It is evident that the break-through curve without sorption is not affected by sorption kinetics.
  Save your system definitions by clicking the command File→Save from the main menu bar. Answer No to the question to save calculated states.

![Break through curves](image)

Figure 5.25: Break-through curves for all isotherms and input peak heights for part B.
Part C

Continue just after doing part B or load the file saved in part A from within the window interface version of AQUASIM. Then perform the following steps:

- **Modification of the system definitions**
  If working with the file from part B change the value of the variable relaxation time constant \( k \) from 100 1/h back to 10000 1/h.  
In the dialog box **Edit Saturated Soil Column Compartment** select the radio button with dispersion and insert the value of 0.015 in the edit field for the dispersion coefficient.  
Save your system definitions to the file `soil.c.aqu` by clicking the command **File→Save As** from the main menu bar and specifying the file name.

- **Execution of the simulation and presentation of results**  
  First click the button **Initialize** and then the button **Start/Continue** of the dialog box **Simulation**. Then plot the five curves defined in part A. Fig. 5.26 shows the result. It becomes evident that the dispersion effect leads to very similar results for the break-through curves of the sorbing solutes as the kinetic effect shown in Fig. 5.25. the important difference is that dispersion, in contrast to sorption kinetics, also affects the break-through curve of the nonsorbing solute.

Save your system definitions by clicking the command **File→Save** from the main menu bar. Answer No to the question to save calculated states.

![Break through curves](image)

Figure 5.26: Break-through curves for all isotherms and input peak heights for part C.
Part D
Continue just after doing part C or load the file saved in part A from within the window interface version of AQUASIM. Then perform the following steps:

- **Modification of the system definitions**
  If using the file from part C select the radio button without dispersion in the dialog box *Edit Saturated Soil Column Compartment*.

Define the following formula variables:

<table>
<thead>
<tr>
<th>Meaning</th>
<th>Name</th>
<th>Unit</th>
<th>Expression</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fract. of im. pore vol.</td>
<td>( f_{im}\theta )</td>
<td></td>
<td>0.1</td>
</tr>
<tr>
<td>Fract. of im. sorpt. sites</td>
<td>( f_{im}\text{sorption} )</td>
<td></td>
<td>0.5</td>
</tr>
<tr>
<td>Exchange coefficient, ( q_{ex} )</td>
<td>( q_{ex} )</td>
<td>m(^2)/h</td>
<td>0.025</td>
</tr>
<tr>
<td>Immobile porosity</td>
<td>( \theta_{im} )</td>
<td></td>
<td>( f_{im}\theta_{im}\theta )</td>
</tr>
<tr>
<td>Mobile porosity</td>
<td>( \theta_{mob} )</td>
<td></td>
<td>((1-f_{im}\theta_{im})\theta )</td>
</tr>
<tr>
<td>Immobile isotherm</td>
<td>( S_{eq,im} )</td>
<td>mg/kg</td>
<td>( f_{im}\text{sorption}\times S_{eq} )</td>
</tr>
<tr>
<td>Mobile isotherm</td>
<td>( S_{eq,mob} )</td>
<td>mg/kg</td>
<td>((1-f_{im}\text{sorption})\times S_{eq} )</td>
</tr>
</tbody>
</table>

Define a program variable \( \text{zoneind} \) to refer to *Zone Index*.
Then define the variable list variable \( \theta_{zone} \) to be equal to \( \theta_{mob} \) for zone index 0 and \( \theta_{im} \) for zone index 1 as shown in Fig. 5.27. Analogously define the

![Edit Variable List Variable](image)

**Figure 5.27**: Definition of the porosity of the zone dependent on the zone index.

Then define the variable list variable \( S_{eq,zone} \) to be equal to \( S_{eq,mob} \) for zone index 0 and \( S_{eq,im} \) for zone index 1.
Change the process *Sorption* as shown in Fig. 5.28 by changing \( S_{eq} \) to \( S_{eq,zone} \) and the \( \theta \) in the denominator of the stoichiometric coefficient of \( C \) to \( \theta_{zone} \).
5.3. **SOIL COLUMN COMPARTMENT**

In the dialog box Edit Saturated Soil Column Compartment change the Mob. Vol. Fract. from theta to theta_mob. Then add an immobile region by clicking the button Add. In the dialog box Edit Immobile Region select the Name to be immob and add a mixed zone with Zone Index equal to 1, Vol. Fraction equal to theta_im, Exchange Coefficient equal to q_ex and Conversion Factor equal to 1.

Comment: Note that you can use any nonnegative integer as the zone index. However, because the mobile zone has zone index 0, a zone index of 0 does not help to distinguish the immobile zone from the mobile zone. The zone index of 1 is in accordance with the definitions of the zone dependent variables theta_zone and S_eq_zone (see 5.27).

Save your system definitions to the file soil.d.aqu by clicking the command File→Save As from the main menu bar and specifying the file name.

- **Execution of the simulation and presentation of results**

  First click the button Initialize and then the button Start/Continue of the dialog box Simulation. Then plot the five curves defined in part A. Fig. 5.29 shows the result. It becomes evident that sorption kinetics, immobile regions and dispersion can have very similar effects on break-through curves. This makes it very difficult to identify these processes from break-through curve data.

  Save your system definitions by clicking the command File→Save from the main menu bar. Answer No to the question to save calculated states.
Figure 5.29: Break-through curves for all isotherms and input peak heights for part D.
5.4 River Section Compartment

This example demonstrates how to calculate river hydraulics, sediment transport and transformation processes in a river.

The main AQUASIM feature introduced in this section is the river section compartment.

Problem

Part A: Look at a 2000 m long river section of rectangular geometry with a width of 20 m and a river bed elevation falling from 400 m above sea level at the beginning of the section to 390 m after 1000 m and to 385 m at the end of the section at 2000 m. The inflow to the river section is 5 m$^3$/s, the friction is given by the expression

$$S_f = \frac{1}{K^2_{st}} \frac{P Q^2}{A A^2}$$

where $K^2_{st} = 20$ m$^{1/3}$/s is the friction coefficient according to Strickler, $P$ is the length of the wetted perimeter, $A$ is the cross-sectional area and $Q$ is the discharge in the river.

Calculate water depth, water level and flow velocity profiles for a steady state situation using the kinematic approximation of the open channel flow equations.

Part B: In the river section defined in part A, introduce state variables for dissolved oxygen, for suspended particulate organic substrate (both as concentrations) and for settled organic substrate (as surface density). Look at dispersion-free transport of these substances which are affected by gas exchange, sedimentation and degradation. Define a gas exchange process (proportional to the saturation deficit) with a reaeration coefficient given as

$$K_2 = 0.18v S_f$$

($v$ is the flow velocity) and a saturation concentration of 10 mgO/l. Furthermore define a sedimentation process of particulate organic substrate with a sedimentation velocity of 10 m/d (be careful to convert the concentrations in the water column correctly to the surface densities in the sediment). Add a degradation process of substrate in the water column and in the sediment with a rate of

$$r = k_{deg} \frac{C_{O2}}{K_{O2} + C_{O2}} X_s$$

where $k_{deg} = 5$ d$^{-1}$ is the degradation rate constant, $K_{O2} = 0.5$ gO/m$^3$ is the half-saturation concentration with respect to oxygen, $C_{O2}$ is the concentration of oxygen in the water column, and $X_s$ is the concentration or surface density of substrate in the water column or in the sediment, respectively (the degradation of 1 g of substrate-COD in the water column or in the sediment results in the consumption of 1 g of oxygen from the water column). The inflow concentration of substrate at the upstream end of the river reach is 15 gCOD/m$^3$.

Plot longitudinal profiles of substrate, oxygen, sediment oxygen demand and of the reaeration coefficient after 100 days of simulation.
Part C: Add a weir at the end of the river section that leads to a water end level of 392 m and redo the simulation. Discuss the differences to part B.
5.4. RIVER SECTION COMPARTMENT

Solution
Part A
Start the window interface version of AQUASIM or click the command File→New from the main menu bar to remove previously entered data from memory. Then perform the following steps:

- **Definition of variables**
  Define the program variables \( x \) referring to Space Coordinate \( X \) (m), \( A \) referring to Cross-Sectional Area (m\(^2\)), \( P \) referring to Perimeter Length (m), \( Q \) referring to Discharge (m\(^3\)/d), \( z_0 \) referring to Water Level Elevation (m) and \( S_f \) referring to Friction Slope. Then define the real list variable \( z_B \) for the river bed elevation as shown in Fig. 5.30. Finally, define the following formula variables:

<table>
<thead>
<tr>
<th>Meaning</th>
<th>Name</th>
<th>Unit</th>
<th>Expression</th>
</tr>
</thead>
<tbody>
<tr>
<td>Water depth, ( h_0 )</td>
<td>( h_0 )</td>
<td>m</td>
<td>( z_0 - z_B )</td>
</tr>
<tr>
<td>Strickler friction coefficient, ( K_{st} )</td>
<td>( K_{st} )</td>
<td>m(^{-1}/3)/s</td>
<td>20</td>
</tr>
<tr>
<td>Water inflow rate, ( Q_{in} )</td>
<td>( Q_{in} )</td>
<td>m(^3)/s</td>
<td>5</td>
</tr>
<tr>
<td>River width, ( w )</td>
<td>( w )</td>
<td>m</td>
<td>15</td>
</tr>
<tr>
<td>Flow velocity, ( v )</td>
<td>( v )</td>
<td>m/s</td>
<td>( Q/A/86400 )</td>
</tr>
</tbody>
</table>

Comment: The factor of \( 1/86400 \) (=24*3600) converts m\(^3\)/d to m\(^3\)/s. This is a simple way...
of using the unit of day for simulation time (and therefore m$^3$/d for the program variable Discharge), while allowing the user to define (and plot) the flow velocity in m/s.

- **Definition of compartment**
  Define a river section compartment as shown in Fig. 5.31. In addition to the entries
  
  ![Edit River Section Compartment](image)
  
  Figure 5.31: Definition of the river section compartment.

  shown in this figure, add an initial condition of $86400\times Q_{in}$ for the variable Q and an upstream input with a water inflow of $86400\times Q_{in}$.

  **Comment:** The factor of $86400$ (=24*3600) is used similarly as above to convert the units of the Strickler coefficient from m$^{1/3}$/s to m$^{1/3}$/d. This conversion is useful because it is usual to specify the Strickler coefficient in m$^{1/3}$/s, but it is more comfortable to use days instead of seconds for the simulation time.

  The selection of Dispersion to be present or absent is irrelevant for purely hydraulic calculations without transported substances.

- **Definition of plot**
  Define a plot with the abscissa Space and a curve for the water depth $h_0$ at time 0, a plot with the abscissa Space and a curve for the velocity $v$ at time 0, and a plot with the abscissa Space and a curve for the river bed elevation $z_B$ (solid) and a second curve with the water surface elevation $z_0$ (dotted).

- **Definition of calculation**
  Define a calculation with 100 step of size 1 day.

  Save your system definitions to the file `river.aq` by clicking the command **File→Save As** from the main menu bar and specifying the file name.
5.4. RIVER SECTION COMPARTMENT

- **Execution of the simulation and presentation of results**
  Initialize the simulation by clicking the button **Initialize** in the dialog box **Simulation**. Then plot the results.
  Figure 5.32 shows the water level and the river bed elevation and Fig. 5.33 the velocity profile along the river section. Due to the smaller slope of the river bed the water depth is higher and the flow velocity smaller in the second part of the river reach. Because of the use of the kinematic approximation, in which gravitational forces are everywhere balanced by friction forces, there is an instantaneous transition from one depth to the other at the point where the slope changes. In the diffusive approximation, there is a slightly smoother transition between the two river depths. However, due to the steepness of the river, also with this description the transition range is short.
  Save your system definitions by clicking the command **File→Save** from the main menu bar. Answer **No** to the question to save calculated states.
Figure 5.33: Longitudinal profile of the flow velocity.
5.4. RIVER SECTION COMPARTMENT

Part B
Continue just after doing part A or load the file saved in part A from within the window interface version of AQUASIM. Then perform the following steps:

- **Modification of the system definitions**
  Add dynamic volume state variables $O_2$ for the concentration of oxygen and $X_{S\text{.water}}$ for the concentration of suspended organic particles in the water column. Add a dynamic surface state variable $X_{S\text{.sediment}}$ for the surface density of sediment at the river bed. Then add the following formula variables:

<table>
<thead>
<tr>
<th>Meaning</th>
<th>Name</th>
<th>Unit</th>
<th>Expression</th>
</tr>
</thead>
<tbody>
<tr>
<td>Oxygen exchange coefficient, $K_2$</td>
<td>$K_2$</td>
<td>1/d</td>
<td>$0.18\times Q/A\times S_f$</td>
</tr>
<tr>
<td>Oxygen saturation concentration, $O_{2\text{sat}}$</td>
<td>$O_{2\text{sat}}$</td>
<td>$g/m^3$</td>
<td>10</td>
</tr>
<tr>
<td>Substrate inflow concentration, $X_{S\text{in}}$</td>
<td>$X_{S\text{in}}$</td>
<td>$g\text{COD}/m^3$</td>
<td>15</td>
</tr>
<tr>
<td>Specific degradation rate, $k_{deg}$</td>
<td>$k_{deg}$</td>
<td>1/d</td>
<td>5</td>
</tr>
<tr>
<td>Sedimentation velocity, $v_{sed}$</td>
<td>$v_{sed}$</td>
<td>$m/d$</td>
<td>10</td>
</tr>
<tr>
<td>Sediment oxygen demand, $SOD$</td>
<td>$SOD$</td>
<td>$gO/m^2/d$</td>
<td>$k_{deg}\times X_{S\text{.sediment}}$</td>
</tr>
<tr>
<td>Oxygen half-saturation conc., $K_{O2}$</td>
<td>$K_{O2}$</td>
<td>$gO/m^3$</td>
<td>0.5</td>
</tr>
</tbody>
</table>

Figure 5.34 shows the example of the definition of the formula variable representing sediment oxygen demand.

Save your system definitions to the file river.b.aqu by clicking the command File→Save As from the main menu bar and specifying the file name.

Define now sedimentation as the dynamic process shown in Fig. 5.35 that converts suspended substrate $X_{S\text{.water}}$ to immobile substrate $X_{S\text{.sediment}}$.

**Comment:** The rate $v_{sed}\times X_{S\text{.water}}$ gives the mass of substrate transferred per square meter and day from the water column to the sediment. In this example, the stoichiometric coefficients are not used for characterizing chemical properties but they are used for geometrical conversions. The mass of substrate transformed per square meter and day is equal to the rate of increase in immobile substrate because $X_{S\text{.sediment}}$ is measured in mass per square meter. For this reason, the stoichiometric coefficient for $X_{S\text{.sediment}}$ is equal to 1. The effect of this sedimentation process on the suspended concentration in the vertically well mixed water column is equal to the rate given above divided by the water depth. For this reason, the stoichiometric
coefficient for $X_{S\_water}$ is equal to $-1/hO$. This 'stoichiometric' coefficient converts mass conversion rates per surface area to mass conversion rates per volume.

Create an additional dynamic process for reaeration with a rate equal to $K2\times (O2_{sat}-O2)$ and a stoichiometric coefficient of 1 for the variable $O2$.

Degradation of substrate suspended in the water column is described by an additional dynamic process with a rate of $k_{deg}\times O2/(K02+O2)\times X_{S\_water}$ and stoichiometric coefficients of -1 for the variables $X_{S\_water}$ and $O2$.

Comment: The stoichiometric coefficients for $X_{S\_water}$ and $O2$ are equal because the degraded organic matter is measured in mass of oxygen required for degradation (COD = chemical oxygen demand).

The definition of the last dynamic process for degradation in the sediment is shown in Fig. 5.36. A geometrical conversion of substrate per unit surface area to oxygen per unit volume as shown in Fig. 5.35 is implemented with the aid of the stoichiometric coefficients.

In the river compartment, the state variables $O2$, $X_{S\_water}$ and $X_{S\_sediment}$ must be activated. Similarly the four processes defined above must also be activated. Finally, as shown in Fig. 5.37, input must be specified for oxygen (saturation assumed) and for suspended substrate.

As a last modification, add plots for spatial profiles of oxygen concentrations ($O2$), of substrate concentrations ($X_{S\_water}$ and $X_{S\_sediment}$), and of sediment oxygen demand (SOD) after 100 days of simulation.

Save your system definitions by clicking the command File→Save from the main menu bar.

- **Execution of the simulation and presentation of results**
  Start now a dynamic calculation over 100 days. Figure 5.38 shows the longitudinal
profiles of substrate concentrations in the water column and of substrate surface densities in the sediment. The decrease in concentrations and surface densities does not reflect the differences in hydraulics in the first and second part of the river section. The reason is that the increase in the elimination efficiency caused by the slower motion of the water in the second part of the river section is compensated by the decrease caused by the higher water depth.

Figure 5.39 shows a profile of oxygen concentration along the river. The new sag in the oxygen concentration in the second part of the river section is caused by the decrease in the reaeration coefficient shown in Fig. 5.40.

Save your system definitions by clicking the command File→Save from the main menu bar. Answer No to the question to save calculated states.
Figure 5.37: Definition of input to the river section.
Figure 5.38: Longitudinal profiles of substrate concentrations in the water column and of substrate surface densities in the sediment.
Figure 5.39: Oxygen profile along the river.
Figure 5.40: Change of the reaeration coefficient caused by the change in the slope of the river bed.
Part C
Continue just after doing part B or load the file saved in part B from within the window interface version of AQUASIM. Then perform the following steps:

- **Modification of the system definitions**
  In the dialog box Edit River Section Compartment select the Method to be diffusive and then the End Level to be given with a value of 392 (m).
  
  Comment: Note that backwater effects cannot be described by the kinematic open channel flow equations. For this reason, in AQUASIM, the end level must only be specified if the radio button diffusive is selected.

  Save your system definitions to the file river_b.aqu by clicking the command File→Save As from the main menu bar and specifying the file name.

- **Execution of the calculation and presentation of results**
  Redo the simulations and plot the results. Figure 5.41 shows the river bed and the water level elevations. The effect of the dam is clearly visible. Figure 5.42 shows a longitudinal profile of the oxygen concentration. Due to the increase in water depth and the decrease in flow velocity, the oxygen exchange decreases dramatically. This causes the oxygen depletion to become much more severe than in part B. The Figs. 5.43 and 5.44 show the profiles of the oxygen exchange coefficient and of the flow velocity, respectively.

  Save your system definitions by clicking the command File→Save from the main menu bar. Answer No to the question to save calculated states.
Figure 5.42: Longitudinal profile of oxygen concentrations.
Figure 5.43: Longitudinal profile of the oxygen exchange coefficient.
Figure 5.44: Longitudinal profile of the flow velocity.
5.5 Lake Compartment

The examples of this section demonstrate how to calculate the distribution of dissolved substances in a lake with a given turbulent diffusion coefficient (subsection 5.5.1), how to model the behaviour of particulate components and the sediment (subsection 5.5.2), and how to calculate stratification and mixing as a result of the influence of weather conditions (subsection 5.5.3).

The main AQUASIM feature introduced in this section is the lake compartment.

5.5.1 Transport of Dissolved Substances

Problem

In this subsection transport of a dissolved substance in a lake with a given turbulent diffusion field is discussed.

Part A: Look at a 30 m deep lake with a cross-sectional area that can be interpolated linearly between the following values:

<table>
<thead>
<tr>
<th>depth $z$ [m]</th>
<th>area $A$ [m$^2$]</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>$1 \cdot 10^4$</td>
</tr>
<tr>
<td>10</td>
<td>$8 \cdot 10^6$</td>
</tr>
<tr>
<td>20</td>
<td>$5 \cdot 10^6$</td>
</tr>
<tr>
<td>30</td>
<td>$1 \cdot 10^5$</td>
</tr>
</tbody>
</table>

Assume a vertical turbulent diffusivity profile given as (with linear interpolation)

<table>
<thead>
<tr>
<th>depth $z$ [m]</th>
<th>diffusivity $K_z$ [m$^2$/d]</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>10</td>
</tr>
<tr>
<td>4.9</td>
<td>10</td>
</tr>
<tr>
<td>5.1</td>
<td>0.05</td>
</tr>
<tr>
<td>9.9</td>
<td>0.05</td>
</tr>
<tr>
<td>10.1</td>
<td>0.5</td>
</tr>
<tr>
<td>30.0</td>
<td>0.5</td>
</tr>
</tbody>
</table>

Assume a dissolved tracer to be distributed in the lake according to the initial concentration

$$C_{ini}(z) = C_0 \exp\left(-\frac{(z - z_0)^2}{2\sigma^2}\right)$$

with a peak concentration of $C_0 = 1$ mg/m$^3$, a peak depth of $z_0 = 11$ m, and a peak width (standard deviation) of $\sigma = 0.5$ m.

Calculate the distribution of the tracer during a 100 d period following an injection with the initial concentration given above.
Part B: Define a temperature profile as follows:

<table>
<thead>
<tr>
<th>depth $z$ [m]</th>
<th>temperature $T$ [$^\circ$C]</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>15</td>
</tr>
<tr>
<td>5</td>
<td>15</td>
</tr>
<tr>
<td>10</td>
<td>5</td>
</tr>
<tr>
<td>30</td>
<td>4.8</td>
</tr>
</tbody>
</table>

Use a density given as (Bührer and Ambühl, 1975)

$$
\rho \approx 999.84298 \text{ kg/m}^3 + 10^{-3} \text{ kg/m}^3 \cdot \left( 65.4891^\circ \text{C}^{-1} T - 8.56272^\circ \text{C}^{-2} T^2 + 0.059385^\circ \text{C}^{-3} T^3 \right)
$$

and define the turbulent diffusivity to be given as

$$
K_z = \begin{cases} 
\min \left( K_{z,\text{max}}, \frac{a}{(N^2)^b} \right) & \text{for } N^2 > 0 \\
K_{z,\text{max}} & \text{for } N^2 \leq 0 
\end{cases}
$$

(units are m and d) with $K_{z,\text{max}} = 10 \text{ m}^2/\text{d}$, $a = 13$, $b = 0.35$ and where $N^2$ is the stability frequency

$$
N^2 = -\frac{g}{\rho} \frac{\partial \rho}{\partial z}.
$$

Redo the simulation and compare the resulting concentration profiles and the diffusivity profile with the profile used in part A.

Part C: Add a bottom inflow to the lake with a discharge of 10 m$^3$/s in the depth range between 25 and 30 m and interpret the differences in the resulting concentration profiles during the first 100 d after the tracer injection.
Solution
Part A
Start the window interface version of AQUASIM or click the command File→New from the main menu bar to remove previously entered data from memory. Then perform the following steps:

- **Definition of variables**
  Define a program variable \( z \) referring to **Space Coordinate** \( Z \). Then define a real list variable \( A \) for the cross-sectional area of the lake as shown in Fig. 5.45. Analogously to the cross-sectional area shown in Fig. 5.45, define the depth-dependent vertical turbulent diffusion coefficient as a real list variable \( K_z \) given with the argument \( z \) and the data pairs given in the problem section. Now define a dynamic volume state variable \( C \) for describing the concentration of the dissolved tracer. Finally, define the following formula variables:

<table>
<thead>
<tr>
<th>Meaning</th>
<th>Name</th>
<th>Unit</th>
<th>Expression</th>
</tr>
</thead>
<tbody>
<tr>
<td>Peak concentration, ( C_0 )</td>
<td>( C_0 )</td>
<td>mg/m(^3)</td>
<td>1</td>
</tr>
<tr>
<td>Initial peak depth, ( z_0 )</td>
<td>( z_0 )</td>
<td>m</td>
<td>11</td>
</tr>
<tr>
<td>Initial peak width, ( \sigma )</td>
<td>( \sigma )</td>
<td>m</td>
<td>0.5</td>
</tr>
<tr>
<td>Initial concentration, ( C_{ini} )</td>
<td>( C_{ini} )</td>
<td>mg/m(^3)</td>
<td>( C_0 \exp\left(-\left(z-z_0\right)^2/(2\sigma^2)\right) )</td>
</tr>
</tbody>
</table>
Save your system definitions to the file lake1.aqu by clicking the command File→Save As from the main menu bar and specifying the file name.

- **Definition of compartment**
Define a lake compartment as shown in Fig. 5.46.

![Figure 5.46: Definition of the lake compartment.](image)

Comment: The density can be set to a constant value irrelevant for the current simulation. The density is only relevant if turbulent diffusion is a function of the density stratification of the water column or if the submodel for turbulent kinetic energy (TKE) is active. A dependence of turbulent diffusivity on density stratification can be realized by a parameterization of the diffusivity as a function of the stability frequency $N^2$.

The large number of grid points was chosen to accurately resolve the sharp initial tracer distribution.

In addition to the entries shown in Fig. 5.46, the variable $C$ must be activated and the variable $C_{ini}$ must be specified as the initial condition for the variable $C$.

Comment: With the aid of the buttons **Particulate Variables** and **Dissolved Variables** in the dialog box shown in Fig. 5.46, properties of particulate and dissolved substances can be assigned to state variables. The property for dissolved substances is the molecular diffusivity. An active state variable for which neither particulate nor dissolved properties are defined behaves as a dissolved substance with molecular diffusivity of zero. This is acceptable in the present context, because the molecular diffusivity is only relevant in the sediment submodel which is inactive in this example.

Save your system definitions by clicking the command File→Save from the main menu bar.
• **Definition of plot**
Define a plot with concentration profiles at \( t = 0, 10, 20, 30, 40, 50 \) and 100 d.

• **Definition of simulation**
Define a calculation with 100 steps of one day (calculation number zero, initial time zero and given initial condition). In order to speed up the simulation, reduce the numerical parameter **Number of Codiagonals of the Jacobian Matrix** to 10. Save your system definitions by clicking the command **File→Save** from the main menu bar.

• **Execution of the simulation and presentation of results**
Figure 5.47 shows the concentration profiles plotted after performing a simulation. It is evident that spreading is stronger in direction to the lake bottom of the lake than in direction to the lake surface. The cause for this effect is the very small value of the vertical turbulent diffusion coefficient in depths between 5 and 10 m. The reason for this small value is further analysed in part B and in subsection 5.5.3.

Save your system definitions by clicking the command **File→Save** from the main menu bar. Answer **No** to the question to save calculated states.
Part B
Continue just after doing part A or load the file saved in part A from within the window interface version of AQUASIM. Then perform the following steps:

• **Modification of the system definitions**
  Define temperature as a real list variable $T$ similarly to the definition of the cross-sectional area $A$ shown in Fig. 5.45 but with the data pairs given in the problem section. Then define a program variable $N2$ referring to Brunt Vaisala Frequency and the following formula variables:

<table>
<thead>
<tr>
<th>Meaning</th>
<th>Name</th>
<th>Unit</th>
<th>Expression</th>
</tr>
</thead>
<tbody>
<tr>
<td>Density of water, $\rho$</td>
<td>rho</td>
<td>kg/m$^3$</td>
<td>$999.843 + 0.001 \times (65.4891 \times T - 8.56272 \times T - 2 + 0.059385 \times T^3)$</td>
</tr>
<tr>
<td>Max. turb. diffusivity, $K_z_{\text{max}}$</td>
<td>Kz_max</td>
<td>m$^2$/d</td>
<td>10</td>
</tr>
<tr>
<td>Parameter for $K_z_{N2}$, $a$</td>
<td>a</td>
<td></td>
<td>13</td>
</tr>
<tr>
<td>Parameter for $K_z_{N2}$, $b$</td>
<td>b</td>
<td></td>
<td>0.35</td>
</tr>
<tr>
<td>Turb. diffusivity, $K_z_{N2}$</td>
<td>Kz_N2</td>
<td>d$^2$/d</td>
<td>if $N2 &gt; 0$ then min($Kz_{\text{max}}, a/N2^b$) else $Kz_{\text{max}}$ endif</td>
</tr>
</tbody>
</table>

  (the last definition is shown in Fig. 5.48).

  ![Edit Formula Variable](image)

  **Figure 5.48: Definition of the formula variable $K_z$.**

In the lake compartment replace the expression for Density by $\rho$ and the expression for Turb. Diffusion by $Kz_{N2}$.

Finally, add plots for profiles of $Kz_{\text{given}}$ and $Kz_{N2}$, of $\rho$, and of $T$.

Save your system definitions to the file `lake1b.aqu` by clicking the command File-$\rightarrow$Save As from the main menu bar and specifying the file name.

• **Execution of the calculation and presentation of results**
  After repetition of the simulation, it becomes evident that the results are the same as in part A. Figure 5.49 shows the cause for this result. The new formula for the diffusivity leads to nearly the same values as were used in part A. This shows that the cause for the small values of the diffusivity in the range between 5 and 10 m is the large temperature gradient. In subsection 5.5.3 the cause for the development of such a temperature profile is discussed.

Save your system definitions by clicking the command File-$\rightarrow$Save from the main menu bar. Answer No to the question to save calculated states.
Figure 5.49: Comparison of the given turbulent diffusivity profile used in part A with that calculated from the stability of the water column used in part B.
Part C
Continue just after doing part B or load the file saved in part B from within the window interface version of AQUASIM. Then perform the following steps:

- **Modification of the system definitions**
  Add a formula variable Qin with a value of $10 \times 86400$ (for conversion from m/s to m/d) and add a point input to the lake compartment as shown in Fig. 5.50.

![Figure 5.50: Definition of the bottom input to the lake.](image)

Comment: A point inflow with a mean depth of 27.5 m and a range of 5 m leads to the uniform distribution of the inflow in the depth range between 25 and 30 m.

Save your system definitions to the file `lake1_c.aqu` by clicking the command **File → Save As** from the main menu bar and specifying the file name.

- **Execution of the simulation and presentation of results**
Figure 5.51 shows the concentration profiles plotted after redoing the simulation. The inflow in the depth of the lake induces a vertical upwards movement of the water column (because the default lake outlet is assumed to be at the lake surface) that moves the tracer pulse upwards in addition to the spreading effect from turbulent diffusion. The very small concentration gradient in the depth range between 0 and 5 m reflects the large value of the turbulent diffusivity in this range.

Save your system definitions by clicking the command **File → Save** from the main menu bar. Answer **No** to the question to save calculated states.
Figure 5.51: Calculated concentration profiles at $t = 0, 10, 20, 30, 40, 50$ and $100$ d with a bottom inflow to the lake.
5.5. LAKE COMPARTMENT

5.5.2 Particulate Substances and Sediment

In this subsection a very simple model for lake eutrophication is used to demonstrate sedimentation of algae growing in the epilimnion of a lake and mineralization of the algae in the sediment.

Problem

Part A: Look at a 30 m deep lake with a cross-sectional area that can be interpolated linearly between the following values:

<table>
<thead>
<tr>
<th>depth z [m]</th>
<th>area A [m²]</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>1·10⁸</td>
</tr>
<tr>
<td>10</td>
<td>8·10⁶</td>
</tr>
<tr>
<td>20</td>
<td>5·10⁶</td>
</tr>
<tr>
<td>30</td>
<td>1·10⁵</td>
</tr>
</tbody>
</table>

Assume a vertical turbulent diffusivity profile given as (with linear interpolation)

<table>
<thead>
<tr>
<th>depth z [m]</th>
<th>diffusivity K_z [m²/c]</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>10</td>
</tr>
<tr>
<td>4.9</td>
<td>10</td>
</tr>
<tr>
<td>5.1</td>
<td>0.05</td>
</tr>
<tr>
<td>9.9</td>
<td>0.05</td>
</tr>
<tr>
<td>10.1</td>
<td>0.5</td>
</tr>
<tr>
<td>30.0</td>
<td>0.5</td>
</tr>
</tbody>
</table>

Implement a simple lake model with the dissolved component phosphate (concentration $C_{PO4}$) and with the particulate components Algae (concentration $X_{Algae}$) and Inert organic matter (concentration $X_{Inert}$). The molecular diffusivity for phosphate is given (approximately) as $1·10^{-4}$ m²/d, the density of the organic components $X_{Algae}$ and $X_{Inert}$ is assumed to be $1·10^5$ g/m³ (dry mass), and the sedimentation velocity of the particles is $v_{sed} = 0.1$ m/d for depths between 0 and 5 m, 1 m/d for depths below 10 m and a linearly interpolated value in between for depths between 5 and 10 m. The inflow to the lake is $10$ m³/s and contains phosphate in a concentration $C_{PO4,in} = 0.05$ gP/m³. The inflow is uniformly distributed to the epilimnion which consists of the range of depths between 0 and 5 m. Mineralization of dead algae in the sediment leads to a flux of $0.002$ gP/(m²d) from the sediment to the water column. The initial concentration of algae is $2$ g/m³ for depths between 0 and 5 m and $0.3$ g/m³ for depths below 5 m.

Define the process of primary production with a rate of

$$r_{prod} = k_{prod} 0.5m^{-1}z \frac{C_{PO4}}{0.01g/m³ + C_{PO4}} X_{Algae}$$

with $k_{prod} = 0.5$ d⁻¹ and with stoichiometric coefficients of +1 for algae and $-\alpha_P$ for phosphate (use a numeric value of 0.01 for the phosphorus content of algae.
$\alpha_P$). In the expression given above, $z$ is the depth (distance from the surface) and the factor $e^{0.5m^{-1}z}$ accounts for light attenuation. Define the process of mineralization with a rate of

$$r_{min} = k_{min} X_{Algae}$$

with $k_{min} = 0.05 \text{ d}^{-1}$ and with stoichiometric coefficients of -1 for algae, 0.2 for inert organic matter and 0.8$\alpha_P$ for phosphate.

Perform now a simulation for 100 a and discuss the shape of the profiles of algae, inert organic matter and phosphate after 0, 1, 2, 3, 4, 5, 10, and 100 a.

**Part B:** Add a sediment layer with a thickness of 2 cm and a porosity of 0.8 to the lake. Replace the given phosphate flux from the sediment to the lake by the calculated phosphate flux resulting from mineralization of dead algae in the sediment (be careful to turn off primary production in the sediment).

Redo the simulation, compare the results with those from part A and discuss the behaviour of the concentrations of phosphate, algae and inert organic matter in the sediment layer.

**Part C:** Replace the sediment model consisting of one mixed layer of 2 cm thickness by a three layer model with a 0.5 cm thick top layer, a 1 cm thick middle layer and a 2 cm thick bottom layer.

Redo the simulation, compare the results with those from part B and discuss the behaviour of the concentrations of phosphate, algae and inert organic matter in the sediment layers.
Solution
Part A
Start the window interface version of AQUASIM or click the command File→New from the main menu bar to remove previously entered data from memory. Then perform the following steps:

- **Definition of variables**
  Define a program variable \( z \) referring to Space Coordinate \( Z \). Then define a real list variable \( A \) for the cross-sectional area of the lake as shown in Fig. 5.45 in section 5.5.1. Analogously to the cross-sectional area shown in Fig. 5.45, define the depth-dependent vertical turbulent diffusion coefficient and the depth dependent sedimentation velocities as real list variables \( K_z \_given \) and \( v_{sed} \) with data pairs given in the problem section, respectively. Then define a real list variable \( epi\_ind \) as shown in Fig. 5.52.

![Figure 5.52: Definition of an indicator variable for the epilimnion of the lake.](image)

Comment: The real list variable \( epi\_ind \) shown in Fig. 5.52 is 1 for depths between 0 and 4.9 m (in the epilimnion) and 0 for values of the depth larger than 5.1 m. This variable simplifies the definition of variables which take different values for depths between 0 and 4.9 m than for depths larger than 5.1 m. In the present example, this variable is used for the specification of the initial condition of algae shown below in Fig. 5.55.

Now define dynamic volume state variables \( C\_P04 \) for phosphate, \( X\_Algae \) for algae and \( X\_Inert \) for inert organic particles. Finally, define the following formula variables:
### CHAPTER 5. COMPARTMENTS

<table>
<thead>
<tr>
<th>Meaning</th>
<th>Name</th>
<th>Unit</th>
<th>Expression</th>
</tr>
</thead>
<tbody>
<tr>
<td>Water inflow, $Q_{in}$</td>
<td>$Q_{in}$</td>
<td>m$^3$/d</td>
<td>$10 \times 86400$</td>
</tr>
<tr>
<td>Phosphate inflow conc., $C_{PO4,in}$</td>
<td>$C_{PO4,in}$</td>
<td>gP/m$^3$</td>
<td>0.05</td>
</tr>
<tr>
<td>Phosphate fraction of algae, $\alpha_P$</td>
<td>$\alpha_P$</td>
<td></td>
<td>0.01</td>
</tr>
<tr>
<td>Mol. diff. of phosphate, $D$</td>
<td>$D$</td>
<td>m$^{-2}$/d</td>
<td>0.0001</td>
</tr>
<tr>
<td>Spec. mineralization rate, $k_{min}$</td>
<td>$k_{min}$</td>
<td>1/d</td>
<td>0.05</td>
</tr>
<tr>
<td>Max. spec. production rate, $k_{prod}$</td>
<td>$k_{prod}$</td>
<td>1/d</td>
<td>0.5</td>
</tr>
<tr>
<td>Density of organic material, $\rho_{org}$</td>
<td>$\rho_{org}$</td>
<td>g/m$^3$</td>
<td>100000</td>
</tr>
</tbody>
</table>

Save your system definitions to the file lake2.a.aqu by clicking the command File→Save As from the main menu bar and specifying the file name.

- **Definition of processes**
  Define two dynamic processes as shown in Figs. 5.53 and 5.54.

![Edit Dynamic Process](image)

**Figure 5.53: Definition of the production process.**

**Comment:** The rate of the production process shown in Fig. 5.53 is proportional to the algae concentration, it has a monod-type rate limitation with respect to phosphorus and a light limitation with an exponential decrease with depth due to light absorption. The stoichiometry of the process specifies a consumption of $\alpha_P$ units of phosphorus per unit of algae produced. In this simple example no other substances (such as oxygen or nitrogen) are considered.

The rate of the mineralization process shown in Fig. 5.54 is proportional to the algae concentration. In the stoichiometry of this process it is assumed that 20% of the transformed algae are converted to inert organic material and 80% of the transformed algae are mineralized. This leads to the release of 80% of the phosphorus content of the transformed algae in the form of phosphate (the other 20% remain bound in the inert organic fraction).

Save your system definitions by clicking the command File→Save from the main menu bar.
5.5. LAKE COMPARTMENT

- **Definition of compartment**
  Open now the dialog box for defining a new lake compartment. Activate the state variables \( C_{PO4} \), \( X_{Algae} \) and \( X_{Inert} \) and the processes production and mineralization. Then define an initial condition for the state variable \( X_{Algae} \) as shown in Fig. 5.55.

![Figure 5.54: Definition of the mineralization process.](image)

![Figure 5.55: Definition of the initial condition for algae.](image)

Comment: The specification of the initial condition shown in Fig. 5.55 demonstrates a way of specifying a depth-dependency with the aid of a formula variable using the epilimnion indicator variable shown in Fig. 5.52. This is an alternative to the definition directly with the aid of real list variables.

Now define a point input (of water and phosphate) into the epilimnion as shown in Fig. 5.56 and a sediment input flux for phosphate (\( C_{PO4} \)) of 0.002 (gP/(m²d)). By clicking the button Particulate Variables define the variables \( X_{Algae} \) and \( X_{Inert} \) as particulate variables with a Density of \( \rho_{org} \) and a Sedimentation Velocity of \( \nu_{sed} \). By clicking the button Dissolved Variables define the variable \( C_{PO4} \) as a dissolved variable with a Molecular Diffusivity of \( D \). Now set the
Gravitation Acceleration to $7.3 \times 10^{10}$ (m$^2$/d), the Top Coordinate to 0 (m), the Bottom Coordinate to 30 (m), the Cross Sectional Area to A, the Density to 1000 (kg/m$^3$), the Turbulent Diffusion to $K_z$ given, and the Number of Grid Points to 32. Let the Mode to be without Sediment and without TKE and the Resolution to be low.

Save your system definitions by clicking the command File→Save from the main menu bar.

- **Definition of plots**
  Define 3 plots with spatial profiles of phosphate ($C_{P04}$), of algae ($L_{Algae}$) and of inert organic material ($L_{Inert}$) at 0 d, 365 d, 730 d, 1095 d, 1460 d, 1825 d, 3650 d and 36500 d, respectively.

- **Definition of simulation**
  Define a calculation with 10 steps of 365 d followed by 9 steps of 3650 d. Set the numerical parameter **Number of Codiagonals of the Jacobian Matrix** to 8.
  Save your system definitions by clicking the command File→Save from the main menu bar.

- **Execution of the simulation and presentation of results**
  Start now the simulation. Figure 5.57 shows the profiles of algae and Fig. 5.58 the profiles of phosphate at the points of time specified above. The algae profiles show the effect of growth in the epilimnion and sedimentation with an increased velocity below 5 m. The phosphate profile demonstrate the diffusion of phosphate back from the sediment to the epilimnion where it is consumed by growing algae.

Save your system definitions by clicking the command File→Save from the main menu bar.
Figure 5.57: Calculated algal profiles after 0, 1, 2, 3, 4, 5, 10 and 100 years.
Figure 5.58: Calculated phosphate profiles after 0, 1, 2, 3, 4, 5, 10 and 100 years.
Part B
Continue just after doing part A or load the file saved in part A from within the window interface version of AQUASIM. Then perform the following steps:

- **Modification of the system definitions**
  Define a program variable `zoneindex` referring to Zone Index and, using this variable as an argument, a real list variable `water_ind` as shown in Fig. 5.59.

![Figure 5.59: Definition of the water index.](image)

Comment: If the zone indices of the sediment layers are set to values larger than or equal to 1 (see below), the variable `water_ind` is 1 in the water column and 0 in the sediment.

Now change the process production by multiplying the rate with the variable `water_ind` as shown in Fig. 5.60.

Comment: The multiplication of the production rate with the variable `water_ind` turns off this process in the sediment. This is only done for the production process; mineralization is very important in the sediment.

Delete the sediment input flux of phosphate in the lake compartment, select the radio button with sediment in the dialog box Edit Lake Compartment and define a sediment layer with a Thickness of 0.02 m and a Porosity of 0.8 as shown in Fig. 5.61. Finally, define plots of phosphate, algae and inert particles in the sediment. Use the same point in time as for the concentrations in the water column. This can be done
Figure 5.60: Definition of the modified production process (multiplication of the rate by \texttt{water\_ind}).

by duplicating the plot definitions for the water column and changing the zones of all curves from \texttt{water\_column} to sediment layer 1.

Increase the numerical parameter \texttt{Number of Codionals of the Jacobian Matrix} to 16 in order to consider the increased number of state variables to be calculated at any grid point.

Save your system definitions to the file \texttt{lake2.b.aqu} by clicking the command \texttt{File}→\texttt{Save As} from the main menu bar and specifying the file name.

- Execution of the simulation and presentation of results
  
  Redo the simulation. The Figs. 5.62 and 5.63 show the concentrations of algae in the sediment and of phosphate in the pore water, respectively. It is evident that starting with no algae in the sediment a steady state in which the input of algae by sedimentation is balanced by mineralization is approximately reached after 10 years. The phosphate concentration in the sediment layer is higher than in the water column. This concentration difference drives the diffusive flux of phosphate from the sediment to the water column.

  Save your system definitions by clicking the command \texttt{File}→\texttt{Save} from the main menu bar. Answer \texttt{No} to the question to save calculated states.
Figure 5.61: Definition of the sediment layer.
CHAPTER 5. COMPARTMENTS

Figure 5.62: Algae concentration in the sediment.
Figure 5.63: Phosphate concentration in the pore water of the sediment.
Part C
Continue just after doing part B or load the file saved in part B from within the window interface version of AQUASIM. Then perform the following steps:

- **Modification of the system definitions**
  Change the single sediment layer used in part B to a thickness of 0.005 m and add two additional sediment layers as shown in Fig. 5.64. Add additional plots for phosphate, algae, and inert organic particles in the deeper sediment layers. Increase the numerical parameter Number of Codiagonals of the Jacobian Matrix to 32 in order to account for the increased number of state variables to be calculated in each grid point. Save your system definitions to the file lake2_c.aqu by clicking the command File→Save As from the main menu bar and specifying the file name.

- **Execution of the simulation and presentation of results**
  Redo the simulation. The Figs. 5.65, 5.66 and 5.67 show the algae profiles in the three sediment layers. Due to mineralization, the concentration of algae decreases strongly from the top to the bottom layer of the sediment.

Save your system definitions by clicking the command File→Save from the main menu bar. Answer No to the question to save calculated states.
Figure 5.65: Algae profiles in the top sediment layer.
Figure 5.66: Algae profiles in the middle sediment layer.
Figure 5.67: Algae profiles in the bottom sediment layer.
5.5.3 Turbulence Modelling

Problem

In this subsection, a brief introduction to the turbulence submodel of the lake compartment is given.

Part A: Look at a 30 m deep lake with a cross-sectional area that can be interpolated linearly between the following values:

<table>
<thead>
<tr>
<th>depth $z$ [m]</th>
<th>area $A$ [m$^2$]</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>1 \cdot 10$^7$</td>
</tr>
<tr>
<td>10</td>
<td>8 \cdot 10$^6$</td>
</tr>
<tr>
<td>20</td>
<td>5 \cdot 10$^6$</td>
</tr>
<tr>
<td>30</td>
<td>1 \cdot 10$^5$</td>
</tr>
</tbody>
</table>

Implement the standard $k$-$\epsilon$ model with a production term for dissipation given by

$$c_1 (P + c_3 G) \frac{\epsilon}{k} - c_2 \frac{\epsilon^2}{k}$$

with $c_1 = 1.44$, $c_2 = 1.92$, $c_3 = 0$ and initial conditions of $k_{ini} = 10^5$ m$^2$/d$^2$ and $\epsilon_{ini} = 10^8$ m$^2$/d$^3$. Use a turbulent diffusivity given by

$$K_z = \min \left( \frac{c_\mu k^2}{\epsilon} \frac{1}{Pr}, K_{z,min} \right)$$

with $c_\mu = 0.09$, $Pr = 1$ and $K_{z,min} = 0.05$ m$^2$/d. The density of water can be approximated by

$$\rho_{water} \approx 999.84298 \text{ kg/m}^3 + 10^{-3} \text{ kg/m}^3 \cdot \left( 65.4891 \circ C^{-1} T \right. \right.$$  
$$\left. - 8.56272 \circ C^{-2} T^2 + 0.059385 \circ C^{-3} T^3 \right)$$

Assume a constant (average) short-wave radiation of $H = 100$ W/m$^2$ which decreases exponentially with water depth according to

$$H_z = H \exp(-\lambda z)$$

(note that this leads to a heat input to the water column of $H \lambda \exp(-\lambda z)$).

Calculate profiles of temperature and turbulent kinetic energy after 0, 1, 2, 3, 4, 5 and 10 days of simulation starting with an initial temperature distribution given by:

<table>
<thead>
<tr>
<th>depth $z$ [m]</th>
<th>temperature $T$ [$\circ C$]</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>5.2</td>
</tr>
<tr>
<td>30</td>
<td>4.8</td>
</tr>
</tbody>
</table>
5.5. LAKE COMPARTMENT

Part B: To the model developed in part A add a surface shear of

$$\rho_{\text{air}}c_{10}w_{10}^2 \text{sign}(w_{10})$$

with the density of air given as \(\rho_{\text{air}} = 1.2 \text{ kg/m}^3\), a drag coefficient of \(c_{10} = 0.001\) and with a Sinus-shape wind velocity \(w_{10}\) with an amplitude of 2.5 m/s and a period of one day.

Redo the simulation, compare the profiles of temperature and turbulent kinetic energy with those calculated in part A and discuss the profiles for the stability frequency \(N^2\) and the horizontal velocity induced in the water column.

Part C: To the model developed in parts A and B add a seiche submodel with a wind excitation of seiche oscillation given by

$$\alpha A \rho_{\text{air}} c_{10} w_{10}^3$$

and with a decay rate of seiche energy of

$$\frac{E_{\text{seiche}}}{V \rho_{\text{water}} \tau_{\text{seiche}}}$$

with \(\alpha = 0.0001\), \(A\) equal to the lake surface area, the lake volume of \(V = 1.805 \cdot 10^8\) m\(^2\) and a decay time constant of \(\tau_{\text{seiche}} = 3\) d.

Redo the simulation and compare the results with those of part B.
Solution

Part A

Start the window interface version of AQUASIM or click the command File→New from the main menu bar to remove previously entered data from memory. Then perform the following steps:

- **Definition of variables**

  Define a program variable \( z \) referring to Space Coordinate \( Z \) (unit: m), a program variable \( \text{tke} \) referring to Turbulent Kinetic Energy (unit: \( m^2/d^2 \)), a program variable \( \text{eps} \) referring to Dissipation (unit: \( m^2/d^3 \)), a program variable \( N_2 \) referring to Brunt–Vaisala Frequency (unit: \( 1/d^2 \)), a program variable \( P \) referring to Shear Production of TKE (unit: \( m^2/d^3 \)), and a program variable \( G \) referring to Buoyancy Production of TKE (unit: \( m^2/d^3 \)). Then define a state variable \( T \) for temperature, a real list variable \( A \) for the cross-sectional area of the lake as shown in Fig. 5.45 in section 5.5.1, and a real list variable \( \text{T.ini} \) with the data pairs given in the problem section. Finally, define the following formula variables:

<table>
<thead>
<tr>
<th>Meaning</th>
<th>Name</th>
<th>Unit</th>
<th>Expression</th>
</tr>
</thead>
<tbody>
<tr>
<td>Specific heat of water, ( c )</td>
<td>( c )</td>
<td>J/(kgK)</td>
<td>4186</td>
</tr>
<tr>
<td>Coeff. of turb. model, ( c_1 )</td>
<td>( c_1 )</td>
<td></td>
<td>1.44</td>
</tr>
<tr>
<td>Coeff. of turb. model, ( c_2 )</td>
<td>( c_2 )</td>
<td></td>
<td>1.92</td>
</tr>
<tr>
<td>Coeff. of turb. model, ( c_3 )</td>
<td>( c_3 )</td>
<td></td>
<td>0</td>
</tr>
<tr>
<td>Coeff. of turb. model, ( \mu )</td>
<td>( \mu )</td>
<td></td>
<td>0.09</td>
</tr>
<tr>
<td>Prandtl number, ( Pr )</td>
<td>( Pr )</td>
<td></td>
<td>1</td>
</tr>
<tr>
<td>Init. val. for TKE, ( k_{ini} )</td>
<td>( k_{ini} )</td>
<td>m^2/d^2</td>
<td>100000</td>
</tr>
<tr>
<td>Init. val. for dissip., ( \epsilon_{ini} )</td>
<td>( \epsilon_{ini} )</td>
<td>m^2/d^3</td>
<td>1e8</td>
</tr>
<tr>
<td>Log of TKE, ( \log(k) )</td>
<td>( \log_{tke} )</td>
<td>log10(m^2/s^2)</td>
<td>log10(tke/86400^2)</td>
</tr>
<tr>
<td>Log of dissipation, ( \log(\epsilon) )</td>
<td>( \log_{eps} )</td>
<td>log10(m^2/s^3)</td>
<td>log10(eps/86400^3)</td>
</tr>
<tr>
<td>Minimum for ( K_z ), ( K_z, \text{min} )</td>
<td>( K_z, \text{min} )</td>
<td>m^2/d</td>
<td>0.05</td>
</tr>
<tr>
<td>Turbulent diffusivity, ( K_z )</td>
<td>( K_z )</td>
<td>m^2/d</td>
<td>max(cmu*tke^2/eps/Pr, ( K_z, \text{min} ))</td>
</tr>
<tr>
<td>Log of ( K_z ), ( \log(K_z) )</td>
<td>( \log_{Kz} )</td>
<td>log10(m^2/s)</td>
<td>log10(Kz/86400)</td>
</tr>
<tr>
<td>Solar radiation, ( H )</td>
<td>( H )</td>
<td>W/m^2</td>
<td>100</td>
</tr>
<tr>
<td>Light extinction coeff., ( \lambda )</td>
<td>( \lambda )</td>
<td>1/m</td>
<td>0.5</td>
</tr>
<tr>
<td>Density of water, ( \rho_{\text{water}} )</td>
<td>( \rho_{\text{water}} )</td>
<td>kg/m^3</td>
<td>999.843</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>+0.001*(65.4891*T)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>-8.56272*T^-2</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>+0.059385*T^-3</td>
</tr>
</tbody>
</table>

As an example, the definition of the variable \( K_z \) is shown in Fig. 5.68.

Comment: Note that \( \log_{10} \) must be used for the logarithm with base 10 and that formula variables can be used to convert units e.g. for plotting (the variables \( N_2, \log_{tke} \) and \( \log_{eps} \) are only defined for plotting).

Many variables (the program variables \( \text{tke}, \text{eps}, P \) and \( G \) and the formula variables \( c_1, c_2, c_3, \mu, Pr \)) are defined here in order to allow to formulate the standard \( k-c \) turbulence model later on in a transparent way (using variables; see Fig. 5.71).

Save your system definitions to the file \( \text{lake3.a.aqu} \) by clicking the command File→Save As from the main menu bar and specifying the file name.
5.5. LAKE COMPARTMENT

Figure 5.68: Definition of the diffusivity $K_z$.

- **Definition of process**
  Define a process for heating by solar radiation as shown in Fig. 5.69.

Figure 5.69: Definition of the process of heating by solar radiation.

Comment: The definition of the process rate for temperature is a little bit more complicated than for substances that are converted chemically. The reason for this is that heat (energy) fluxes are the physically meaningful quantities and not temperature fluxes. The division of the heat flux $H$ by the factor $\rho_{water}c$ in the rate expression shown in Fig. 5.69 accounts for this difference. Furthermore, the surface heat flux $H$ is distributed within some meters of the water column. The factor $\lambda*\exp(-\lambda z)$ considers the exponential decrease in light intensity and distributes the rate of temperature accordingly. Finally, the factor 86400 converts the time units of s used for the formulation of $H$ to the time units of d used for the simulation.

- **Definition of compartment**
  Define a lake compartment as shown in Fig. 5.70. In addition to the entries shown in Fig. 5.70 activate the state variable $T$ and the process Heating, define the initial
conditions for T, tke and eps to be T.ini, tke.ini and eps.ini, and specify the submodel for turbulent kinetic energy as shown in Fig. 5.71 (the dialog box shown in Fig. 5.71 is opened by clicking the button TKE Prop. in the dialog box shown in Fig. 5.70).

Comment: The correction factors of 1 (Sigma TKE) and of 1.3 (Sigma Diss.) as well as the expression c1*(P+c3*G)*eps/tke-c2*eps^-2/tke correspond to the standard k-ε model for stratified fluids. The reason that this expression for production of dissipation is not implemented in the program but must be specified by the user is to allow the user more flexibility in changing this empirical rate of dissipation. The disadvantage is, however, that this makes the turbulence submodel more difficult to use. It is recommended that this tutorial file is used as a base for lake turbulence model implementations instead of starting from scratch.

Save your system definitions by clicking the command File→Save from the main menu.

- **Definition of plots**
  Define plots for profiles of the variables T, log.tke, log.eps, N2, rho.water and log.Kz for simulation times of 0, 1, 2, 3, 4, 5 and 10 days (use the button Duplicate for duplicating plot definitions and then modify the comments and plot variables).

- **Definition of simulation**
  Define a calculation with 101 steps of size 0.1 (d) and reduce the number of codiagonals of the Jacobian matrix to 12 (in the dialog box opened by clicking the command Numerical Parameters in the Edit menu). Finally, by clicking the button Acc. in the dialog box Edit Lake Compartment select the accuracies of the program variables in the lake compartment as shown in Fig. 5.72.
5.5. LAKE COMPARTMENT

Figure 5.71: Definition of the submodel for turbulent kinetic energy.

Figure 5.72: Definition of the accuracies of program variables in the lake compartment.

Comment: Since many variables of the turbulence submodel are integrated numerically as program variables, the numerical accuracy of program variables is of special importance in the lake compartment. All accuracies should carefully be selected according to the typical size of the variables in the units selected by the program users. Because the Turbulent Kinetic Energy and the Dissipation vary over many orders of magnitude within a given lake profile (without becoming zero), it is not meaningful to specify an absolute accuracy. It is more advantageous to specify a pure relative accuracy as it is done in the example shown in Fig. 5.72.

Save your system definitions by clicking the command File→Save from the main menu bar.

• Execution of the simulation and presentation of results
Start now the simulation and look at the results. As examples of the results, in Figs. 5.73, 5.74 and 5.75 the temperature profiles, the profiles of turbulent kinetic energy, and the profiles of turbulent diffusivity are shown.

The temperature profiles clearly reflect the surface heating. Because there is no wind
and no cooling during the night, the stratification extends to the surface and no mixed surface layer (epilimnion) develops. Due to this missing input of turbulence-generating energy, the profiles of turbulent kinetic energy only show the gradual decrease of turbulence over time. Already after one day, the turbulent diffusivity, $K_z$, takes its minimum value, $K_{z,\text{min}}$.

Save your system definitions by clicking the command File→Save from the main menu bar. Answer No to the question to save calculated states.
Figure 5.74: Profiles of turbulent kinetic energy after 0, 1, 2, 3, 4, 5 and 10 days of simulation.
Figure 5.75: Profiles of turbulent diffusivity after 0, 1, 2, 3, 4, 5 and 10 days of simulation.
5.5. LAKE COMPARTMENT

Part B
Continue just after doing part A or load the file saved in part A from within the window interface version of AQUASIM. Then perform the following steps:

- **Modification of the system definitions**
  Define a program variable t referring to Time (unit: d) and a program variable Uprog referring to Horizontal Velocity (unit: m/d). Then define the following formula variables:

<table>
<thead>
<tr>
<th>Meaning</th>
<th>Name</th>
<th>Unit</th>
<th>Expression</th>
</tr>
</thead>
<tbody>
<tr>
<td>Horizontal velocity, U</td>
<td>U</td>
<td>m/s</td>
<td>Uprog/86400</td>
</tr>
<tr>
<td>Density of air, ( \rho_{air} )</td>
<td>rho_air</td>
<td>kg/m(^3)</td>
<td>1.2</td>
</tr>
<tr>
<td>Drag coefficient, ( c_{10} )</td>
<td>c..10</td>
<td></td>
<td>0.001</td>
</tr>
<tr>
<td>Wind speed 10 m above water level, ( w_{10} )</td>
<td>u10</td>
<td>m/s</td>
<td>2.5*\sin(2*\pi*t)</td>
</tr>
</tbody>
</table>

Now add surface shear to the turbulence submodel as shown in Fig. 5.76.

![Edit Lake Turbulent Kinetic Energy Submodel](image)

Figure 5.76: Definition of the turbulence submodel with surface shear by the wind.

Save your system definitions to the file `lake3_b.aqu` by clicking the command **File→Save As** from the main menu bar and specifying the file name.

- **Execution of the simulation and presentation of results**
  Redo now the simulation and plot the results. Figure 5.77 shows the temperature profiles. In contrast to the profiles in part A (Fig. 5.73), due to the wind mixing at the surface, a mixed surface layer develops. The wind-induced turbulence is even clearer shown in the profiles of turbulent kinetic energy shown in Fig. 5.78 and in the profiles of turbulent diffusivity shown in Fig. 5.79. Figure 5.80 shows the stability resulting from the temperature-gradient induced density gradient around 5 m depth, and Fig. 5.81 shows the profiles of horizontal velocities in the water induced by the wind.

Save your system definitions by clicking the command **File→Save** from the main menu bar. Answer No to the question to save calculated states.
Figure 5.77: Temperature profiles after 0, 1, 2, 3, 4, 5 and 10 days of simulation.
5.5. LAKE COMPARTMENT

Figure 5.78: Profiles of turbulent kinetic energy after 0, 1, 2, 3, 4, 5 and 10 days of simulation.
Figure 5.79: Profiles of turbulent diffusivity after 0, 1, 2, 3, 4, 5 and 10 days of simulation.
Figure 5.80: $N^2$ profiles after 0, 1, 2, 3, 4, 5 and 10 days of simulation.
Figure 5.81: Velocity profiles after 0, 1, 2, 3, 4, 5 and 10 days of simulation.
Part C
Continue just after doing part B or load the file saved in part B from within the window interface version of AQUASIM. Then perform the following steps:

- **Modification of the system definitions**
  Define a program variable Eseiche referring to Energy of Seiche Oscillation (unit: m^2kg/d^2). Then define the following formula variables:

<table>
<thead>
<tr>
<th>Meaning</th>
<th>Name</th>
<th>Unit</th>
<th>Expression</th>
</tr>
</thead>
<tbody>
<tr>
<td>Energy fraction, (\alpha)</td>
<td>alpha</td>
<td></td>
<td>0.0001</td>
</tr>
<tr>
<td>Log of Eseiche</td>
<td>log_Eseiche</td>
<td>log10(J/Kg)</td>
<td>if Eseiche&gt;0 then log10(Eseiche/V/ (\rho_{\text{water}}/86400^2)) else -20 endif</td>
</tr>
<tr>
<td>Seiche decay, (P_{\text{seiche}})</td>
<td>Pseiche</td>
<td>m^2/d^3</td>
<td>Eseiche/V/(\rho_{\text{water}})/tau_seiche</td>
</tr>
<tr>
<td>Decay time, (T_{\text{seiche}})</td>
<td>tau_seiche</td>
<td>d</td>
<td>3</td>
</tr>
<tr>
<td>Lake volume, (V)</td>
<td>V</td>
<td>m^3</td>
<td>1.805e+008</td>
</tr>
</tbody>
</table>

Now add wind excitation (of seiche) and the power of seiche energy decay as an additional contribution to the dissipation and as internal friction to the turbulence submodel as shown in Fig. 5.82.

![Edit Lake Turbulent Kinetic Energy Submodel](image)

Figure 5.82: Definition of the turbulence submodel with seiche oscillation.

Save your system definitions to the file lake3.c.aqu by clicking the command File→Save As from the main menu bar and specifying the file name.

- **Execution of the simulation and presentation of results**
  Redo the simulation and plot the results. Figure 5.77 shows the temperature profiles. The results are nearly equal to those calculated in part B (cf. Fig. 5.77). The profiles of turbulent kinetic energy shown in Fig. 5.83 are significantly different. The decay of turbulent kinetic energy in the hypolimnion is stopped by the transfer of energy from seiche oscillation to turbulence. The turbulent diffusivities shown in Fig. 5.85 show a
minimum in depths between 5 and 10 m and increase not only above these depths as in part B but also below. Finally, in the present steady state conditions, as shown in Fig. 5.86 the energy of seiche oscillation reaches an equilibrium, where production is equal to transfer to turbulence.

Save your system definitions by clicking the command File → Save from the main menu bar. Answer No to the question to save calculated states.

Figure 5.83: Temperature profiles after 0, 1, 2, 3, 4, 5 and 10 days of simulation.
Figure 5.84: Profiles of turbulent kinetic energy after 0, 1, 2, 3, 4, 5 and 10 days of simulation.
Figure 5.85: Profiles of turbulent diffusivity after 0, 1, 2, 3, 4, 5 and 10 days of simulation.
Figure 5.86: Time series of seiche energy in the lake.
Chapter 6

Batch Processing

In this last chapter, examples of the application of the batch version of AQUASIM are given. These short examples are recommended to experienced users who often have to process computationally demanding simulations, sensitivity analyses or parameter estimations, or who want to use AQUASIM as a simulation tool that is controlled from external programs (e.g. for profiling $\chi^2$ surfaces or for executing Monte Carlo simulations).

The example discussed in section 6.1 demonstrates the execution of usual AQUASIM tasks in batch mode. The example discussed in section 6.2 shows how the batch version of AQUASIM can be used to generate results that can be processed by other programs for parameter values also generated by other programs. Both examples use the AQUASIM file created in section 3.2 which is also distributed with AQUASIM (as all the other tutorial examples also).
6.1 Execution of AQUASIM Jobs in Batch Mode

Problem
This problem demonstrates the use of AQUASIM in batch mode.

Part A: Execute the parameter estimation problem implemented in part A of section 3.2 in batch mode and look at the results in the parameter estimation file.

Part B: Execute a combined batch job that starts the parameter estimation as in part A, then restarts the parameter estimation twice (in order to check for convergence), then executes a sensitivity analysis and finally plots the concentrations and sensitivity functions to a PostScript file.
6.1. EXECUTION OF AQUASIM JOBS IN BATCH MODE

Solution

Part A

- **Execution of batch job**
  Type the command line
  \[ \text{aquasimb} \ -e \ \text{parest}_a.\log \ \text{parest}_a.\aqu \ \text{res}.\aqu \ \text{parest}_a.\fit \]

- **Looking at the results**
  Open the file \( \text{parest}_a.\fit \) (specified in the command line above) with a text editor. The same (and more detailed) results as shown interactively in Fig. 3.15 are given on this file.

Part B

- **Preparation of batch job**
  Create a file \( \text{parest}_a.\plt \) containing the two lines:
  \begin{verbatim}
  Conc parest_a.ps
  Sens parest_a.ps
  \end{verbatim}
  These are the specifications which plot is to write on which file (both plots are written to the PostScript file \( \text{parest}_a.\ps \)).
  Then create a file \( \text{parest}_a.\job \) containing the following lines:
  \begin{verbatim}
  -e parest_1.log parest_a.aqu res.aqu parest_1.fit
  -e parest_2.log res.aqu res.aqu parest_2.fit
  -e parest_3.log res.aqu res.aqu parest_3.fit
  -a parest_4.log res.aqu res.aqu
  -p parest_5.log res.aqu parest_a.plt
  \end{verbatim}
  This file defines the requested job.

- **Execution of batch job**
  Type the command line
  \[ \text{aquasimb} \ \text{parest}_a.\job \]

- **Looking at the results**
  The PostScript file \( \text{parest}_a.\ps \) contains now the two plots shown in Figs. 3.16 and 3.17. This file can be processed to a PostScript printer in a system-dependent way (ask your system administrator), or it can be viewed and printed with the shareware program GhostView. The results of the three parameter estimations can be viewed in the files \( \text{parest}_1.\fit, \text{parest}_2.\fit \) and \( \text{parest}_3.\fit \), and the progress of the AQUASIM tasks performed can be viewed in the log files \( \text{parest}_1.\log \) to \( \text{parest}_5.\log \).
6.2 Use AQUASIM with other programs

Problem
This problem demonstrates the use of AQUASIM as a tool for generating results prepared and postprocessed in external programs.

Part A: For the parameter estimation problem implemented in part A of section 3.2 generate a listing of $\chi^2$ values for a 60 x 60 values grid of the parameters $K$ and $r_{\text{max}}$ for the ranges of 0 to 5 mg/l and 0 to 2 mg/l/h, respectively. You can use the file `parest.a.par` containing the parameter values.

Part B: For the same parameter values as used in part A calculate the values of the substance concentration in the batch reactor at times 0, 3, 6, 9, 12 and 15 hours.
Solution

Part A

- **Execution of batch job**
  The file `parest.a.par` contains the names of the parameters followed by the list of 3600 combinations of parameter values. Type the command line
  \[ \text{aquasimb} -c \text{parest.a.log} \text{ parest.a.aqu} \text{ parest.a.par} \text{ parest.a.res} \]

- **Looking at the results**
  The file `parest.a.res` contains all parameter combinations given on the file `parest.a.par` together with the corresponding values for $\chi^2$. This file was used to generate Fig. 3.18 with the aid of a 3d plot program.

Part B

- **Preparation of batch job**
  Create a file `parest.a.def` containing the following lines:
  \[
  \begin{align*}
  &\text{C 0 Reactor 0 0 0 a} \\
  &\text{C 0 Reactor 0 3 0 a} \\
  &\text{C 0 Reactor 0 6 0 a} \\
  &\text{C 0 Reactor 0 9 0 a} \\
  &\text{C 0 Reactor 0 12 0 a} \\
  &\text{C 0 Reactor 0 15 0 a}
  \end{align*}
  \]
  The values in each line of this file correspond to variable name, calculation number, compartment, zone index, time, space coordinate and indicator for absolute coordinates.

- **Execution of batch job**
  Type the command line
  \[ \text{aquasimb} -r \text{parest.a.log} \text{ parest.a.aqu} \text{ parest.a.par} \text{ parest.a.def} \text{ parest.a.res} \]

- **Looking at the results**
  The file `parest.a.res` contains now all parameter combinations given on the file `parest.a.par` together with the requested values for the variable C.
CHAPTER 6. BATCH PROCESSING
Bibliography


